Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff
Author Message
Dawg
RavenNuke(tm) Development Team


Joined: Nov 07, 2003
Posts: 910

PostPosted: Thu Dec 11, 2008 10:08 am Reply with quote

Greetings All,

I have been building a MOD (I started on it last year but didn't finish it)

This is for displaying boat ads...

Here is what it "Should Do"
It calls the list of towns sorted by rank....it runs each town through another call for all the boats in that town and displays them 2 boats per row. (The 2 boats per row is the hard part)

When it hit a new town...it should drop to a new TR... and display all the boats from that town...2 per row.

I have it sorting the towns....and sorting the boats....I can display them...the problem is I can either get it to put 2 boats per row with no tr drop or all boats per row and it drops to a new tr with each town.

I am STUCK! 2 days I have messed with it. I have tried everything I can think of.

HELP!

HEre is what I have....



Thank You for your time. No need to write the code for me. Just explain what I am doing wrong...PLEASE!


..................I THINK I GOT IT!...............

Dawg


Last edited by Dawg on Thu Dec 11, 2008 3:17 pm; edited 1 time in total 
View user's profile Send private message
Palbin
Site Admin


Joined: Mar 30, 2006
Posts: 2583
Location: Pittsburgh, Pennsylvania

PostPosted: Thu Dec 11, 2008 1:49 pm Reply with quote

sql_num_rows should be $db->sql_numrows($sql, $dbi)
mysql_fetch_row should be $db->sql_fetchrow($sql, $dbi)
sql_fetch_row should be $dbi->sql_fetchrow($sql, $dbi)

For $content use $content =" xxxxxxx ";, take the <<<END and END stuff out.

I'm assuming the current way the script is written it prints in a strait line. To fix this do the following.

Remove the <TR> and </TR> from your outer table open and close tags.

add an echo "<TR><TD>"; at the beginning of your FOR LOOP and add an echo "</TD></TR>";

It appears to me that the second part of the text in the $content variable is floating outside of a cell (well in a cell, but not where it should be). I do not know exactly what this is supposed to look so I can't be sure. Just turn your borders on for the tables and see if it is layed out how you like.
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©