Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
blith
Client


Joined: Jul 18, 2003
Posts: 977

PostPosted: Wed Jul 09, 2008 9:03 am Reply with quote

After uploading all files and making core file edits I am getting the following:
Code:
NukeRepository(tm) ?.?.??: Error Loading Functions 

 

It appears that NukeRepository(tm) has not been configured correctly. The most common causes are:
1. you have an error in the syntax including includes/nukerepository.php
2. you have not added the NukeRepository(tm) code to your mainfile.php
3. You have not run the nsnnr.php installer
Details for including code are included in the download package in the Edits_For_Core_Files directory. 


I have changed the name of my admin file. Do I need to edit any file in Nuke Repository to account for that? Thank you.

Bob Marions forums are closed.
 
View user's profile Send private message Visit poster's website
blith
PostPosted: Wed Jul 09, 2008 1:46 pm Reply with quote

If a file has this line in it do I need to change the "admin" part to be the name of my admin.php file name, without the php of course?

Code:
if(empty($admin_file)) { $admin_file= "admin"; }
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Wed Jul 09, 2008 4:06 pm Reply with quote

No, $admin_file should already be defined in config.php and thus this code should work as intended

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
blith
PostPosted: Thu Jul 10, 2008 10:32 am Reply with quote

thank you, now I have to figure out why Nuke Repository won't work
 
blith
PostPosted: Thu Aug 28, 2008 3:34 pm Reply with quote

I still cannot get Nuke Repository to work same error:
Code:


It appears that NukeRepository(tm) has not been configured correctly. The most common causes are:
1. you have an error in the syntax including includes/nukerepository.php
2. you have not added the NukeRepository(tm) code to your mainfile.php
3. You have not run the nsnnr.php installer
Details for including code are included in the download package in the Edits_For_Core_Files directory.
 
blith
PostPosted: Fri Aug 29, 2008 2:51 pm Reply with quote

Please help. I have been looking at the includes/nukerepository and I cannot see what might be wrong:
Code:


global $nuke_config, $nr_config, $admin_file, $nrmodule;
define('NUKEREPOSITORY_IS_LOADED', true);
if(empty($admin_file)) { $admin_file= "admin"; }
$nrmodule = "Repository";
$nr_config = nrget_configs();

if(defined('FORUM_ADMIN')) {
  define('NRINCLUDE_PATH', '../../../');
} elseif(defined('INSIDE_MOD')) {
  define('NRINCLUDE_PATH', '../../');
} else {
  define('NRINCLUDE_PATH', './');
}

$nuke_config = $db->sql_fetchrow($db->sql_query("SELECT * FROM `".$prefix."_config`"));
if(!isset($lang)) { $lang = $nuke_config['language']; }
if(!stristr("$lang", ".") AND file_exists(NRINCLUDE_PATH."language/nukerepository/lang-$lang.php")) {
  @require_once(NRINCLUDE_PATH."language/nukerepository/lang-$lang.php");
} else {
  @require_once(NRINCLUDE_PATH."language/nukerepository/lang-english.php");
}

$next_clear = $nr_config['last_clear']+$nr_config['when_clear'];
$time_clear = time();
if($time_clear > $next_clear) {
  $dir_clear = @opendir($temp_dir);
  while($file = @readdir($dir_clear)) {
    if(($file != ".") && ($file != "..") && !stristr($file, "index.htm")) {
      if(@is_file($temp_dir."/".$file)) { @unlink($temp_dir."/".$file); }
    }
  }
  nrsave_config("last_clear", $time_clear);
}

function nrsave_config($config_name, $config_value){
    global $prefix, $db;
    $db->sql_query("UPDATE `".$prefix."_nsnnr_config` SET `config_value`='$config_value' WHERE `config_name`='$config_name'");
}

function nrget_configs(){
    global $prefix, $db;
    $configresult = $db->sql_query("SELECT `config_name`, `config_value` FROM `".$prefix."_nsnnr_config`");
    while(list($config_name, $config_value) = $db->sql_fetchrow($configresult)) {
        $config[$config_name] = $config_value;
    }
    return $config;
}

function nrfancysize($number) {
  if($number >= 1073741824) {
    $number = round((($number/1024)/1024)/1024, 1)." "._NR_GB;
  } elseif($number >= 1048576) {
    $number = round(($number/1024)/1024, 1)." "._NR_MB;
  } elseif($number >= 1024) {
    $number = round($number/1024, 1)." "._NR_KB;
  } else {
    $number = $number." "._NR_BYTES;
  }
  return $number;
}

function nrget_image($extension) {
  global $module_name;
  if(!file_exists("modules/$module_name/images/".$extension.".png")) {
    return "modules/$module_name/images/unknown.png";
  } else {
    return "modules/$module_name/images/".$extension.".png";
  }
}

function nrdirsize($directory) {
  $dir_read = opendir($directory);
  if(!isset($tsize)) { $tsize = 0; }
  while($Files = readdir($dir_read)) {
    $Filename = $directory."/".$Files;
    if(is_file($Filename)) { $tsize += filesize($Filename); }
    if(is_dir($Filename)) {
      if($Files != "." && $Files != "..") { $tsize += nrdirsize($Filename); }
    }
  }
  closedir($dir_read);
  return $tsize;
}

?>
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Fri Aug 29, 2008 2:59 pm Reply with quote

Could it be that it is not being 'included' corectly from mainfile.php?
Quickest way to debug this I think would be to turn error reporting on in config.php
 
View user's profile Send private message Send e-mail
blith
PostPosted: Fri Aug 29, 2008 3:21 pm Reply with quote

Guardian2003 wrote:
Could it be that it is not being 'included' corectly from mainfile.php?
Quickest way to debug this I think would be to turn error reporting on in config.php

I tried that and I see no errors anywhere
 
blith
PostPosted: Fri Aug 29, 2008 3:24 pm Reply with quote

ll I see in the title of the admin block is NukeRepository(tm) ?.?.??: Error Loading Functions

I have changed the core edits:
Code:


#
#-----[ OPEN ]------------------------------------------
#
mainfile.php

#
#-----[ FIND ]------------------------------------------
#
@require_once(INCLUDE_PATH."includes/sql_layer.php");

#
#-----[ AFTER ADD ]------------------------------------------
#
@require_once(INCLUDE_PATH."includes/nukerepository.php");


ran the installer... nothing.
 
Guardian2003
PostPosted: Fri Aug 29, 2008 4:04 pm Reply with quote

Hmm, that should be working depending on what INCLUDE_PATH is defined as.
You could temporarily remove the ampersands (@) as they will stop PHP from showing any errors there.
Ampersands are used in case there is an error generated that might reveal sensitive information but as you are trying to debug this, it is worth a shot (removing the ampersands and with error reorting on) - just don't forget to put them back.
At least we can then rule that one out.
 
blith
PostPosted: Tue Sep 02, 2008 11:15 am Reply with quote

No Joy, I removed the at symbol and turned error reporting true and I am not seeing any errors anywhere. Has anyone else installed this and got it to work?
 
Guardian2003
PostPosted: Tue Sep 02, 2008 3:14 pm Reply with quote

I installed an earlier version which I think was called Nuke Depository on an earlier version of RN and do not recall having any problems with it but I am using a dedicated CVS now so removed it quite a while ago.
Sorry I'm not much help with this one.
 
blith
PostPosted: Fri Sep 05, 2008 10:54 am Reply with quote

Yes, I could get Nuke Depository to work but I wanted to try Repository. If anyone else has an input Iwould appreciate it.
Thanks! Smile
 
Loki
Worker
Worker


Joined: Oct 05, 2003
Posts: 107
Location: Illinois

PostPosted: Sat Sep 06, 2008 10:59 am Reply with quote

Post the link to it and I will look at it.
 
View user's profile Send private message Visit poster's website
blith
PostPosted: Thu Sep 11, 2008 12:10 pm Reply with quote

It turns out there is a problem with the code. Posted at Bob marion's site by testy1:

"It seem to be a bug
Code:


Open: admin/modules/nukerepository.php

Find:

if(!$nw_config) { include("admin/modules/nukerepository/NRLoadError.php"); }

Replace With:

if(!$nr_config) { include("admin/modules/nukerepository/NRLoadError.php"); }

$nw_config should be $nr_config"
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©