Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
esttecb
Hangin' Around


Joined: Mar 14, 2007
Posts: 37

PostPosted: Sat May 10, 2008 1:54 pm Reply with quote

Hi everyone. I'm trying to make my site multi-language, I'm using spanish by default (in the admin settings, I've activated multi language options). When I select English in the block-Languages, only the index makes changes, url: www.mysite.com/index.php?newlang=english and if I go to some other module, it's still in spanish lang and if I return to index (mysite.com/index.php), it's returns to spanish lang.
I suppose the block-language should be change something in the cockie, and make english as default language for my user (or others), but it's not working...

I tried with the search in this forum, but nothing helpful appeared. (at least not with the same problem)

Thanks in advanced!.
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Sat May 10, 2008 2:52 pm Reply with quote

Are you logged in as the admin as well as your normal user account at the same time?
If you are logged in as the admin, nuke assumes that the site admin preferences for the sites language is 'your' language and doesn't take any notice of the language block.

If you go to Only registered users can see links on this board! Get registered or login! you can see the sites default language is English. If you select another language in the language block you can see it changes even in other modules (where translations are available).
 
View user's profile Send private message Send e-mail
esttecb
PostPosted: Sun May 11, 2008 9:36 pm Reply with quote

I tried that and I still have the same problem. I tried with Firefox as a normal user account (not logged as admin), and it's still changing the language to spanish...

Same problem:
Quote:
When I select English in the block-Languages, only the index makes changes, url: Only registered users can see links on this board! Get registered or login! and if I go to some other module, it's still in spanish lang and if I return to index (mysite.com/index.php), it's returns to spanish lang.


Crying or Very sad Crying or Very sad
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Mon May 12, 2008 5:24 am Reply with quote

Does sound like the "lang" cookie isn't getting set. I do believe that you must be a logged in user, though, to have that set??? (Sorry, don't deal much with multilingual sites so not 100% certain.)

You might want to check to see if the lang cookie is getting written. Also, try doing this being completely logged out as admin (but I've never had that stop this from working).

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©