Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
mds
Client


Joined: Dec 24, 2004
Posts: 194
Location: Michigan

PostPosted: Tue Apr 22, 2008 8:34 pm Reply with quote

not sure where to start ive looked threw the DB file in rn 2.20.01 looking for the fields as listed and the search returns nothing like these i have re-uploaded the files ..my DB appears to match that of the rncore file as far as the fields anyway...maybe i should delete and upload a fresh set ?

any help is appreciated

dblog info
Code:
April 16, 2008, 10:29 pm 1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')

            AND aa.group_id = ug.group_id
            AND aa.auth_mod = 1
         GROUP BY ug.us' at line 3
SQL was: SELECT ug.user_id, COUNT(auth_mod) AS is_auth_mod FROM nuke_bbauth_access aa, nuke_bbuser_group ug WHERE ug.user_id IN () AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_id
 remote addr: **.**.**.**
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Tue Apr 22, 2008 8:55 pm Reply with quote

Looks like something Fixgroup script should fix

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
mds
PostPosted: Tue Apr 22, 2008 9:08 pm Reply with quote

is this what your talking about ? Only registered users can see links on this board! Get registered or login!

else where might i be able to find that 1 Embarassed
 
mds
PostPosted: Tue Apr 22, 2008 9:20 pm Reply with quote

found this link Only registered users can see links on this board! Get registered or login!

however it gives me
Code:
You are trying to access a restricted area.


We are Sorry, but this section of our site is for Registered Users Only.

You can register for free by clicking here, then you can
access this section without restrictions. Thanks.

[ Go Back ]

didnt have time to register tonight
 
mds
PostPosted: Tue Apr 22, 2008 9:28 pm Reply with quote

also if this helps here is the error message from forum admin panel when i try to update a users permission from not modertor to is moderator

Code:
Could not obtain moderator status


DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.us' at line 3

SELECT ug.user_id, COUNT(auth_mod) AS is_auth_mod FROM nuke_bbauth_access aa, nuke_bbuser_group ug WHERE ug.user_id IN () AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_id

Line : 559
File : admin_ug_auth.php
 
mds
PostPosted: Tue Apr 22, 2008 9:32 pm Reply with quote

ok so i tried ravens download for admin_ug_auth.php from the above link and it now shows so i am switching back to the original file

Code:
Couldn't update private forum permissions


DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 0, 0, 0, 0, 0, 0, 0, 0, 0, 1)' at line 2

INSERT INTO nuke_bbauth_access (forum_id, group_id, auth_view, auth_read, auth_post, auth_reply, auth_edit, auth_delete, auth_sticky, auth_vote, auth_pollcreate, auth_mod) VALUES (31, , 0, 0, 0, 0, 0, 0, 0, 0, 0, 1)

Line : 385
File : admin_ug_auth.php
 
sting
Involved
Involved


Joined: Sep 23, 2003
Posts: 456
Location: Somewhere out there...

PostPosted: Wed Apr 23, 2008 9:06 am Reply with quote

mds wrote:
not sure where to start ive looked threw the DB file in rn 2.20.01 looking for the fields as listed and the search returns nothing like these i have re-uploaded the files ..my DB appears to match that of the rncore file as far as the fields anyway...maybe i should delete and upload a fresh set ?

any help is appreciated

dblog info
Code:
April 16, 2008, 10:29 pm 1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')

            AND aa.group_id = ug.group_id
            AND aa.auth_mod = 1
         GROUP BY ug.us' at line 3
SQL was: SELECT ug.user_id, COUNT(auth_mod) AS is_auth_mod FROM nuke_bbauth_access aa, nuke_bbuser_group ug WHERE ug.user_id IN () AND aa.group_id = ug.group_id AND aa.auth_mod = 1 GROUP BY ug.user_id
 remote addr: **.**.**.**



Just a note - in your original code you have a close single quote without an open on the GROUP BY - is this in the original code, or just part of the output error?

Code:
AND aa.group_id = ug.group_id 

            AND aa.auth_mod = 1
         GROUP BY ug.us' <------------ (this one)     at line 3



-sting

_________________
You see - I told you I wasn't paranoid. They were really out to get me. 
View user's profile Send private message Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
mds
PostPosted: Wed Apr 23, 2008 7:55 pm Reply with quote

this is wierd i see nothing in the admin_ug_auth file that contains "GROUP BY ug.us" at all... its all like this
this is at approx line 472ish(copied pasted into the code box below)
theres another "GROUP BY" at line 487ish and 496ish ,and 505, and 451
looks like maybe the error script may have stopped writing to the dblog file maybe resulting in the single quote ? i dont see it in the code and thats a copy and paste from the dblog file which logs the error

Code:


WHERE ug.group_id = aa.group_id
                                AND u.user_id = ug.user_id
            AND ug.user_pending = 0
            AND u.user_level NOT IN (" . MOD . ", " . ADMIN . ")
                        GROUP BY u.user_id
                        HAVING SUM(aa.auth_mod) > 0";
                if ( !($result = $db->sql_query($sql)) )
 
mds
PostPosted: Wed Apr 23, 2008 8:19 pm Reply with quote

also not sure if this is related but i have a new user well about 2 weeks ago and since i have noticed the member is showing up in the moderator list of ALL forums...i have changed his permissions back to user only several times and now again tonight the member is back on the moderator list of all forums even the ones marked hidden and private..... Evil or Very Mad
 
sting
PostPosted: Thu Apr 24, 2008 1:18 pm Reply with quote

mds wrote:
also not sure if this is related but i have a new user well about 2 weeks ago and since i have noticed the member is showing up in the moderator list of ALL forums...i have changed his permissions back to user only several times and now again tonight the member is back on the moderator list of all forums even the ones marked hidden and private..... Evil or Very Mad


Sounds like you may have an issue there. . . I would certainly disable/delete to see if the user comes back . .
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Thu Apr 24, 2008 4:42 pm Reply with quote

I had this exact same issue myself (new users getting Mod status) but it was several years ago whilst doing a nuke upgrade.
It was that long ago I simply cannot remember how I fixed it (possibly the fix group script posted earlier) but suffice to say it isn't an issue specific to RavenNuke.

Was this a clean install or an upgrade/migration?
 
View user's profile Send private message Send e-mail
CodyG
Life Cycles Becoming CPU Cycles


Joined: Jan 02, 2003
Posts: 712
Location: Vancouver Island

PostPosted: Fri Apr 25, 2008 8:49 am Reply with quote

hmm... I have had the same issue and likely in RN ..
I had to assume i hadn't set forums group stuff correctly (lack of moderator?). So, the registered user was accessing the forums usergroups aup. And, since there wasn't already a moderator, the system helped itself and gave the first registered user brand new moderator status.

I removed the registered user from the group and they didn't come back.

I've also had issues when setting moderator... silly phpbb, it's been years and still, I'm knocking my head against the desk every time I need to manage forums groups.

_________________
"We want to see if life is ubiquitous." D.Goldin 
View user's profile Send private message
mds
PostPosted: Fri Apr 25, 2008 7:36 pm Reply with quote

sting wrote:
mds wrote:
also not sure if this is related but i have a new user well about 2 weeks ago and since i have noticed the member is showing up in the moderator list of ALL forums...i have changed his permissions back to user only several times and now again tonight the member is back on the moderator list of all forums even the ones marked hidden and private..... Evil or Very Mad


Sounds like you may have an issue there. . . I would certainly disable/delete to see if the user comes back . .


the user is relevant to the site has posted and stuff i have checked his page views via sentinal and nothing looks odd about the pages he views

Quote:
Guardian2003
Was this a clean install or an upgrade/migration?


this is an upgrade from 2.10.01

im starting to wonder if theres another file somewhere other than the admin ug auth file where the issue lies...i renamed my whole module/forum folder to backup and downloaded and unzipped a fresh new copy of rn22001 and uploaded the whole forum folder again and still get the same thing......
 
mds
PostPosted: Mon Apr 28, 2008 6:03 pm Reply with quote

any updates or thoughts on this ?
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Tue Apr 29, 2008 5:22 am Reply with quote

mds, I have re-read the entire thread and I do not see anywhere where you state that you in fact ran the fix-group script that Evaders referenced here:

evaders99 wrote:
Looks like something Fixgroup script should fix


Would you please let us know if you had tried that yet? Thanks.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
CodyG
PostPosted: Tue Apr 29, 2008 10:04 am Reply with quote

I don't think I'd want to replace my current admin_ug_auth.php with the version I found here. I did a compare and, I'm no expert, but seems to me my current version is way more evolved.

not sure what's on the nukefixes site
 
mds
PostPosted: Tue Apr 29, 2008 6:51 pm Reply with quote

I posted 2 links in response to the fix group script and got no reply. i did try the 1 in the downloads(which is a file not a script) here and posted the results but other than that where do i find the 1 he is specifically talking about ? i figured there would be something here in downloads and this is what i tried and posted the results other than that i didnt find any other info about a "groups fix script" except to a link in a post dated back to 2006 so i highly doubt that is it.... i would be more than happy to try it IF i knew better what im looking for or responses to questions of weather or not this file was the mentioned "fix" i posted 2 links actually and there was no follow up so i still have no idea if thats what he was talking about...
Thanks
mds wrote:
is this what your talking about ? Only registered users can see links on this board! Get registered or login!

else where might i be able to find that 1 Embarassed
 
mds
PostPosted: Tue Apr 29, 2008 6:52 pm Reply with quote

CodyG wrote:
I don't think I'd want to replace my current admin_ug_auth.php with the version I found here. I did a compare and, I'm no expert, but seems to me my current version is way more evolved.

not sure what's on the nukefixes site


i did replace it with the one from here but i did switch it back from the current version..
 
mds
PostPosted: Tue Apr 29, 2008 8:45 pm Reply with quote

Never mind i just found it
 
CodyG
PostPosted: Tue Apr 29, 2008 8:58 pm Reply with quote

found a different fix file? found a way to get rid of the spurious moderator?
inquiring minds want to know. Smile
 
mds
PostPosted: Tue Apr 29, 2008 9:07 pm Reply with quote

Ok i found the fix group script here Only registered users can see links on this board! Get registered or login!
which is as follows
Code:
After applying the above new users should get a group assigned to them but users that had registered before might now have one, to correct this save the following to a file, name it fixgroup.php upload it to your Forum's folder and point your browser to: 

http://your_site.com/modules.php?name=Forums&file=fixgroup

Delete the file once done.

php:

<?php
//*****  check users and user groups ****//
if (!eregi("modules.php", $PHP_SELF)) {
    die ("You can't access this file directly...");
}
if ($popup != "1"){
    $module_name = basename(dirname(__FILE__));
    require("modules/".$module_name."/nukebb.php");
}
else
{
    $phpbb_root_path = 'modules/Forums/';
}

define('IN_PHPBB', true);
include($phpbb_root_path . 'extension.inc');
include($phpbb_root_path . 'common.'.$phpEx);
include('includes/functions_search.'.$phpEx);

// Start session management
$userdata = session_pagestart($user_ip, PAGE_SEARCH, $nukeuser);
init_userprefs($userdata);
// End session management

$sql = "SELECT user_id, username
    FROM " . USERS_TABLE ."
    WHERE user_id > 0";
if ( !($result = $db->sql_query($sql)) )
{
    message_die(GENERAL_ERROR, 'Could not obtain user list', '', __LINE__, __FILE__, $sql);
}

$liste ='';
while ( $row = $db->sql_fetchrow($result) )
{
   $username = $row['username'];
   $user_id = $row['user_id'];
   $usergroup = '';
     
   $sql1 = "SELECT ug.group_id
          FROM " . USER_GROUP_TABLE ." ug, ". GROUPS_TABLE. " g   
          WHERE ug.user_id = $user_id
            AND ug.group_id = g.group_id
            AND g.group_single_user  = 1
            ";
               
   if ( ($result1 = $db->sql_query($sql1)) )
   {
       $row1 = $db->sql_fetchrow($result1);
          $usergroup =( ( $row1['group_id'] != '' ) ? $row1['group_id'] : 'User has no user group'.$row1 );
           
   }

          if (!($row1['group_id'] != ''))
          {
               
         $sql2 = "SELECT MAX(group_id) AS total
            FROM " . GROUPS_TABLE;
         if ( !($result2 = $db->sql_query($sql2)) )
         {
            message_die(GENERAL_ERROR, 'Could not obtain next group_id information', '', __LINE__, __FILE__, $sq2l);
         }

         if ( !($row2 = $db->sql_fetchrow($result2)) )
         {
            message_die(GENERAL_ERROR, 'Could not obtain next group_id information', '', __LINE__, __FILE__, $sql2);
         }
         $group_id = $row2['total'] + 1;
           
           
         $sql3 = "INSERT INTO " . GROUPS_TABLE . " (group_id, group_name, group_description, group_single_user, group_moderator)
            VALUES ($group_id, '', 'Personal User', 1, 0)";
         if ( !($result3 = $db->sql_query($sql3, BEGIN_TRANSACTION)) )
         {
            message_die(GENERAL_ERROR, 'Could not insert data into groups table', '', __LINE__, __FILE__, $sql3);
         }

         $sql4 = "INSERT INTO " . USER_GROUP_TABLE . " (user_id, group_id, user_pending)
            VALUES ($user_id, $group_id, 0)";
         if( !($result4 = $db->sql_query($sql4, END_TRANSACTION)) )
         {
            message_die(GENERAL_ERROR, 'Could not insert data into user_group table', '', __LINE__, __FILE__, $sql4);
         }

               
             $usergroup = $usergroup.', adding user group '.$group_id;
          }


   $liste .= ( ( $liste != '' ) ? '<br> ' : '' ) . $username.' <b>'.$usergroup.'</b>';
}

message_die(GENERAL_MESSAGE,'Users:<br>'.$liste);

?>

 
mds
PostPosted: Tue Apr 29, 2008 9:14 pm Reply with quote

i did this with the exception to the " After applying the above" which are these edits to the Your Account module in other words i have NOT made these edits which brings me to the question of will i need to ?

i have run the script and made some permission changes and do not get the error message anymore , should i be good at this point with just running the fix script or do i still need to do the Your Account edits ?
Code:
Users don't get a group assigned to them when they register via the Your_Account module: 


File: modules/Your_Account/index.php
find:
Code:
function activate($username, $check_num) {
    global $db, $user_prefix, $module_name, $language;

change to:
Code:
function activate($username, $check_num) {
    global $db, $user_prefix, $module_name, $language, $prefix;

find:
Code:
       $db->sql_query("INSERT INTO ".$user_prefix."_users (user_id, username, user_email, user_password, user_avatar, user_avatar_type, user_regdate, user_lang) VALUES (NULL, '$row[username]', '$row[user_email]', '$user_password', 'gallery/blank.gif', '3', '$row[user_regdate]', '$language')");

after add:
Code:
       $result2 = $db->sql_query("SELECT user_id FROM ".$user_prefix."_users WHERE username='$row[username]'");
       $row2 = $db->sql_fetchrow($result2);
       $guserid = intval($row2[user_id]);
       $db->sql_query("INSERT INTO ".$prefix."_bbgroups (group_name, group_description, group_single_user, group_moderator) VALUES ('', 'Personal User', '1', '0')");
       $group_id = $db->sql_nextid();
       $db->sql_query("INSERT INTO ".$prefix."_bbuser_group (user_id, group_id, user_pending) VALUES ('$guserid', '$group_id', '0')");
 
mds
PostPosted: Tue Apr 29, 2008 9:38 pm Reply with quote

still haveing issues...allthought it says "user permissions have been updated" on some they actually havnt...i somehow now have some as moderators that weren't before or atleast not shown as mods nor have i ever made them moderators either and there permissions won't update from is moderator to not moderator...and as for my troubled user still popping up as moderator of ALL forums is still happening and he isnt even shown online or as visting the site as of tonight per nuke sentinal tracked users list
 
mds
PostPosted: Tue Apr 29, 2008 9:57 pm Reply with quote

the user that wouldnt update from is mod to not mod i found out after looking at the users info from the forum admin and from the rn admin user admin there was no other info for this person it was somehow just a username there was no email or any other info for this person so i deleted them....and wahla the permissions for this person was changed he he he Smile

still have the issue with the other user getting mod status to AlL forums
it just dawned on me and i verified that every time i change my permissions to is moderator even tho i am admin and have the god account its changeing the new users permissions as well......i changed his permissions to not moderator in all forums and both mine and his names disappear as moderators......i go to my user name change my permissions to is moderator and his name auto pops up next to mine .......theres the issue and why it looks like the new user is doing it....but why is it doing it and how do i fix it ??
 
montego
PostPosted: Wed Apr 30, 2008 5:53 am Reply with quote

Evaders... can you please shed some lite on this given the above oh phpBB Swami. Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©