Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
esttecb
Hangin' Around


Joined: Mar 14, 2007
Posts: 37

PostPosted: Tue Apr 15, 2008 10:20 am Reply with quote

An user in my site is getting a message like ''invalid session'' when he try to create a new topic.
I truncate (empty) some tables: _bbsessions, _bbsessions_keys and _sessions. It's right what I did?

I'm not sure if it's ok clean the bbsessions_keys...

PS: yes, I changed the domain cockie name but nothing... and to seem it's only happen with one (maybe more) user (he deleted the cache and cockies, the problem still happening), he's commenting his problem using the ShoutBox...

Somebody can help me? Thanks in advanced
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Tue Apr 15, 2008 12:37 pm Reply with quote

Please link us to your site and let us know what your cookie settings are set to.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
esttecb
PostPosted: Tue Apr 15, 2008 2:03 pm Reply with quote

omg!!, I'm open this topic in the wrong section, I'm using RN 2.20.01...
My cockie setting in the forum cp is:

(I remplace my real domain to mysite.org, it's the samething for the example)

Cookie domain: mysite.org
Cookie name: mysiteorg
path: /
[https] : Disabled
Session [seconds] : 3600

I'm using the CNBYA 4.4.2 (original version, not modified by fade2gray), It's setting to:

the cookie path field is empty (it's as default)
cookie check: disabled
cookie cleaner: able
cookie period: 1 month
pageview inactivity: undefined

Maybe, is the CNBYA 4.4.2 generating the problem?
If I pruning the bbsessions_keys data base table? All will be right? or this will to generate some or error?
I pruned: bbsessions_keys, bbsessions and sessions tables, btw
I know it's ok if I pruned bbsessions and sessions, but I'm not very sure about the sessions_key function... someone can clear my doubt?

Thanks in advanced
 
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Tue Apr 15, 2008 2:36 pm Reply with quote

NP moved. Wink
 
View user's profile Send private message
nunopiri
New Member
New Member


Joined: Jul 20, 2007
Posts: 2

PostPosted: Tue Apr 15, 2008 8:07 pm Reply with quote

This hapened with at least two users on my site too when trying to post on forums.

Both users are unable to post using firefox 2.0.0.13 one is on mac and another on windows XP.

I told them to delete Cookies and cache and no luck then i cleared _bbsessions and _session and didn't work too.

After I changed cookies settings on the site to mysite.org and it didn't work either.

my site: Only registered users can see links on this board! Get registered or login!

cookie domain xupakabra.com
cookie name: phpbb2mysql2
cookie path /
cookie secure: disabled
session lenght: 3600

I'm using firefox 2.0.0.13 and it doesn't happen to me. One of the users tryed to post using internet explorer with success. when I tryed to change the cookies to mysite.org he was unable to post with both browsers.

bbtonuke version was updated to 2.0.23 when it was released.
 
View user's profile Send private message
esttecb
PostPosted: Thu May 22, 2008 1:35 pm Reply with quote

nunopiri wrote:

my site: Only registered users can see links on this board! Get registered or login!

cookie domain xupakabra.com
cookie name: phpbb2mysql2
cookie path /
cookie secure: disabled
session lenght: 3600


nunopiri, your domain name is wrong, it's the most important setting. your coockie name should be "xupakabra" (without the quotes "")

----------------------------------

ok, I'm trying with this settings, and it's working fine...

Secure cookie should be off

Your site is on the root of a domain
Example URL: Only registered users can see links on this board! Get registered or login! / Only registered users can see links on this board! Get registered or login!

Cookie domain: .mysite.com (Note the period before the name)
Cookie name: mysite (The cookie name MUST match exactly your domain without the suffix)
Cookie path: /

try with this settings and let me know how it's works in your site...
 
nunopiri
PostPosted: Mon May 26, 2008 11:23 am Reply with quote

You explained it very well esttecb, i changed the settings and worked for me. If I have any more problem I give some feedback, thank you.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©