Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues
Author Message
themadhacker
Worker
Worker


Joined: May 30, 2006
Posts: 100

PostPosted: Wed Apr 09, 2008 2:43 pm Reply with quote

Is there a mod that will work with 2.20.xx forums to Ignore User?

As I have said before, I am a long time nuker and never really thought about this. But the other day I was contacted by a member about this. And it would be a nice feature.

Kinda surprised that it doesnt come as standard issue.

Any link to a working mod or addon is appreciated.

Smile
 
View user's profile Send private message
bprsk8r4272
Regular
Regular


Joined: Jan 23, 2007
Posts: 96
Location: Rochester, Ny

PostPosted: Wed Apr 09, 2008 6:18 pm Reply with quote

you can try this Only registered users can see links on this board! Get registered or login!
but make sure you make backups first

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
themadhacker
PostPosted: Wed Apr 09, 2008 7:18 pm Reply with quote

bprsk8r4272 wrote:
you can try this Only registered users can see links on this board! Get registered or login!
but make sure you make backups first


Thanks for the link...but I was hoping that someone would have some information on something that they are currently using and is known to work for sure.

I have followed your link and made the download just in case there is not much action on this topic.

Thanks again.
 
themadhacker
PostPosted: Wed Apr 09, 2008 8:47 pm Reply with quote

After looking thru the above mentioned mod it seems like it could work...but there are a few differences that I am not sure how to convert because the lines to look for and change in a couple of instances are totally different.

Hopefully someone already has one ported over to phpNuke. Ive only had limited success with porting stand alone phpBB stuff over to nuke.

If anyone knows how to incorp this....maybe I can get the rest...or most of it.

It asks to find this line

Code:


#
#-----[ OPEN ]------------------------------------------
#
templates/subSilver/overall_header.tpl

#
#-----[ FIND ]------------------------------------------
#
                  <td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>

#
#-----[ REPLACE WITH ]------------------------------------------
#
                  <td height="25" align="center" valign="top" nowrap="nowrap"><span class="mainmenu">&nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;
                  <!-- BEGIN switch_user_logged_in -->
                  <a href="{U_IGNORE_HEADER}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_ignore.gif" width="12" height="13" border="0" alt="{L_IGNORE_HEADER}" hspace="3" />{L_IGNORE_HEADER}</a>&nbsp; &nbsp;
                  <!-- END switch_user_logged_in -->
                  <a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</span></td>


But RN code is "I think" this...

Code:


                   <a href="{U_PROFILE}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>   <a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>   <a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a> </center></span></td>


Thanks!
 
Paul_K
Hangin' Around


Joined: Feb 22, 2004
Posts: 40
Location: Dorset, England

PostPosted: Thu Apr 10, 2008 2:24 am Reply with quote

Hi,

That shouldn't be a problem, all they are getting you to do really is add a button into the header of the forum. I'd pick where you wanted it to show and then stick the extra code in. This is the bit they want you to add...

Code:
                  <!-- BEGIN switch_user_logged_in -->

                  <a href="{U_IGNORE_HEADER}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_ignore.gif" width="12" height="13" border="0" alt="{L_IGNORE_HEADER}" hspace="3" />{L_IGNORE_HEADER}</a>&nbsp; &nbsp;
                  <!-- END switch_user_logged_in -->
                 


I'm not sure where you got your RN code as mine is different! Are you using the file from your theme? i.e. /themes/theme_name/forums/ If I look in there I can see at the bottom of the file...

Code:
<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu"><center>&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;<a href="{U_SEARCH}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp;

                  &nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</center></span></td>


This is the code that sets up the buttons at the top of the forums (FAQ, Search, Usergroups etc) So I'd put it next to the FAQ button like so...

Code:
<td align="center" valign="top" nowrap="nowrap"><span class="mainmenu"><center>&nbsp;<a href="{U_FAQ}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_faq.gif" width="12" height="13" border="0" alt="{L_FAQ}" hspace="3" />{L_FAQ}</a>&nbsp; &nbsp;

<!-- BEGIN switch_user_logged_in -->
<a href="{U_IGNORE_HEADER}" class="mainmenu"><img src="templates/subSilver/images/icon_mini_ignore.gif" width="12" height="13" border="0" alt="{L_IGNORE_HEADER}" hspace="3" />{L_IGNORE_HEADER}</a>&nbsp; &nbsp;
<!-- END switch_user_logged_in -->
<a href="{U_SEARCH}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_search.gif" width="12" height="13" border="0" alt="{L_SEARCH}" hspace="3" />{L_SEARCH}</a>&nbsp; &nbsp;<a href="{U_GROUP_CP}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_groups.gif" width="12" height="13" border="0" alt="{L_USERGROUPS}" hspace="3" />{L_USERGROUPS}</a>&nbsp;
                  &nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="themes/DiveTheme2/forums/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</center></span></td>


Your going to need to edit the image path to match your theme setup though... That should be it, I haven't modified any Nuke forums for a long time though!
 
View user's profile Send private message Yahoo Messenger MSN Messenger ICQ Number
themadhacker
PostPosted: Thu Apr 10, 2008 6:22 am Reply with quote

Paul_K,

Thanks for your input. I will give it a go when I get home from work tonight.

I pulled the code from my file. It is standard with no edits. I am running RN 2.20.01. And I was guessing that was the place to edit...only because of part of the path mentioned to edit was in that line.

I am aware of changing the path. Already had to do so on a couple of the other files. This was basically the only file that didnt match everything BUT the image path.

Also....this mod of course doesnt create a "nuke_something_something". db table. But rather just a "something_something". Will this make a difference? Or should I create the table with the nuke_ prefix and then scour the code and change the pointers?

Thanks
 
Paul_K
PostPosted: Thu Apr 10, 2008 9:03 am Reply with quote

Hi,

From what I can remember (again, it was a while ago) any table created by running scripts inside nuke should get the nuke_ prefix automatically. Remember to modify the overall_header.tpl in every theme your site uses. Good luck
 
bprsk8r4272
PostPosted: Thu Apr 10, 2008 11:03 am Reply with quote

themadhacker wrote:
Hopefully someone already has one ported over to phpNuke. Ive only had limited success with porting stand alone phpBB stuff over to nuke.


im going to install it later and see how it works then i'll port it.
 
themadhacker
PostPosted: Thu Apr 10, 2008 12:20 pm Reply with quote

bprsk8r4272 wrote:
themadhacker wrote:
Hopefully someone already has one ported over to phpNuke. Ive only had limited success with porting stand alone phpBB stuff over to nuke.


im going to install it later and see how it works then i'll port it.


I'll be awaiting your reports.

Thanks!
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Thu Apr 10, 2008 3:28 pm Reply with quote

Quote:

From what I can remember (again, it was a while ago) any table created by running scripts inside nuke should get the nuke_ prefix automatically.


Actually no. There is nothing special about the queries that phpNuke does, your script must attach the $prefix value if you want it to be used.

phpBB itself uses TABLE_CONSTANTS so that you can edit includes/constants.php for them. If your mod uses this, then it is relatively easy to change or set whatever table name you want.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
bprsk8r4272
PostPosted: Thu Apr 10, 2008 3:30 pm Reply with quote

almost done porting it i just have to make a few edits in the install text and test it a few more times after that and its done i'll update this post when im fully done

*alright here you go Only registered users can see links on this board! Get registered or login! if theres any problems with it post in that topic


Last edited by bprsk8r4272 on Thu Apr 10, 2008 4:58 pm; edited 1 time in total 
Paul_K
PostPosted: Thu Apr 10, 2008 3:49 pm Reply with quote

I stand corrected Smile

evaders99 wrote:


Actually no. There is nothing special about the queries that phpNuke does, your script must attach the $prefix value if you want it to be used.

phpBB itself uses TABLE_CONSTANTS so that you can edit includes/constants.php for them. If your mod uses this, then it is relatively easy to change or set whatever table name you want.
 
themadhacker
PostPosted: Thu Apr 10, 2008 4:06 pm Reply with quote

bprsk8r4272 wrote:
almost done porting it i just have to make a few edits in the install text and test it a few more times after that and its done i'll update this post when im fully done


Thank You! Smile

I'll actually be glad to be able to compare my code edits to yours to see how much I actually did right! LOL
 
themadhacker
PostPosted: Thu Apr 10, 2008 4:14 pm Reply with quote

evaders99 wrote:
Quote:

From what I can remember (again, it was a while ago) any table created by running scripts inside nuke should get the nuke_ prefix automatically.


Actually no. There is nothing special about the queries that phpNuke does, your script must attach the $prefix value if you want it to be used.

phpBB itself uses TABLE_CONSTANTS so that you can edit includes/constants.php for them. If your mod uses this, then it is relatively easy to change or set whatever table name you want.


Just to make sure I am understanding you....you could append this...

Code:


// Table names
define('CONFIRM_TABLE', $prefix.'_bbconfirm');
define('AUTH_ACCESS_TABLE', $prefix.'_bbauth_access');
define('BANLIST_TABLE', $prefix.'_bbbanlist');
define('CATEGORIES_TABLE', $prefix.'_bbcategories');
define('CONFIG_TABLE', $prefix.'_bbconfig');
define('DISALLOW_TABLE', $prefix.'_bbdisallow');
define('FORUMS_TABLE', $prefix.'_bbforums');
define('GROUPS_TABLE', $prefix.'_bbgroups');
define('POSTS_TABLE', $prefix.'_bbposts');
define('POSTS_TEXT_TABLE', $prefix.'_bbposts_text');
define('PRIVMSGS_TABLE', $prefix.'_bbprivmsgs');
define('PRIVMSGS_TEXT_TABLE', $prefix.'_bbprivmsgs_text');
define('PRIVMSGS_IGNORE_TABLE', $prefix.'_bbprivmsgs_ignore');
define('PRUNE_TABLE', $prefix.'_bbforum_prune');
define('RANKS_TABLE', $prefix.'_bbranks');
define('SEARCH_TABLE', $prefix.'_bbsearch_results');
define('SEARCH_WORD_TABLE', $prefix.'_bbsearch_wordlist');
define('SEARCH_MATCH_TABLE', $prefix.'_bbsearch_wordmatch');
define('SESSIONS_TABLE', $prefix.'_bbsessions');
define('SESSIONS_KEYS_TABLE', $prefix.'_bbsessions_keys');
define('SMILIES_TABLE', $prefix.'_bbsmilies');
define('THEMES_TABLE', $prefix.'_bbthemes');
define('THEMES_NAME_TABLE', $prefix.'_bbthemes_name');
define('TOPICS_TABLE', $prefix.'_bbtopics');
define('TOPICS_WATCH_TABLE', $prefix.'_bbtopics_watch');
define('USER_GROUP_TABLE', $prefix.'_bbuser_group');
define('USERS_TABLE', $user_prefix.'_users');
define('WORDS_TABLE', $prefix.'_bbwords');
define('VOTE_DESC_TABLE', $prefix.'_bbvote_desc');
define('VOTE_RESULTS_TABLE', $prefix.'_bbvote_results');
define('VOTE_USERS_TABLE', $prefix.'_bbvote_voters');


with something like this

Code:


define('SOMETHING_SOMETHING_TABLE, $prefix.'_something_something');
 
bprsk8r4272
PostPosted: Thu Apr 10, 2008 5:01 pm Reply with quote

updated that post

and it would be something like this
define('IGNORE_TABLE', $prefix.'_bbignore_user'); for this mod
 
themadhacker
PostPosted: Thu Apr 10, 2008 6:27 pm Reply with quote

bprsk8r4272 wrote:
updated that post

and it would be something like this
define('IGNORE_TABLE', $prefix.'_bbignore_user'); for this mod


Thanks.....

wife and I are AIdol fans...so will work on it after the show and report back.

Smile
 
themadhacker
PostPosted: Thu Apr 10, 2008 7:17 pm Reply with quote

downloaded...but will take me a while to check and edit my own files. I dont use DeepBlue....but rather Karate.

So it may be tomorrow before I can install it....but thanks again and I will definately let you know when Im done.

Smile
 
themadhacker
PostPosted: Thu Apr 10, 2008 7:38 pm Reply with quote

BTW....since DeepBlue theme has its own forum folder and I use Karate. Should I just do it all over based on what you did but to the subSilver files?

I missed the part above where you asked about if I was using the theme one and it was a total brainfart on my part. I thought that all of the forums files were in the Forums module.

I think I will go ahead and edit the DeepBlue just to see how it works...but I already have customized my Karate theme and all users forced to view my default theme without the ability to change it. So making it work for Karate will be something I need to do.

Thanks again
 
bprsk8r4272
PostPosted: Thu Apr 10, 2008 8:06 pm Reply with quote

k since karate doesnt have a forum set it uses the default subSilver so instead of doing the edits to themes/DeepBlue/forums do them to modules/Forums/templates/subSilver
 
themadhacker
PostPosted: Fri Apr 11, 2008 7:35 am Reply with quote

bprsk8r4272 wrote:
k since karate doesnt have a forum set it uses the default subSilver so instead of doing the edits to themes/DeepBlue/forums do them to modules/Forums/templates/subSilver


Yes...that is what I was doing when I posted the code a few posts above. Because the subSilver file isnt like what the code that it says to FIND and REPLACE with.

I will work on it more tonight when I get home from work and report back.
 
bprsk8r4272
PostPosted: Fri Apr 11, 2008 1:24 pm Reply with quote

open:
modules/Forums/templates/subSilver/overall_header.tpl

find:
Code:
                  &nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; &nbsp;<a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>&nbsp; &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</center></span></td>


replace with:
Code:
                  &nbsp;<a href="{U_PROFILE}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_profile.gif" width="12" height="13" border="0" alt="{L_PROFILE}" hspace="3" />{L_PROFILE}</a>&nbsp; 

                  <!-- BEGIN switch_user_logged_in -->
                  &nbsp;<a href="{U_IGNORE_HEADER}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_ignore.gif" width="12" height="13" border="0" alt="{L_IGNORE_HEADER}" hspace="3" />{L_IGNORE_HEADER}</a>&nbsp;
                  <!-- END switch_user_logged_in -->
                  &nbsp;<a href="{U_PRIVATEMSGS}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_message.gif" width="12" height="13" border="0" alt="{PRIVATE_MESSAGE_INFO}" hspace="3" />{PRIVATE_MESSAGE_INFO}</a>&nbsp;
                  &nbsp;<a href="{U_LOGIN_LOGOUT}" class="mainmenu"><img src="modules/Forums/templates/subSilver/images/icon_mini_login.gif" width="12" height="13" border="0" alt="{L_LOGIN_LOGOUT}" hspace="3" />{L_LOGIN_LOGOUT}</a>&nbsp;</center></span></td>
 
themadhacker
PostPosted: Thu May 15, 2008 7:38 am Reply with quote

Just wanted to post back in this thread that right after my last post I had some unexpected things come up that had me put this on my backburner for several weeks.

I now am free'd up and will get back on this with trying to make it work with Karate.

But I have to ask this. Did you port this to Deep Blue because that is what you use? Or is Deep Blue preferred for some other reason?
 
bprsk8r4272
PostPosted: Thu May 15, 2008 8:27 am Reply with quote

DeepBlue is the default theme so thats why i used it and all ported mods use it too.
 
themadhacker
PostPosted: Thu May 22, 2008 11:12 am Reply with quote

Gotcha.....Thanks!

Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> RN v2.20.00 - All Issues

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©