Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff
Author Message
icewolf
Hangin' Around


Joined: Jul 10, 2006
Posts: 32

PostPosted: Fri Sep 07, 2007 11:40 pm Reply with quote

Hello, I recently re-installed my website and when I try to browse the forums I get this error:

Code:
phpBB : Critical Error 


Error doing DB query userdata row fetch

DEBUG MODE

SQL Error : 1146 Table 'z7rsq3_******.SESSIONS_KEYS_TABLE' doesn't exist

SELECT u.* FROM nuke_users u, SESSIONS_KEYS_TABLE k WHERE u.user_id = 2 AND u.user_active = 1 AND k.user_id = u.user_id AND k.key_id = 'b4cc92640322fc12ac6f5251dc34efa7'

Line : 89
File : sessions.php


I need some help please, if you guys can help me out with this.
Thank you in advance.


Last edited by icewolf on Sat Sep 08, 2007 9:53 am; edited 1 time in total 
View user's profile Send private message
utssace
Worker
Worker


Joined: Feb 18, 2006
Posts: 155
Location: Virginia

PostPosted: Sat Sep 08, 2007 7:16 am Reply with quote

Were you reinstalling a previously working site with backed up site files & database or are you starting over with a fresh install?
 
View user's profile Send private message Visit poster's website
icewolf
PostPosted: Sat Sep 08, 2007 9:34 am Reply with quote

Greetings, I started up with a fresh install.
 
Gremmie
Former Moderator in Good Standing


Joined: Apr 06, 2006
Posts: 2415
Location: Iowa, USA

PostPosted: Sat Sep 08, 2007 10:17 am Reply with quote

What did you install? Nuke or phpBB? What version? Sort of looks like you are missing or have a corrupt database table.

_________________
Only registered users can see links on this board! Get registered or login! - An Event Calendar for PHP-Nuke
Only registered users can see links on this board! Get registered or login! - A Google Maps Nuke Module 
View user's profile Send private message
icewolf
PostPosted: Sat Sep 08, 2007 11:08 am Reply with quote

I installed Nuke 8.1, which includes both.
 
Gremmie
PostPosted: Sat Sep 08, 2007 11:40 am Reply with quote

Do you have the file includes/constants.php on your server?
 
gotcha
Regular
Regular


Joined: Mar 14, 2005
Posts: 91

PostPosted: Sat Sep 08, 2007 11:42 am Reply with quote

Looks like the includes/constants.php is missing the definition for SESSIONS_KEYS_TABLE..

define('SESSION_KEYS_TABLE', $prefix.'_bbsessions_keys');
 
View user's profile Send private message Visit poster's website
icewolf
PostPosted: Sat Sep 08, 2007 11:43 am Reply with quote

/public_html/modules/Forums/includes/constants.php
Yes
 
icewolf
PostPosted: Sat Sep 08, 2007 11:47 am Reply with quote

gotcha wrote:
Looks like the includes/constants.php is missing the definition for SESSIONS_KEYS_TABLE..

define('SESSION_KEYS_TABLE', $prefix.'_bbsessions_keys');


After adding that I get this error:

phpBB : Critical Error

Error doing DB query userdata row fetch

DEBUG MODE

SQL Error : 1146 Table '*****_*****.nuke_bbsessions_keys' doesn't exist

SELECT u.* FROM nuke_users u, nuke_bbsessions_keys k WHERE u.user_id = 2 AND u.user_active = 1 AND k.user_id = u.user_id AND k.key_id = 'b4cc92640322fc12ac6f5251dc34efa7'

Line : 89
File : sessions.php
 
icewolf
PostPosted: Sat Sep 08, 2007 11:54 am Reply with quote

So I suppose there are some parts missing from the SQL, weird.., is there an SQL file I should get that has all the tables?
 
Gremmie
PostPosted: Sat Sep 08, 2007 11:57 am Reply with quote

icewolf wrote:
/public_html/modules/Forums/includes/constants.php
Yes


No, I said includes/constants.php, meaning public_html/includes/constants.php, not modules/Forums/includes/constants.php.

Otherwise I'm not familiar with how PHP-Nuke 8 does the forums. I assumed it was using BBtoNuke, in which case all the includes are in the root directory, not under forums.
 
icewolf
PostPosted: Sat Sep 08, 2007 12:28 pm Reply with quote

That be a no, usually for phpnuke they have it in modules/forums/includes/constants.php
But no there is no constants.php on the public_html/includes/constants.php
 
icewolf
PostPosted: Sat Sep 08, 2007 12:40 pm Reply with quote

Hey should I try to install 7.9 and then keep upgrading to 8.1? that may work.
 
Gremmie
PostPosted: Sat Sep 08, 2007 12:50 pm Reply with quote

I am familiar with RavenNuke, Nuke Evolution, and PHP-Nuke 7.9. They all use the BBtoNuke package to achieve phpBB integration. And all of these put the forums includes stuff in <root>/includes, not modules/Forums/includes. So either 8.x is doing something different, or you have the files in the wrong locations.

You are better off trying to go to RavenNuke if you are going to go anywhere. Wink
 
icewolf
PostPosted: Sat Sep 08, 2007 12:59 pm Reply with quote

Gremmie wrote:
I am familiar with RavenNuke, Nuke Evolution, and PHP-Nuke 7.9. They all use the BBtoNuke package to achieve phpBB integration. And all of these put the forums includes stuff in <root>/includes, not modules/Forums/includes. So either 8.x is doing something different, or you have the files in the wrong locations.

You are better off trying to go to RavenNuke if you are going to go anywhere. Wink


I don't think I put files in the wrong locations.
Anyways I went to Only registered users can see links on this board! Get registered or login!
but not sure which one to download (ravenuke) I could use some help.
 
Gremmie
PostPosted: Sat Sep 08, 2007 1:05 pm Reply with quote

They are all the same, they just differ on how they are archived (.zip, .rar, etc). You won't need the core table fix package.
 
icewolf
PostPosted: Sat Sep 08, 2007 3:47 pm Reply with quote

Alrighty, I installed everything, now when I try to go to the forums and post something it takes me to Your Account page, not sure whats going on, btw Gremmie, do you have anything that we can use to talk real time? msn or something.
 
Gremmie
PostPosted: Sat Sep 08, 2007 3:55 pm Reply with quote

You have to be logged in as a user probably to make a forum post. Are you just logged in as God admin?
 
icewolf
PostPosted: Sat Sep 08, 2007 4:21 pm Reply with quote

my username is the same as the god admin, I logged out from god admin and still kept going to the same page when I tried to post or reply to a thread.
Here is a screenshot: Only registered users can see links on this board! Get registered or login!
 
Gremmie
PostPosted: Sat Sep 08, 2007 4:33 pm Reply with quote

What are the forum permissions? Clear your cookies just in case.
 
icewolf
PostPosted: Sat Sep 08, 2007 5:15 pm Reply with quote

Looks like clearing my cookies fixed the problem! thank you so much, I believe I am all good to go!
Thank you so much Gremmie you are truly amazing.
 
Gremmie
PostPosted: Sat Sep 08, 2007 5:20 pm Reply with quote

RavensScripts

Glad you got it working!
 
icewolf
PostPosted: Sat Sep 08, 2007 6:01 pm Reply with quote

Looks like it wasn't just me but other users were not able to post, should I tell them to just go ahead and delete cookies for all ?
 
Gremmie
PostPosted: Sat Sep 08, 2007 7:35 pm Reply with quote

Sure, I guess....??? Can't hurt.
 
icewolf
PostPosted: Sat Sep 08, 2007 8:07 pm Reply with quote

Sorry to add this, as I go I keep getting more and more errors:
When I try to update my info (adding avatar) or something else I get error saying:
Invalid Session. Please resubmit the form.
I get that over and over again, I also tried from Profile (the phpnuke one instead of the forums one) and same bug, instead of uploading the avatar it re-directs me to the avatar page (the one with all the icons)
Its weird.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©