Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules
Author Message
p17blo
Regular
Regular


Joined: Jul 27, 2007
Posts: 77

PostPosted: Mon Sep 03, 2007 12:05 pm Reply with quote

Hi,

I had a user sign up (btw I am user AML) and I approved their membership which generated an activation email to them. But when they click on the link it does not activate and instead it takes them to the login page (and they tried to log-in with an account that hasn't been activated yet!)

Anyone, I couldn't actually believe it, so I deleted the account, went through the process again, then I remote controlled onto their PC and double checked that the link wasn't broken and again it didn't activate.

The user had another alternative address they could use and we went through the process yet again and that activated without a problem.

Does anyone have any ideas as to why this might be happening?

Paul
 
View user's profile Send private message
p17blo
PostPosted: Mon Sep 03, 2007 1:44 pm Reply with quote

OK, Already I have found some details out about this and there is definitely some dodgy code going on here.

The original code had escaped & (as &) in the link. But more importantly the email that it generated has a spelling mistake in it:

Quote:

To finish the registration process you should visit the following link in
the next 48 hours to activate your user account, otherwise the information
will be automaticaly deleted by the system and you should apply again:


I sent a follow up email which is what we activated in the end and this does not have escaped & in the link and the spelling is correct (but gives 24 hours less!)

Quote:

To finish the registration process you should visit the following link in
the next 24 hours to activate your user account, otherwise the information
will be automatically deleted by the system and you should apply again:


So now I am totally at a loss as to the original problem, whether it is related to the original email notification, AML, or RN

As this doesn't appear to be anything to do with Sentinel perhaps the mods could move it into a more appropriate topic.

Paul
 
p17blo
PostPosted: Mon Sep 03, 2007 2:05 pm Reply with quote

Sorry for triple posting but I have a further update.

The escaped & is only a problem with Outlook 2003 (which my client was using). I tried to activate exactly the same link on both Outlook 2003 (in which case the & was transferred into the URL bar on the browser) and on Thunderbird (in which case the & was correctly translated into a & in the address bar).

I also amended the URL bar of the opened address after clicking the link from Outlook 2003 to change the & into & and the link then activated as it should do.

This looks to be an error with Outlook 2003 but the coders cannot assume that no-one will be using Outlook 2003 and therefore code should be updated not the escape the & in the link (I can't see why it is needed anyway)

Comments?

Paul
 
p17blo
PostPosted: Mon Sep 03, 2007 3:10 pm Reply with quote

It's a good thing someone here is working on my problem Smile - Oh that's me Smile

OK, here is a solution to the problem most of you don't know you have.

Firstly the affected Module is Approve Membership Lite for RavenNuke
The affected file is \modules\Approve_Membership\admin\index.php
Affected Line: 245 (assuming I haven't added or removed anything
Original Code
Code:


$finishlink = "$nukeurl/modules.php?name=Your_Account&op=activate&username=$username&check_num=$check_num";

Replaced Code
Code:


$finishlink = "$nukeurl/modules.php?name=Your_Account&op=activate&username=$username&check_num=$check_num";


This removes the escaped & which doesn't work with Outlook 2003.

Now I also know why I couldn't get ever approve my membership at Only registered users can see links on this board! Get registered or login! and why Guardian had to manually set-up my account.

Thanks

Paul

ps. You may wish to edit the language file to correct a spelling mistake which is also present in the original your_account language files. You will find the mistake on both _TOFINISHUSER and _TOFINISHUSER1
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Mon Sep 03, 2007 6:43 pm Reply with quote

If I am not mistaken, any version of Approve Membership is at best beta quality on RN. A lot of us would like it to be more than that but there are many discussions taking place as to what to do with the Your Account module.

On my own "production" web site, due to some deadlines we have, I have been dealing with a group of users who can't even deal with the normal Nuke activation routines. The solution for the short run: find out what username and password they want and go into YA administration and set it up and email them back. Activation and other emails from web sites can too easily get caught up in spam filters.
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Tue Sep 04, 2007 7:03 am Reply with quote

Thanks p17blo, I have added this as a true bug (both the email link and textual change). Timing on revised release is TBD.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
montego
PostPosted: Tue Sep 04, 2007 7:10 am Reply with quote

BTW, I have moved this to the Modules forum as it turned out to not be NS related.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©