Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules
Author Message
xblader
Client


Joined: Aug 17, 2006
Posts: 28

PostPosted: Sat Jun 23, 2007 5:27 am Reply with quote

Hello all, I've got some problems with NukedGallery. Hopefully this is the right place to discusse it.

I've Installed all correctly(i think). After a couple of hours it would stop working.

Error is :
Code:
G2 did not return a success status. Here is the error message from G2: 

Error (ERROR_STORAGE_FAILURE)
in modules/core/classes/GalleryStorage.class at line 226 (gallerycoreapi::error)
in modules/core/classes/GalleryStorage.class at line 545 (mysqlstorage::_getconnection)
in modules/core/classes/GalleryCoreApi.class at line 2792 (mysqlstorage::getmapentry)
in modules/core/classes/GallerySession.class at line 851 (gallerycoreapi::getmapentry)
in modules/core/classes/GallerySession.class at line 231 (gallerysession::_loadsessiondata)
in modules/core/classes/Gallery.class at line 287 (gallerysession::init)
in init.inc at line 118 (gallery::initsession)
in modules/core/classes/GalleryEmbed.class at line 99
in index.php at line 170 (galleryembed::init)
in /home/username/public_html/modules.php at line 66


Looked around on google for this error and found some post about one of the directorys permissions not being set to 777 although it is. Tried re-installing Nukedgallery and placing it outside of the public directory. e.g. /g2data instead of /www/g2data

still the same thing happens, can anyone suggest or know what im doing wrong?
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Sat Jun 23, 2007 9:03 am Reply with quote

Have you tried to get support from the NukedGallery site? They have a wealth of information there in their forums and are pretty good about support (at least that has been my past experience.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
xblader
PostPosted: Sat Jun 23, 2007 11:37 am Reply with quote

Not posted anything there, but i read some posts on there that the error im getting is relating to the folder permission not being set to 777, although they are set to that. I do host it with Raven, i heard that he runs a Cron job looking for folders with 777 and does somthing to that folder to stop it working? Anyone can confirm that so i can stop wasting my time trying to debug it Wink
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Jun 24, 2007 12:37 pm Reply with quote

That was a very old post and that cron job was to address a specific problem and was only active for a couple of weeks and hasn't been used since.
 
View user's profile Send private message
xblader
PostPosted: Sun Jun 24, 2007 1:14 pm Reply with quote

ahh thanks, wasnt trying to blame you or anything just needed to know. Smile
 
Raven
PostPosted: Sun Jun 24, 2007 2:50 pm Reply with quote

I didn't take it like that Smile - it was just meant as an fyi Wink
 
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Sun Jun 24, 2007 3:52 pm Reply with quote

The whole permissions issue can be a nightmare with Gallery. I've spend DAYs working on it. You may need the Gallery data folder to be 777 entirely. Don't bother trying to do it yourself as a user, Gallery creates hundreds, maybe thousands of directories and folders more or less dynamically. Your host can chmod them recursively to 777.

Usually that works. When it works, it works. By that I mean Gallery can run for a year or two without problems. When it doesn't work you really need your host to look at it.

If you dig deep enough on the Gallery web site, you will find some very instructive posts. But they still haven't written a Compleat Idiots guide to making Gallery work in any Hosting Situation and that's what's needed.
 
View user's profile Send private message Visit poster's website
xblader
PostPosted: Mon Jun 25, 2007 5:48 am Reply with quote

yeh, installed Gallery it was running perfectly for an hour or so then just breaks like that. 4th time i've tried installing this. Gonna have anther check to make sure if everything is right before i refeer it up. Thanks for alll the info though, really appericate it Smile

EDIT: Welll got it working again after, the problem was the Smarty directory where it stores the template temp files. it Was set to 644, changed them to 777 and it now working, again thanks for the info.
 
Raven
PostPosted: Mon Jun 25, 2007 12:07 pm Reply with quote

xblader,

Would you please post exactly how you installed Gallery for the benefit of others? Thanks!
 
CodyG
Life Cycles Becoming CPU Cycles


Joined: Jan 02, 2003
Posts: 712
Location: Vancouver Island

PostPosted: Mon Jun 25, 2007 11:39 pm Reply with quote

yes please!
i'm having some issues with 404 pages when i try to verify configuration and when exporting users.
The nuke_g2config table is getting set up, but not populated with any record.
And about a g2 user table ???... is there a name for that table that someone wants to share? cause i don't think i have it.... when i click on the export users button it takes me to another 404 page.

i wonder where the integration package /install dir needs to be?? in modules/gallery2/install ?? or someplace else?

(i didn't really want to install gallery2, but the others on the computer club team want to see it in action before looking for another solution... )

_________________
"We want to see if life is ubiquitous." D.Goldin 
View user's profile Send private message
CodyG
PostPosted: Tue Jun 26, 2007 12:35 am Reply with quote

i need to have gallery2 all setup and running before i attempt the integration pack, right? (duh) ... in that case, when i get to the second page of the gallery2 install i'm getting this error.

Warning: putenv(): Cannot set environment variable 'LANG' - it's not in the allowed list in /xxx/xx/xxx/xxx/www/modules/gallery2/modules/core/classes/GalleryTranslator.class on line 302 Warning: putenv(): Cannot set environment variable 'LANGUAGE' - it's not in the allowed list in /xxx/xx/x/xxx/www/modules/gallery2/modules/core/classes/GalleryTranslator.class on line 303

is this a safe-mode off application?
 
xblader
PostPosted: Tue Jun 26, 2007 6:12 am Reply with quote

Will post a more detail guide once i get home. other then that here is a breif guide on what i did.

Step1) Installed Gallery2 through Cpanel using Fantastico. (Much quicker then uploading all the files manullay) Although it will install it in /home/username/www/gallery2/ . You should be able to then move this folder with your FTP client (i'm using Filezillia).

Step2) Start the install process by going to Only registered users can see links on this board! Get registered or login! depending if you installed this via fatastico.

Step3) After you finished the install process the folder is ready to be moved. In this example i will move my gallery folder to the phpnuke modules folder. (/home/username/public_html/modules/gallery2/


Step4)If you are going to move this folder you will need to make the necassary change in the config.php file within the gallery folder( /gallery2/config.php ) .

Following changes are to be made:

From:
$gallery->setConfig('data.gallery.base', '/home/username/public_html/gallery2/g2data/');

To:
$gallery->setConfig('data.gallery.base', '/home/username/public_html/modules/gallery2/g2data/');

Step5) You are now ready to install the intergration pack located here. Only registered users can see links on this board! Get registered or login! (Please note that if you changed the folder name of gallery you will need to change the folder paths/names within the intergration pack aswell. I will post more on that later. )

Step6) You can know go to your admin control panel (http://www.yoursite.com/admin.php) and start importing user over within the gallery section.




To CodyG: Did you rename your Gallery folder to something other then the standard gallery2 folder name? if so this is most likley your problem with the 404 errors, you will need to go within each file of the intergration amend the paths/folder names.

Had a brief look at my database and can only see a g2config table. If you solve the 404 page errors first this may be the solution to this 2.

Also Gallery2 will not work in safemode.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©