Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules
Author Message
wiz
Involved
Involved


Joined: Oct 09, 2006
Posts: 413
Location: UK

PostPosted: Tue Apr 24, 2007 3:48 pm Reply with quote

Hi guys

We have a custom module that we made years back, works a treat. However recently, i added a simple hyperlink to the page. Worked fine, but i decided in the end i didnt want it there. So i go back into the module script and remove my hyperlink.

Clear my cookies, blah blah. reformat my pc even!! and it still shows.
I then get another admin to look at the script, and he confirmed..no hyperlink is actually there, but he too sees it on the page.

So before i start doing any more fiddling, i go into Cpanel and copy the module over to a test site on a subdomain...et voilla, no hyperlink.
Hmm me thinks...
I delete the module on the 'live' site..confirm it has gone via browsing to it. Then copy over the module from the test site (which works perfectly)....
Yup you guessed it...hyperlink re-appears, as if by magic.


2 things spring to mind for me.. 1/ im not actually editing the correct script-- but i made the original edit, so it cant be that. 2/ my temp files and cookies are showing me an old version of the page-- it cant be because ive re-formatted my pc and had others confirm the errors.

As the topic title says..Very Weird
 
View user's profile Send private message Visit poster's website AIM Address
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Tue Apr 24, 2007 5:47 pm Reply with quote

and what if you download the page...
delete the one on the server...
confim that by checking if you get the error that the page is missing..
then upload the downloaded one that you edited without hyperlink....
 
View user's profile Send private message
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Tue Apr 24, 2007 7:49 pm Reply with quote

I was looking at something odd sort of like this today and it was driving me nuts. I had created a new php file, let's call it abc.php based on some older code in my module. The directory it should have been in was let's say /my_nuke_root/modules/. So it should have been /my_nuke_root/modules/abc.php. Well, when I created the abc file I did a copy and paste, made some modifications and then did a save as. It seemed to work fine in the browser so I went to make some adjustments and couldn't find the file. Where the heck did abc.php go? Sometimes my editor doesn't refresh the file list so I went to Explorer and looked and it wasn't there either. Finally I did a search on the whole drive and there it was in /my_nuke_root. So the includes for it could work [include('abc.php'); but it wasn't there for the editor. I hope this isn't too convoluted; all I'm suggesting is look to see if you saved the file somewhere else in the path that your browser can find even though you don't have it where you expect it.
 
View user's profile Send private message Visit poster's website
wiz
PostPosted: Wed Apr 25, 2007 1:15 pm Reply with quote

any ideas how i can search for it on server?
 
wiz
PostPosted: Wed Jan 02, 2008 9:16 pm Reply with quote

bump...just got back to this one Shocked
 
fkelly
PostPosted: Thu Jan 03, 2008 8:06 am Reply with quote

1. Cpanel has a file manager so look in your Nuke Root directory for a file with the name you are having trouble with.

2. Make some obvious modification to the file (like put a big echo in at the top) and reload it. See if it is picking up that version or somehow still picking up the old one.

3. I just looked on my Cpanel. There's a nice little search all files for function at the top. Put in the file name and have it search across all directories.
 
wiz
PostPosted: Thu Jan 03, 2008 10:04 am Reply with quote

ok, i have edited the proper file and added a test echo, at the top; as suggested. The echo is not displayed.
So do we assume that, this is not the file that it is reading?
 
fkelly
PostPosted: Thu Jan 03, 2008 11:37 am Reply with quote

I would assume that yes. I'd go looking for another file with the same name thru Cpanel or other means. If you can't find it on Cpanel perhaps download the whole setup from your nuke root on down to your PC and use Windows explorer to search for a file with that name.
 
wiz
PostPosted: Thu Jan 03, 2008 8:48 pm Reply with quote

I looked at the module index.php, and it includes only 1 file..the one i was looking at.
I d/l'd a copy and did a windows search.. It returns only 1 script, i open it and ..yep you guessed it. absolutly no reference to the hyperlink
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Modules

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©