Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x
Author Message
Bluezzz
Involved
Involved


Joined: Feb 08, 2005
Posts: 290
Location: USA

PostPosted: Tue Apr 17, 2007 3:45 pm Reply with quote

One of my sites was recently migrated to another host. Since then I've tried to log into admin and cannot, NS does not recognize the username/pw. It was fine before I migrated, not fine now. After much pondering I realized that when recently installing NS I had an issue with CGIAuth which is what the new host uses, whereas my old host used the other Auth (forgot the name of it but it was much easier to set up in NS).

That being said, I can't get into my site as admin/god. NS is expecting the old Auth when the new site doesn't have that. How exactly do I get in to NS to change that? I'm completely locked out. Sometimes NS just tells me after three attempts that it can't verify me, other times I get sent to a page that says "Leave this site now!".

Help!?

_________________
Bluezzz
~ Stop & smell the roses, while you can! ~ 
View user's profile Send private message
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Tue Apr 17, 2007 5:09 pm Reply with quote

Go to your database and check if there is http auth= 1 in nuke_nsnst_config. Set it to 0.
Read also about .staccess and CGI-AUTH in the Nuke Sentinel administration.


Last edited by Susann on Tue Apr 17, 2007 5:12 pm; edited 1 time in total 
View user's profile Send private message
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Tue Apr 17, 2007 5:11 pm Reply with quote

well your probably in the table nsnst_admins.
you could empty that...or any info you put into the htaccess and staccess file
 
View user's profile Send private message
Bluezzz
PostPosted: Tue Apr 17, 2007 5:21 pm Reply with quote

I checked the .htaccess and .staccess both have a username:password (different but I believe they're both correct) ... I haven't had to do anything to this site since I set it up a few years ago aside from log in as admin for backups, etc. I didn't add any additional info to either file and like I said they worked fine before the migration to the new host, which doesn't allow the Auth I use to use.

How do I got to my database if I'm locked out of the site?

Thanks for your answers ...
 
hitwalker
PostPosted: Tue Apr 17, 2007 5:39 pm Reply with quote

well you have phpmyadmin right ?
cpanel.....
 
Susann
PostPosted: Tue Apr 17, 2007 5:44 pm Reply with quote

If you are banned remove your IPS from the .htaccess and use PhpMyadmin to check the database tables.You could also remove the htaccess for a short time.
 
Bluezzz
PostPosted: Tue Apr 17, 2007 8:34 pm Reply with quote

I'm not banned I just can't log in, for the rest of it I have no clue what you are talking about LOL I know how to log into PHPmyAdmin but I don't know how to check tables or what to look for specifically.
 
hitwalker
PostPosted: Wed Apr 18, 2007 5:08 am Reply with quote

so ...tell me....if you go to your admin area you still get the popup window to login ?
 
Bluezzz
PostPosted: Wed Apr 18, 2007 5:22 am Reply with quote

Yes, I get the popup window (for NS) but when I put in my login info it's not recognized, after three tries I'm redirected to a page that says I can't be identified as authenticated, or sometimes it goes to a page that says "Leave this site now!"

As I said, I'm pretty sure it has to do with hosting migration, my new host doesn't allow HTMLAuth or whatever the old host did, this host is CGIAuth, which is the more complicated to set up.

I have PHPmyAdmin but no clue how to look at tables or anything.
 
hitwalker
PostPosted: Wed Apr 18, 2007 5:25 am Reply with quote

pm me your site admin login and the full login to your phpmyadmin....
(i waited for reply but im off to the gym now)
 
Bluezzz
PostPosted: Wed Apr 18, 2007 11:30 pm Reply with quote

Sorry, not been feeling well today.

This PHP site is a couple of years old, I don't imagine it will be that easy to just fix this problem. I will likely have to get the latest RN/NS and reinstall, should I choose to go that route ... that may be more trouble than I care to go through at this point.

As I said I'm not feeling so good today so I'm going to hold off for now. I'm also not sure I want to continue with this type of site for that particular domain since it's not often used by me or anyone else even tho it is my personal *main domain*. I may need to look into other formats ... the easier the better ... and yes I know, then I run into security issues, but I'd do that by not keeping on top of it, which I'm notorious for.

I have one other RN/NS site and I'm not doing so well maintaining that one either, these types of sites take quite abit of maintenance to keep up with security and every time something needs to be updated it causes more problems ... I find it all very draining sometimes.

Thank you for your comments, and hitwalker thank you for the offer to get into the messy work of admin for me, much appreciated.
 
hitwalker
PostPosted: Thu Apr 19, 2007 5:08 am Reply with quote

sorry to hear that...
if help is needed when your feeling better just reply here again.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©