Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Captcha Security
Author Message
ghostgeek
Regular
Regular


Joined: Jan 14, 2005
Posts: 93

PostPosted: Tue Feb 20, 2007 7:16 pm Reply with quote

At some point (way in the past - maybe 2 years ago) I disabled the captcha from my site due to some issue I was having with it.

We'll my site has now become the target of a POS spammer who keeps signing up new accounts (like dozens every day) and I'm having to manually purge them out.

I tried to reenable captcha by setting...

$gfx_chk = 3

for new users in config.php, but it doesnt seem to be working. I've also tried setting it to a value of 7 for all users, but I'm still not being prompted to enter the access code.

Any clue as to where I should check next?

Thanks so much

P.S.
I've checked the last_ip section of the database for all these accounts, and they always come back with a value of 0 - how is this person cloaking their IP address?
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Feb 20, 2007 10:19 pm Reply with quote

Do you get something that looks like a "broken image"? I don't know for sure, but it might be that the GD libraries are not installed (ask your host to enable them for you).

This might help.
Only registered users can see links on this board! Get registered or login!

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Wed Feb 21, 2007 5:35 am Reply with quote

Ghostgeek you need to check the behavior of the captcha with both browser IE and Firefox. Like many guys I had the same issue with this function. After I changed the code in the files the captcha worked only in IE and not in Firefox. But it was a good start. I checked then all files and indeed I found a blank line in mainfile.php. Afterthat it worked with both browser. Hope this helps. However, there are so many reasons for this issue maybe use the search function here and you ´ll find out how people solved this problem. Smile
 
View user's profile Send private message
Trubador
Regular
Regular


Joined: Dec 28, 2004
Posts: 94

PostPosted: Sun May 13, 2007 3:53 am Reply with quote

Quote:
I found a blank line in mainfile.php.


I've just been scratching my head for ages on this one. Using RN 2.10.01

Yes Susan. After ?> in mainfile.php. Once I deleted that then all worked fine. Thanks for the simple but utterly time saving fix. Smile

Trub
 
View user's profile Send private message
Susann
PostPosted: Sun May 13, 2007 5:04 am Reply with quote

Glad that worked for you. Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Captcha Security

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©