Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
rsrichie
New Member
New Member


Joined: Jan 11, 2007
Posts: 11

PostPosted: Sun Jan 14, 2007 11:55 pm Reply with quote

Hi all i hope im not repeating a problem reported else where as i have read all posts that seem somewhat relevant with no resolve found.
Ok I have just completed a new install and all is working great accept the activation email and the mass email function from the forum admin panel. I also used nuketool box to test the php mail functionality and it advised that it is working and should a email not be received that there is a issue with the smtp server or path.
As my previous site was a ealier version of nuke and i have moved it to another folder i was able to copy all the details over from it exacly into the new sites configuration panel but have had no luck in sending out emails from activation, topic notifacation or mass email.
One thing i did notice was that when selected to use the smtp option on the configuration board that when i send a mass email the screen would just go to white only leaving the menu bar to the left but no confirmation of any email being sent. If i select NO to the use of smtp and then send a mass email it comes up with a confirmation screen, but either way it doesnt manage to send the email.
Any help would be much appreciated.
Only registered users can see links on this board! Get registered or login!

regards
Richie

_________________
Lifes short make the most of it

Last edited by rsrichie on Mon Jan 15, 2007 10:00 pm; edited 1 time in total 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Mon Jan 15, 2007 5:20 am Reply with quote

If you don't have the access yourself, ask your host to check the email server to see what is happening. Sometimes you can see how it is handled there.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Mon Jan 15, 2007 6:51 am Reply with quote

Also you mentioned you were getting a white screen. It would be useful if you could turn on error checking and post any errors you get here.
 
View user's profile Send private message
bunter
New Member
New Member


Joined: Jan 19, 2007
Posts: 2

PostPosted: Fri Jan 19, 2007 10:25 pm Reply with quote

I am the one hosting Richies site we run the email Server on a diff Server than the web server, and i have many pages using SMF and phpBB2 forums and they all seems to work with the email settings, only richies one dont even when i use settings from a phpbb2 forum thats email is working.

its not showing eny errors, and yes i turnd on show errors.

i guess its an issue with the forum and not the portal.

we have even tried to use known working email servers from other places NO working still.

We have even tried installing the portal twice thus far and both installs had no errors.

But still have the same Problem.
 
View user's profile Send private message
bunter
PostPosted: Mon Jan 22, 2007 12:10 am Reply with quote

I guess no one has any idea.
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Jan 23, 2007 7:04 am Reply with quote

Sorry... unfortunately I do not have experience in this area to draw upon (in the configuration of mail services). Hopefully someone else here can pick this up?

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
rsrichie
PostPosted: Fri Jan 26, 2007 8:31 am Reply with quote

i was wondering if maybe it is the sential that is conflicting with somthing as this is the only major difference between my previous nuke install and this one.
 
montego
PostPosted: Fri Jan 26, 2007 3:46 pm Reply with quote

I think you would be experiencing different problems if it was NukeSentinel. This release has worked very well for so many people, so it is just a few environments with slight nuances that seem to trip it up. I just wish I new more about SMTP/mail setup to help you. Sad
 
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Sat Jan 27, 2007 7:48 am Reply with quote

c'mon peeps , its fair to say that if you install nuke (whatever version) in a normal server enviroment all should work flawless.
at that point the simple nuke standard configuration is sufficient enough to let it all work.
but when mail functions arent working thats usualy because of your host and his settings,or you have some corrupted files....
pages turning blank with a new fresh install ....? Laughing
 
View user's profile Send private message
rsrichie
PostPosted: Sat Jan 27, 2007 9:08 pm Reply with quote

ok well it would appear that it is not a issue specific with the raven76 as i just tried to install nuke lite 7.9 with the same result 7.9 comes loaded with sentinal also so my next move is to try plain nuke without sentinal and see what happens.
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Sat Jan 27, 2007 10:37 pm Reply with quote

Sentinel has no bearing on how your site handles the php mail() function or smtp mail.
No offence but your time would be better spent reviewing the advice already posted.
 
View user's profile Send private message Send e-mail
skeetch
New Member
New Member


Joined: Oct 20, 2007
Posts: 20

PostPosted: Sat Oct 20, 2007 8:44 pm Reply with quote

Started a new post for this : Only registered users can see links on this board! Get registered or login!


Well, just a quick note.. MANY major ISP / Hosting services are turning off the PHPMAIL function. Forcing all of us to use SMTP. the real issue is that phpnuke and"RN"environment uses the phpmail function exclusively, and so far i have not found a way to force it to use smtp, without using an auth hack that circumvents your e-mail auth. thus allowing anyone to register and become auto-enabled.. which is the same as handing the keys of your site over to anyone.

What we really need is for someone who knows how to force the php to use smtp to make an easily searchable post with a fix. I have been searching for hours, and alot of people have errors similar, but this is not an error, it is simply most hosting providers are disabling the phpmail function, and so far there seems to be no workaround without opening the flood gates..


Last edited by skeetch on Sat Oct 20, 2007 9:50 pm; edited 1 time in total 
View user's profile Send private message Visit poster's website
PHrEEkie
Subject Matter Expert


Joined: Feb 23, 2004
Posts: 358

PostPosted: Sat Oct 20, 2007 9:35 pm Reply with quote

The mail calls in Nuke are hard-coded in, so it will not be an easy task to create a centralized mail function that can be called via a setting in the config file or the config table (more likely).

To the original poster: Have you downloaded a fresh phpBB 2.x and installed it to test mail functionality? It shouldn't take more than a few minutes to do so...

Trust me, Sentinel does not block or interfere with outgoing ANYTHING. It only filters INCOMING requests, so it will have no effect on outgoing email or associated services.

PHrEEk

_________________
PHP - Breaking your legacy scripts one build at a time. 
View user's profile Send private message
skeetch
PostPosted: Sat Oct 20, 2007 9:52 pm Reply with quote

Hey Phreekie,

Thanks for the response! I started a new post for this, as it is quickyl becoming a serious problem as more and more hosters and denying the phpmail() function.

here is a link to the post i started so we can more easily search and fix this issue as it becomes more serious.

Only registered users can see links on this board! Get registered or login!
 
skeetch
PostPosted: Sat Oct 20, 2007 9:56 pm Reply with quote

lol, the more serious problem seems to be my l33t typing skeelz, lol Very Happy
 
montego
PostPosted: Mon Oct 22, 2007 5:23 am Reply with quote

I agree. See my response within your other thread. Wink
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©