Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
ccac
Hangin' Around


Joined: May 23, 2006
Posts: 40

PostPosted: Fri Jan 05, 2007 12:56 pm Reply with quote

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in /home/public_html/modules/Forums/search.php on line 1053

I can not find any information about this error. Please help.

Thanks!
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Jan 05, 2007 1:40 pm Reply with quote

ccac, what have you changed in that script? This is almost always a result of a coding error made when trying to make a mod to a script. Maybe compare that script with the original one from the distribution?

I have looked at the original script from the 2.02.02 download and that line of code looks to be just fine.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Fri Jan 05, 2007 3:34 pm Reply with quote

looks like it indeed....
i even found another site having the same error...
probably edited file....
 
View user's profile Send private message
ccac
PostPosted: Fri Jan 05, 2007 10:15 pm Reply with quote

'FORUM_NAME' => $searchset[$i]['forum_name'],

That is the line - my php software is saying 'FORUM_NAME' is the error? Any ideas?

I never edited this file...
 
montego
PostPosted: Sat Jan 06, 2007 8:26 am Reply with quote

Post the line above and the line below too (or, better yet, like 10 lines above and below). Thx.
 
ccac
PostPosted: Sat Jan 06, 2007 2:53 pm Reply with quote

if ( $userdata['session_logged_in'] && $searchset[$i]['post_time'] > $userdata['user_lastvisit'] )
{
if ( !empty($tracking_topics[$topic_id]) && !empty($tracking_forums[$forum_id]) )
{
$topic_last_read = ( $tracking_topics[$topic_id] > $tracking_forums[$forum_id] ) ? $tracking_topics[$topic_id] : $tracking_forums[$forum_id];
}
else if ( !empty($tracking_topics[$topic_id]) || !empty($tracking_forums[$forum_id]) )
{
$topic_last_read = ( !empty($tracking_topics[$topic_id]) ) ? $tracking_topics[$topic_id] : $tracking_forums[$forum_id];
}

if ( $searchset[$i]['post_time'] > $topic_last_read )
{
$mini_post_img = $images['icon_minipost_new'];
$mini_post_alt = $lang['New_post'];
}
else
{
$mini_post_img = $images['icon_minipost'];
$mini_post_alt = $lang['Post'];
}
}
else
{
$mini_post_img = $images['icon_minipost'];
$mini_post_alt = $lang['Post'];
}

$template->assign_block_vars("searchresults", array(
'TOPIC_TITLE' => $topic_title,
'FORUM_NAME' => $searchset[$i]['forum_name'],
'POST_SUBJECT' => $post_subject,
'POST_DATE' => $post_date,
'POSTER_NAME' => $poster,
'TOPIC_REPLIES' => $searchset[$i]['topic_replies'],
'TOPIC_VIEWS' => $searchset[$i]['topic_views'],
'MESSAGE' => $message,
'MINI_POST_IMG' => $mini_post_img,

'L_MINI_POST_ALT' => $mini_post_alt,

'U_POST' => $post_url,
'U_TOPIC' => $topic_url,
'U_FORUM' => $forum_url)
);
}
else
{
$message = '';

if ( count($orig_word) )
{
$topic_title = preg_replace($orig_word, $replacement_word, $searchset[$i]['topic_title']);
}

$topic_type = $searchset[$i]['topic_type'];

if ($topic_type == POST_ANNOUNCE)
{
$topic_type = $lang['Topic_Announcement'] . ' ';
}
else if ($topic_type == POST_STICKY)
{
$topic_type = $lang['Topic_Sticky'] . ' ';
}
else
{
$topic_type = '';
}
 
montego
PostPosted: Sat Jan 06, 2007 3:21 pm Reply with quote

Well, nothing wrong with the assignment, but I wonder about the backets. Please send me this file to montego --AT)) montegoscripts ((do t)) com. Smile

I want to compare it to what we have running on Only registered users can see links on this board! Get registered or login!
 
ccac
PostPosted: Sun Jan 14, 2007 12:29 am Reply with quote

There must have been some sort of edit... I did not do it though.
I restored the file from the download and it works fine.

Thank You for your help and time. Ravennuke is THE BEST!
 
montego
PostPosted: Mon Jan 15, 2007 11:00 pm Reply with quote

ccac wrote:
I never edited this file...


Rolling Eyes Bang Head Groovy
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©