Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's
Author Message
howard
Hangin' Around


Joined: Aug 23, 2006
Posts: 32

PostPosted: Wed Dec 13, 2006 2:54 pm Reply with quote

Hello to all!

I've spent a fair bit of time trying to figure this out and I'm stuck. Here is what I'm trying to do:

I have a set of pages that I've written in html that I'm incorporating into my modules using Chris Karakas' instructions.

I call up each html file using an index.php file...the code for is below.

Code:
<?php

/************************************************************************/
/* PHP-NUKE: Web Portal System                                          */
/* ===========================                                          */
/*                                                                      */
/* PHP-Nuke-HOWTO module for <application>PHP-Nuke</application>                                   */
/*                                                                      */
/* Copyright (c) 2003 index.php                                         */
/* by Chris Karakas                                                     */
/* http://www.karakas-online.de                                         */
/*                                                                      */
/* See licence.html for the Licence of the other files                  */
/* distributed together with this index.php file.                       */
/*                                                                      */
/* This program is free software. You can redistribute it and/or modify */
/* it under the terms of the <acronym>GNU</acronym> General Public License as published by */
/* the Free Software Foundation; either version 2 of the License.       */
/************************************************************************/
if (!eregi("modules.php", $PHP_SELF)) {
  die ("You can't access this file directly...");
}
$index = 0;   // 0 : do not show right blocks - 1:show right blocks
require_once("mainfile.php");
$module_name = basename(dirname(__FILE__));
include("header.php");
// We initialize the array, to avoid attacks based on poisoning the
// <acronym>PHP</acronym> global variable space. Thanks to waraxe for pointing this out!
// See http://www.waraxe.us
//
$ACCEPT_FILE = array();
$ACCEPT_FILE['0'] = 'menu.html';
$ACCEPT_FILE['1'] = 'colt1911.html';
$ACCEPT_FILE['2'] = 'm1carbine.html';
$ACCEPT_FILE['3'] = 'm1garand.html';
$ACCEPT_FILE['4'] = 'thompson.html';
$ACCEPT_FILE['5'] = 'bar.html';
$ACCEPT_FILE['6'] = 'springfield03.html';
$ACCEPT_FILE['7'] = 'm1919.html';

OpenTable();
$php_ver = phpversion();
$php_ver = explode(".", $php_ver);
$phpver = "$php_ver[0]$php_ver[1]";
if ($phpver >= 41) {
    $page = $_GET['page'];
} else {
    $page = $HTTP_GET_VARS['page'];
}
$pagename = $ACCEPT_FILE[$page];
if (!isSet($pagename)) $pagename = "menu.html"; // default file
include("modules/Weapons/$pagename");
CloseTable();
include("footer.php");
?>


Now, In one of the files, my m1garand.html file, I've got a flash movie I'd like to embed of somebody firing an m1 garand. I keep trying different ways of getting ti to work, and I keep getting a white block where the flash file should be, but when I right click the box it says "movie not loaded"

Here is the code for the m1garand.html file.

Code:
<scr~ipt src="scr~ipts/AC_RunActiveContent.js" type="text/javascr~ipt"></scr~ipt>

                <td align="left"><b><obj~ect classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="320" height="275"><param name="movie" value="garandslow.swf"><param name=quality value=high><PARAM NAME=loop VALUE=true><embed src="flash.swf"  width="320" height="275" loop=true quality=highpluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash"></emb~ed>
</obj~ect>


Can anybody give me a tip on how tog et this flash to display?

Thanks
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Wed Dec 13, 2006 3:19 pm Reply with quote

My guess is you have the wrong path

Remember that it looks for files from your Nuke root


If your Nuke root was Only registered users can see links on this board! Get registered or login!
It is looking for
Code:


src="flash.swf"


which would go to Only registered users can see links on this board! Get registered or login!

scr~ipts/AC_RunActiveContent.js
would go to Only registered users can see links on this board! Get registered or login!

I hope that may help

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Wed Dec 13, 2006 3:20 pm Reply with quote

flash is usualy a path problem howard...
make sure you have the path corect set to the module...
and with path i mean... /modules/your_mod/
 
View user's profile Send private message
floppydrivez
Involved
Involved


Joined: Feb 26, 2006
Posts: 340
Location: Jackson, Mississippi

PostPosted: Wed Dec 13, 2006 3:22 pm Reply with quote

Nice I have never seen this approach to post code

Code:
scr~ipts


Thats one way to get it done.

_________________
Only registered users can see links on this board! Get registered or login!, Only registered users can see links on this board! Get registered or login!, Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
howard
PostPosted: Wed Dec 13, 2006 3:30 pm Reply with quote

Thanks evaders and hitwalker...path was right...I never thought to add /modules/Weapons to it. Ya'll rock!

@floppydrivez--it wouldn't let me post unless I broke up some of that scripting.
 
floppydrivez
PostPosted: Wed Dec 13, 2006 3:32 pm Reply with quote

Yeah, I just never seen anyone take that approach.

Can I see your flash video?
 
howard
PostPosted: Wed Dec 13, 2006 3:53 pm Reply with quote

Only registered users can see links on this board! Get registered or login!

Still very much under construction

I gotta fool around and get the control bar to work for the flash.
 
Gremmie
Former Moderator in Good Standing


Joined: Apr 06, 2006
Posts: 2415
Location: Iowa, USA

PostPosted: Wed Dec 13, 2006 3:57 pm Reply with quote

(Nevermind - how do you delete posts?)
 
View user's profile Send private message
howard
PostPosted: Wed Dec 13, 2006 3:59 pm Reply with quote

::shrug:: It wouldn't let me post, I had an error msg, I put a ~ in the word script like it suggested and it let me post.
 
howard
PostPosted: Wed Dec 13, 2006 3:59 pm Reply with quote

lol

you can't
 
howard
PostPosted: Thu Dec 14, 2006 11:38 pm Reply with quote

Got it workin...looks great. Thanks to all who helped!!
Only registered users can see links on this board! Get registered or login!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> How To's

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©