Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
datnewf
New Member
New Member


Joined: Nov 30, 2006
Posts: 8

PostPosted: Fri Dec 01, 2006 11:52 pm Reply with quote

Like the title says, if i click the "Register" link on my install i get all the steps - fill out username, emal, password, then click finish on the 2nd page to confirm.

THe problem is is that the activation emails never arrive in my inbox and if i go to the user admin page or the users section of the phpbb admin page the username i just created does not exist.

if i try to reregister with the same information as before i get "the email address is already registered"

if i go to "lost password" and type in the user name, i get that there is no such user.

If i start from the beginning and create the user while im logged into the admin panel from the User control everything works peachy.


Any suggestions at all?

this is a fresh raven install with my user accounts and phpBB contents ported over using a script i found online - unfortunatly i didnt notice if the user problem was happening before i imported the table.
(im hearing no complaints from users with issues logging in).

also and maybe related, on the "groups admin" page i have 12 users (out of many many more) to choose from, and if i pick a single group (officers for instance) on the nuke admin page it looks normal but on the forum usergroup page each user is in the group twice.


Last edited by datnewf on Thu Dec 07, 2006 8:17 am; edited 1 time in total 
View user's profile Send private message
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Sat Dec 02, 2006 2:45 am Reply with quote

check your users temp table,they are probably in there....
who knows what the script has done....
 
View user's profile Send private message
datnewf
PostPosted: Sat Dec 02, 2006 1:00 pm Reply with quote

well... you sure are right - all three test users are in that table....

so um... any suggestions?

edit:

am i right in thinking that the nuke_users_temp table is the "holding pen" where an account goes when its awaiting the email verification?

if so the emails are never coming through to the addresses.
Email from the forum seems ok, i can PM and get the PM notifications, watched topic notices etc.
 
hitwalker
PostPosted: Sat Dec 02, 2006 2:19 pm Reply with quote

well it looks like you have to find the problem in the mail..
if no mail is send then the account will never be verified,and therefor the account stays temp...
start checking your mail settings....and the your-account...
 
datnewf
PostPosted: Sat Dec 02, 2006 7:23 pm Reply with quote

yeah i tracked down that its an issue with the initial messages that are sent out on registration.

is there a config setting that can be enabled to give a more detailed log of whats going on behind the scenes when a message is sent? I sent a test message from the forum admin to me and a few others, and i know i haven't received it yet.

Edit: I set "display_errors = true" in my config.php and this is what i get upon submitting a new registration:
Code:
Warning: mail() [function.mail]: SMTP server response: 550 Sender address must be specified. in C:\webpages\Hosts\KOS\modules\Your_Account\index.php on line 163


Line 163 is:
Code:
mail($user_email, $subject, $message, "From: $from\nX-Mailer: PHP/" . phpversion());


and in that user record i get
Code:
5, 'grose', 'grose@DOMAINNAME.com', 'accea77df6add4e312805816c97d54d3', 'Dec 03, 2006', '53c68f538b9c826876cbfd6ff28be71b', '1165109584'


the server is setup the same way as my previous board, Localhost for smtp with my username/password in place
 
hitwalker
PostPosted: Sun Dec 03, 2006 7:01 am Reply with quote

start reading here... Only registered users can see links on this board! Get registered or login!
 
datnewf
PostPosted: Sun Dec 03, 2006 8:02 am Reply with quote

hitwalker wrote:
start reading here... Only registered users can see links on this board! Get registered or login!
thanks a ton, lots of great info to look into.

i will keep you posted.

if its an IIS thing or improper PHP setup is seems odd that it would crop up now and not on our old forums.. but whatever Very Happy
 
hitwalker
PostPosted: Sun Dec 03, 2006 8:07 am Reply with quote

well you have to start somewhere with investigating....
im sure you will find it.... Wink
 
datnewf
PostPosted: Sun Dec 03, 2006 10:29 am Reply with quote

Just on an offchance i installed CNYBA 4.4.2 to see if that would correct the problem or give me a way to bypass it.

i tried to "resend activiation" to one of my temp accounts and i get the same error (different file, different line) so now i have it pretty much narrowed down to a global setting, either in PHP itself or in my Nuke setup..i don't have access to the PHP setup files, but i can get my admin to look into them - any settings offhand you can think of? keeping in mind that activation emails were (and still do) work fine on my old phpbb2 forums which are on the same server and the config in the forum admin is the same

ill post more when i find out anything...
 
datnewf
PostPosted: Sun Dec 03, 2006 11:10 am Reply with quote

ok - so with cnbya installed i have found the following:

Private message notification emails send fine
Topic reply notifications send fine

activation mail messages result in the following Above and below the main "thank you" block:
Code:


Warning: mail() [function.mail]: SMTP server response: 550 Sender address must be specified. in C:\webpages\Hosts\KOS\modules\Your_Account\public\new_finish2.php on line 76


if i go to admin-> user admin -> search users -> temp users then choose the user i just made, and choose Functions -> resend i get
Code:
Warning: mail() [function.mail]: SMTP server response: 550 Sender address must be specified. in C:\webpages\Hosts\KOS\modules\Your_Account\admin\resendmailconf.php on line 40


so something is apparently different in the way the nuke board and the BB are sending messages (mainly the follow up notices and PM notices).

I will compare the phpbb files once i figure out which ones they are (lol)
 
datnewf
PostPosted: Thu Dec 07, 2006 8:15 am Reply with quote

Code:
Warning: mail() [function.mail]: SMTP server response: 550 Sender address must be specified. in C:\webpages\Hosts\KOS\modules\Your_Account\public\new_finish2.php on line 76

is the error im still getting with the site on registration... on a whim i decided to take out the "from" field and see what would happen and i get
Code:
Warning: mail() [function.mail]: "sendmail_from" not set in php.ini or custom "From:" header missing in C:\webpages\Hosts\KOS\modules\Your_Account\public\new_finish2.php on line 76


i have the phpini file, and i have this in it:
Code:


[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
;sendmail_from = Only registered users can see links on this board! Get registered or login!


the commented out sendmail_from= line only needs to be uncommented and filled in if im not using a custom "from" header in the mail() function correct?
 
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Thu Dec 07, 2006 9:32 am Reply with quote

I would sudjest that you uncomment that for the time being, Then well try to debug your mail issue, lets get you working first.

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©