Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
wiz
Involved
Involved


Joined: Oct 09, 2006
Posts: 413
Location: UK

PostPosted: Thu Nov 23, 2006 11:57 am Reply with quote

Ok so im the webmaster for a gaming clan. I stumbled across RN when looking at building them something new. I got it, installed it, bar a few niggles works fine. Now i decide i want to use it for my own personal site.
I Started by installing it all into a sub-folder (so that i can keep my site alive). As im constructing it, i just add the folder to the path...logically.
However when i type Only registered users can see links on this board! Get registered or login! it navigates me to the currently running index.html.

I dont see how it can do that, it just doesnt make any sense.
 
View user's profile Send private message Visit poster's website AIM Address
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Thu Nov 23, 2006 12:08 pm Reply with quote

Do you have a redirect in htaccess?
 
View user's profile Send private message Visit poster's website
wiz
PostPosted: Thu Nov 23, 2006 12:11 pm Reply with quote

i havent touched the Sentinel settings yet. I just got it up with the theme. working ok, built a test forum, and started moving blocks around. No custom files have been added yet, or script alterations. Just noticed actually. It is not limited to admin.php, also index.php has the same effect
 
fkelly
PostPosted: Thu Nov 23, 2006 12:30 pm Reply with quote

Just look at .htaccess in an editor thru Cpanel or Vdeck or FTP or whatever you have that will let you look at it. It's possible that you have a redirect in there that's sending everything to your old site. It's just a possibility to rule out. And you don't need Sentinel to have that happening.
 
wiz
PostPosted: Thu Nov 23, 2006 12:53 pm Reply with quote

htaccess contains 1 line

Deny from all
 
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Thu Nov 23, 2006 2:30 pm Reply with quote

Is that the .htaccess file in the root of your RN installation?

Because if you are running RN you should have a bit more than 1 line. Confused
 
View user's profile Send private message
wiz
PostPosted: Thu Nov 23, 2006 2:32 pm Reply with quote

Well yeh, cos its my 2nd RN install i was wondering why it doesnt contain much.
However i have played with the other site quite a lot since install.
 
jakec
PostPosted: Thu Nov 23, 2006 2:35 pm Reply with quote

I'm just wondering if somethings gone amiss.
 
wiz
PostPosted: Sat Nov 25, 2006 7:36 am Reply with quote

something is not right for sure. Ive checked admin.php and config.php etc etc. And i cant see for the life of me why it would re-direct to the actual root, rather than the sub-folder that this install is in.
I told ya it was wired Very Happy
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Sat Nov 25, 2006 12:09 pm Reply with quote

Would this be a site you 'moved' or 'copied' from another location?
It seems to me the nukeurl variable might be wrong.
As you cannot access admin.php directly you might want to check the nuke_config table and see what is in there for the site url.
If that needs altering, you will need to do the same for the nukebb_config table
 
View user's profile Send private message Send e-mail
wiz
PostPosted: Sat Nov 25, 2006 12:29 pm Reply with quote

No Guardian

I have my site running, but not using php-nuke. I decide RN is quite nice, so i upload RN76 to a sub-folder, and start building a new site in there, ready to swap over when its finished.
I will check the config.php though, it sounds like a logical reason for an un-expected re-direct
 
wiz
PostPosted: Sat Nov 25, 2006 12:51 pm Reply with quote

OK an update

I kinda fixed it, by deleting all and starting again, this time in the root, however i have renamed the index.php to index1.php

The issue now is that its not sending activation emails out.
 
Guardian2003
PostPosted: Sat Nov 25, 2006 12:57 pm Reply with quote

Then you'll need to check with your host to see if php mail is enable.
If you are using a free host, this has probably been disabled
 
wiz
PostPosted: Sat Nov 25, 2006 12:59 pm Reply with quote

Dont know about php mail, i know webmail is activated, and Nuke 7.8 is available in fantastico.

Its definatly not free hosting tho Very Happy
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sat Nov 25, 2006 6:24 pm Reply with quote

Webmail? If you are using the Webmail module inside phpNuke, it is seriously old and vulnerable to hacks. You should delete it immediately.

The local mail() function is something that your host has to check and make sure it is enabled Only registered users can see links on this board! Get registered or login!

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
wiz
PostPosted: Sat Nov 25, 2006 6:27 pm Reply with quote

Noooooo

All i meant was my server uses webmail. I dont know how RN authorises accounts. Anyway i can turn that verification off?
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©