Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> PHP-Nuke Patched Series By Chatserv
Author Message
evaria
New Member
New Member


Joined: Mar 07, 2005
Posts: 10

PostPosted: Sat Oct 28, 2006 6:32 pm Reply with quote

Hi all,

I am having a problem with7.6.0.3.2b It seems that whenever I post something in content that contains HTML it adds slashes. When you initially submit an article to the content module it's fine. However if you go back and edit it all of a sudden there will be 3 slashes like below.

Code:
<img src="\\\ddwd/tarponflats.jpg\\\" width="\\\300\\\" height="\\\400\\\" align="\\\right\\\">


If you try and edit it a second time there will be 6.

I am sure this has been asked and answered before so I apologize if it's a duplicate post but after 3 days of looking and trying to fix it. I am at my wits end.

Please help before I lose what little of my mind I have remaining.

Thank you in advance
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sat Oct 28, 2006 11:52 pm Reply with quote

Disable magic_quotes_gpc - either you can do it through .htaccess or your host has to do it through php.ini (Some hosts may not change this setting)

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
evaria
PostPosted: Sun Oct 29, 2006 8:07 am Reply with quote

Thank you evaders, problem is this, my so called host refuses to do this and I have no idea how to to it using .htaccess

I tried searching it out on the web, got me nowhere.
 
evaria
PostPosted: Sun Oct 29, 2006 8:26 am Reply with quote

Nevermind evaders. I figured it out. I downloaded 7.6.0.3.3 patch. I didn't realize there even was a new patch. Uploaded the content mod and viola it's working fine.

Thank you for helping though.

I would still be interested in learning about turning off the magic_quotes if you don't mind.
 
evaders99
PostPosted: Sun Oct 29, 2006 10:20 pm Reply with quote

The new patched does some extra stripslashes to fix this problem. It really isn't the best approach.

You may consider turning off magic_quotes_gpc using .htaccess

Place this line in your .htaccess file
Code:


PHP_FLAG magic_quotes_gpc Off
 
brewski
New Member
New Member


Joined: Jan 20, 2007
Posts: 3

PostPosted: Tue Jan 30, 2007 7:47 am Reply with quote

Started my own similar, but maybe slightly different thread.
 
View user's profile Send private message
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> PHP-Nuke Patched Series By Chatserv

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©