Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes
Author Message
hireamerica
Client


Joined: Sep 30, 2004
Posts: 103
Location: New Jersey

PostPosted: Tue Oct 10, 2006 9:00 pm Reply with quote

I've been looking into this on my site: Only registered users can see links on this board! Get registered or login!

Polls: The Poll Results use a header location redirect and never completes. Firefox, IExplorer both yield same result. My members all say the same (e.g., it's not my ISP, firewall if it happens to all.

Banners:

Banners don't open.. banners.php has very simple code for op = click. Header location again. New window opens: Firefox timesout and tries to open localhost, IExplorer just dies.

Wondering what can be the issue... I don't see this as a particult PHP Nuke version issue, as banners.php and poll results code hasn't changed.

Also, when I run local version with Apache/MySQL I have no issues with re-directs...only on hosted site (sorry Gaylen!)
 
View user's profile Send private message Visit poster's website Yahoo Messenger
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9455
Location: Arizona

PostPosted: Tue Oct 10, 2006 9:32 pm Reply with quote

Actually, are you on the latest 3.2b/3.3 patches from Chat? I had these fix a couple of other things.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
hireamerica
PostPosted: Tue Oct 10, 2006 9:36 pm Reply with quote

Oohh...good call, but now I can't seem to find them.

nukeresources.com gone?
 
hireamerica
PostPosted: Tue Oct 10, 2006 10:36 pm Reply with quote

Well, I found 3.2 for my 7.9...fixed the Poll/Survey redirect, but did nothing to the banners issue.

All my banners error out like the Polls used to. Anyone want to click on my banners at the bottom of my main page? Only registered users can see links on this board! Get registered or login!
 
montego
PostPosted: Wed Oct 11, 2006 6:40 am Reply with quote

Try something here. Either comment out NukeSentinel in mainfile.php, or turn it off temporarily (depends on your NS version) and quickly check to see if it works. I want to rule out the extra NSNST_FLOOD session id that is being tagged onto the end of the link.

If that works, you may want to consider upgrading to NS 2.5.02, which I think no longer appends that to the URL string (not certain, but an educated guess).
 
hireamerica
PostPosted: Wed Oct 11, 2006 7:57 am Reply with quote

Thanks, but it's definitely not NS.

NS doesn't consistently append the Flood URL, so I've seen clean/clear URLs.

Note: All my banners go through LinkShare which resolves to LinkSynergy, but they are indicating no problems, and when I run a local version of my site, my clicks open fine into the banner sites.

Since all the banners execute index.php op = click here is my code...perhaps it's something there?

====

if (isset($op) AND ($op == "ad_click") AND isset($bid)) {
$bid = intval($bid);
$sql = "SELECT clickurl FROM ".$prefix."_banner WHERE bid='$bid'";
$result = $db->sql_query($sql);
list($clickurl) = $db->sql_fetchrow($result);
$clickurl = filter($clickurl, "nohtml");
$db->sql_query("UPDATE ".$prefix."_banner SET clicks=clicks+1 WHERE bid='$bid'");
update_points(21);
Header("Location: ".addslashes($clickurl));
die();
}

======
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Bug Fixes

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©