Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
burzurk
New Member
New Member


Joined: Oct 03, 2006
Posts: 9

PostPosted: Sat Oct 07, 2006 12:22 pm Reply with quote

Ok the sites are working now and the theme is getting there, i transferred from a 6.5 production site to the Raven 7.6 2.02.02 distro and then upgraded the forums to 2.0.21
Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login!

Is there any easy way to transfer members from the 6.5 site to the 7.6 site? If it's just mapping the tables from one to the other and some sql then I may be able to do it.

Also need to do the same thing with the previous posts...

Are there too many different fields or new encryptions in the new tables preventing me from moving to the new one?

not much of an admin or mySQL guy but I can figure it out....

thanks, BurZ-
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Sat Oct 07, 2006 12:37 pm Reply with quote

Forget updating the forums until the site is working ok.
You may need to apply the upgrade sql files to bring your 6.5 table schema into line with the 7.6 one
 
View user's profile Send private message Send e-mail
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Mon Oct 09, 2006 10:24 am Reply with quote

Note that the next version of RavenNuke will include 2.0.21 forums. However, this current one should have 2.0.20 already.

Run the phpNuke upgrade scripts to get up to 7.6. Then run the RavenNuke installer to install NSN Groups and Nuke Sentinel tables only.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Mon Oct 09, 2006 11:51 am Reply with quote

Just to add a perhaps unnecessary note of caution. Make sure you have a good back up of your tables before starting.

And when you run the Ravennuke installer make SURE that you don't run the core tables update ... in other words follow what Evaders said literally. The core tables routine drops all the tables before it starts building new ones.
 
View user's profile Send private message Visit poster's website
wiz
Involved
Involved


Joined: Oct 09, 2006
Posts: 413
Location: UK

PostPosted: Tue Oct 10, 2006 6:19 pm Reply with quote

For the members..

Drop the Nuke_users table.
Then import your old Nuke_users table

(assuming that your using something like PhpMyadmin)
 
View user's profile Send private message Visit poster's website AIM Address
Guardian2003
PostPosted: Tue Oct 10, 2006 6:25 pm Reply with quote

wiz wrote:
For the members..

Drop the Nuke_users table.
Then import your old Nuke_users table

(assuming that your using something like PhpMyadmin)

Caveat: You must use the same God user/password combination during setup as you have in your old back-up.
 
wiz
PostPosted: Tue Oct 10, 2006 6:32 pm Reply with quote

yes, ill second that. However i dont think it really matters for importing the Nuke user accounts. But it definatly does if your importing your Nuke Admins (nuke_authors table)
 
Guardian2003
PostPosted: Tue Oct 10, 2006 6:38 pm Reply with quote

Thats correct. The caveat is based on the fact that during the install process, Sentinel will add the God user/pass to the 'protected range' and there is a slim chance that you might accidentally ban yourself from an admin link if you forget to update that if the imported God user/pass from a table back-up is different.
 
evaders99
PostPosted: Tue Oct 10, 2006 10:56 pm Reply with quote

Quote:

For the members..

Drop the Nuke_users table.
Then import your old Nuke_users table


Given that there are changes to the users table (esp from a version jump 6.5 to 7.6), I don't recommend this method. The upgrade scripts are prefered to get the necessary database changes.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©