Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
devkinetic
New Member
New Member


Joined: Sep 18, 2006
Posts: 1

PostPosted: Sun Sep 24, 2006 9:32 pm Reply with quote

hi i installed this disto just like the guide said, but i don't seem to have any right side blocks... i tried changing the theme a few times too

speedtype> Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Mon Sep 25, 2006 4:50 am Reply with quote

whitch themes?
The ones that comes with ravennuke or the ones you uploaded?
 
View user's profile Send private message
Doulos
Life Cycles Becoming CPU Cycles


Joined: Jun 06, 2005
Posts: 626

PostPosted: Mon Sep 25, 2006 12:06 pm Reply with quote

Most of the time I have found that this is a result of the theme not being compatible with the current patched versions of nuke. I found a fix for right side blocks not showing here in the RN forums:
1. in the /* Function themefooter() part of theme.php
find:
Code:
if ($index == 1) {

and change it to:
Code:
if (defined('INDEX_FILE')) {


2. occasionally I have come across a theme that does not contain that particular bit of code refering to right blocks, in that case you may be able to fix it by copying this code :
Code:
if (defined('INDEX_FILE')) { 

echo"</td><td width=\"183\" valign=\"top\">\n";
blocks(right);
}

and adding it in the /* Function themefooter() part of theme.php
immediately following the line that contains this code:
Code:
global $index, $banners ...


Depending on how the theme was written either one or the other of these worked to put right side blocks back on all the themes I have tried.
Note: I am not a php programmer so I don't know what I did -- only that it worked. Smile
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Sep 26, 2006 5:35 am Reply with quote

Ezekiel pretty much covered it, but I wanted to point out that there are also FAQs which address many of the common questions:
Only registered users can see links on this board! Get registered or login!

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
dogpowell
Regular
Regular


Joined: Oct 01, 2006
Posts: 50
Location: UK

PostPosted: Tue Nov 28, 2006 4:26 am Reply with quote

I have tried both of these hacks and I still am unable to get my right blocks working.
The blocks and related modules are active.

Any further ideas ?

PP- I am using ravens 2.02.02 with an early version of fisubice on a new install. I've not had this problem before with sites.
 
View user's profile Send private message
montego
PostPosted: Tue Nov 28, 2006 6:46 am Reply with quote

Why are you using this and not the fisubice theme which comes with the distribution (that one works!):

Quote:

with an early version of fisubice on a new install
 
dogpowell
PostPosted: Tue Nov 28, 2006 7:16 am Reply with quote

montego wrote:
Why are you using this and not the fisubice theme which comes with the distribution (that one works!):

Quote:

with an early version of fisubice on a new install


Because the version I have has been modified and don't look like fisubice

Crying or Very sad I don't really want to use another version
 
dogpowell
PostPosted: Tue Nov 28, 2006 7:23 am Reply with quote

Right. I have removed my version and replaced it with a full original version that comes packed with Ravens 2.02.02 NO MODIFICATIONS.


Still won't work ??????
 
montego
PostPosted: Tue Nov 28, 2006 7:37 am Reply with quote

1) make sure its using the new theme

2) have you made any changes to mainfile.php or header.php?

3) what module(s) are you testing this with? Which one is not working for you?

I can say with 100% certainty that the core 2.02.02 distribution fisubice theme works (been time-tested by many). If Downloads doesn't show the right-hand blocks, then you have modified something which is causing this, so you may need to backtrack what you have changed.
 
dogpowell
PostPosted: Tue Nov 28, 2006 8:55 am Reply with quote

montego wrote:
1) make sure its using the new theme

2) have you made any changes to mainfile.php or header.php?

3) what module(s) are you testing this with? Which one is not working for you?

I can say with 100% certainty that the core 2.02.02 distribution fisubice theme works (been time-tested by many). If Downloads doesn't show the right-hand blocks, then you have modified something which is causing this, so you may need to backtrack what you have changed.



This is a brand new install. Nothing has been modified yet. The only thing I have added is to 'forums/index.php' for number of new posts.
The original theme has been completly restored and I have removed my old version. The blocks won't show at all. I have tried adding surveys, total hits, links, downloads and just about every block available and nothing shows on the right yet they all work on left or center.

All normal modules are active and the ones I don't want are active but admin only.

I'm stumped.
I have removed howtoinstall, INSTALLATION, Experimental and import folders from server but I cannot see that would affect it.
 
dogpowell
PostPosted: Tue Nov 28, 2006 10:13 am Reply with quote

D'Oh

Just worked out the ftp hadn't uploaded footer.php correctly

Thanks for help though
 
montego
PostPosted: Tue Nov 28, 2006 9:25 pm Reply with quote

Well, my next comment was going to be "did everything get uploaded properly". I guess that is easy for me to say now.

ROTFL

Glad you're up and running!
 
Doulos
PostPosted: Wed Nov 29, 2006 2:00 pm Reply with quote

dogpowell wrote:
D'Oh

Just worked out the ftp hadn't uploaded footer.php correctly

Thanks for help though


Yep. #2 in my list of "probable reasons why my site won't do what I tell it to".

Most of my posts could have been avoided if I would have properly verified each file I ftp'd.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©