Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
bugges
New Member
New Member


Joined: Nov 22, 2005
Posts: 4

PostPosted: Mon Sep 18, 2006 9:20 am Reply with quote

I'm running RavenNuke's 7.6 2.02 and am having a problem getting the Flash player controls to show up in the news module and other modules as well. It works fine outside of my nuke site. See samples:

Image

Image

Tested in both IE and firefox and both didn't work. Windows server, Apache and php 5.04. The flash file itself plays fine, If I navigate to it directly on the web server it works fine as well. Thanks in advance.
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Mon Sep 18, 2006 3:52 pm Reply with quote

I don't think this is a Raven Nuke specific issue, its more likely to be core nuke.
Are the player controls java or somthing else?
Do they need to be embedded?
Are the tags you need 'allowed' in the 'allowed html array' which you can find in config.php or mainfile.php (forget which).
 
View user's profile Send private message Send e-mail
bugges
PostPosted: Mon Sep 18, 2006 5:21 pm Reply with quote

I found a solution for it, which doesn't make alot of sense but seems to work. The player controls are a seperate .swf file that is called from the .fla, I believe. I don't think it's java unless it's in the .fla file. The solution was this:

My .swf and .fla files were located in root/images/Flash/xxxx.swf

This included myflash.swf, steelExternalAll.swf (The player controls), and myflash.fla. I only had to call the myflash.swf to have it show up in the news article, the flash worked fine but did not include the player controls.

All I did was copy the steelExternalAll.swf (Player Controls) to the root of the web site and it worked perfectly in IE 6.0 and Firefox.

Thanks very much for the reply, I hoope others can take advantage of this solution.
 
Guardian2003
PostPosted: Mon Sep 18, 2006 5:23 pm Reply with quote

Thanks for the update Smile
 
loraxx
Regular
Regular


Joined: Jan 24, 2008
Posts: 58

PostPosted: Thu Mar 13, 2008 9:48 am Reply with quote

I have the exact problem mentioned regarding buttons not showing up. However, where do I get the button file?

Acutally this is my starting point.

I have a video.swf on a remote url

I add this video.swf to news story on home page

I use insert flash via raven editor

all good but no control buttons just a blank space like buggs image above

how do I add control buttons? where do I gets the files that have the control button information?


Many thanks
 
View user's profile Send private message
bugges
PostPosted: Fri Mar 14, 2008 5:57 am Reply with quote

I created the video.swf file so I had all the files and control over which buttons to use in the swf file. You are using it from a remote site so you don't have that information. I'd suggest you play around with flash to discover which buttons were used, create your own with a different video and the same buttons as the other author and see if your files work as a subsitute by adding them as mentioned as above.
 
loraxx
PostPosted: Fri Mar 14, 2008 11:16 am Reply with quote

Given the code from the swf source can you tell which buttons?

Also what SW would you recommend to make a swf movie/video if I don't want to spend much kaching!? Any go freeware??

THANKS !!!

Code:
           <td width="390" align="right" valign="top"><table width="390" border="0" align="right" cellpadding="0" cellspacing="20">

                <tr>
                  <td height="330" colspan="2" align="center" valign="middle" bgcolor="#705D3E"><!-- InstanceBeginEditable name="EditRegion3" -->
                    <script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','390','height','330','src','http://www.site.org/movie','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','http://www.site.org/movie' ); //end AC code
                    </script>
                    <noscript>
                    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="390" height="330">
                      <param name="movie" value="http://www.site.org/movie.swf" />
                     
                      <embed src="http://www.site.org/movie.swf" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="390" height="330"></embed>
                    </object>
                    </noscript>
                  <!-- InstanceEndEditable --></td>
                </tr>
                <tr>
 
bugges
PostPosted: Fri Mar 14, 2008 6:30 pm Reply with quote

I don't see code for the buttons in there. A link to the movie might help.

I used Macromedia Flash 8. You'll have to play with the others and find one you like.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©