Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's Collapsing Forums Block
Author Message
Meoff
Regular
Regular


Joined: Aug 05, 2006
Posts: 55
Location: Thailand

PostPosted: Thu Aug 24, 2006 11:54 am Reply with quote

I've been searching for the answer to this, but can't find it.

I want to remove the "Forum Title" from the first column of the expanded list, leaving only the Topic Title visible. Reason being- my customer has some long a$$ed forum names, which run to several lines in the first column, and it is difficult to read.

What do I need to take out of the Block code to accomplish this?

Thanks in advance!
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Aug 25, 2006 6:12 am Reply with quote

=== FIND ====

Code:


if (!$hideLinksFromGuests||is_admin($admin)||is_user($user)) {
$content .= <<<_JS_
   tickercontents[$cnt] = "<tr><td width=\"60%\" bgcolor=\"$bgcolor1\" class=\"row1\"><a href=\"modules.php?name=Forums&file=viewforum&f=$forum_id\" title=\"$forum_name\"><span style=\"text-decoration:none;font-style: italic\">[$cat_title:&nbsp;$forum_name]<\/span><\/a><br /><a href=\"modules.php?name=Forums&file=viewtopic&t=$topic_id\" title=\"$topic_title\"><span style=\"text-decoration:none;\">&nbsp;$lockTopic$topic_title<\/span><\/a><\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_replies<\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row3\" width=\"20%\"><a href=\"forum-userprofile-.html$sifra\">$_avtor<\/a><\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_views<\/td><td align=\"center\" nowrap bgcolor=\"$bgcolor1\" class=\"row3\"><font size=\"-2\" width=\"10%\"><i>&nbsp;&nbsp;$post_time&nbsp;<\/i><\/font><br><a href=\"forum-userprofile-.html$user_id\">$_username<\/a>&nbsp;<a href=\"modules.php?name=Forums&file=viewtopic&p=$topic_last_post_id#$topic_last_post_id\"><img src=\"images/blocks/icon_minipost_new.gif\" alt=\"Last Post\" border=\"0\" \/><\/a><\/td><\/tr>";
_JS_;
}
else {
$content .= <<<_JS_
   tickercontents[$cnt] = "<tr><td width=\"60%\" bgcolor=\"$bgcolor1\" class=\"row1\"><a href=\"modules.php?name=Forums&file=viewtopic&p=$topic_last_post_id#$topic_last_post_id\" title=\"$topic_title\"><span style=\"text-decoration:none;font-style: italic\">[$cat_title:&nbsp;$forum_name]<\/span><br />&nbsp;$lockTopic$topic_title<\/a><\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_replies<\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row3\" width=\"20%\">$_avtor<\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_views<\/td><td align=\"center\" nowrap bgcolor=\"$bgcolor1\" class=\"row3\"><font size=\"-2\" width=\"10%\"><i>&nbsp;&nbsp;$post_time&nbsp;<\/i><\/font><br>$_username<\/td><\/tr>";
_JS_;
}


=== REPLACE WITH ====

Code:


if (!$hideLinksFromGuests||is_admin($admin)||is_user($user)) {
$content .= <<<_JS_
   tickercontents[$cnt] = "<tr><td width=\"60%\" bgcolor=\"$bgcolor1\" class=\"row1\"><a href=\"modules.php?name=Forums&file=viewforum&f=$forum_id\" title=\"$forum_name\"><span style=\"text-decoration:none;font-style: italic\">[$forum_name]<\/span><\/a><br /><a href=\"modules.php?name=Forums&file=viewtopic&t=$topic_id\" title=\"$topic_title\"><span style=\"text-decoration:none;\">&nbsp;$lockTopic$topic_title<\/span><\/a><\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_replies<\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row3\" width=\"20%\"><a href=\"forum-userprofile-.html$sifra\">$_avtor<\/a><\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_views<\/td><td align=\"center\" nowrap bgcolor=\"$bgcolor1\" class=\"row3\"><font size=\"-2\" width=\"10%\"><i>&nbsp;&nbsp;$post_time&nbsp;<\/i><\/font><br><a href=\"forum-userprofile-.html$user_id\">$_username<\/a>&nbsp;<a href=\"modules.php?name=Forums&file=viewtopic&p=$topic_last_post_id#$topic_last_post_id\"><img src=\"images/blocks/icon_minipost_new.gif\" alt=\"Last Post\" border=\"0\" \/><\/a><\/td><\/tr>";
_JS_;
}
else {
$content .= <<<_JS_
   tickercontents[$cnt] = "<tr><td width=\"60%\" bgcolor=\"$bgcolor1\" class=\"row1\"><a href=\"modules.php?name=Forums&file=viewtopic&p=$topic_last_post_id#$topic_last_post_id\" title=\"$topic_title\"><span style=\"text-decoration:none;font-style: italic\">[$forum_name]<\/span><br />&nbsp;$lockTopic$topic_title<\/a><\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_replies<\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row3\" width=\"20%\">$_avtor<\/td><td align=\"center\" bgcolor=\"$bgcolor1\" class=\"row2\" width=\"5%\">$topic_views<\/td><td align=\"center\" nowrap bgcolor=\"$bgcolor1\" class=\"row3\"><font size=\"-2\" width=\"10%\"><i>&nbsp;&nbsp;$post_time&nbsp;<\/i><\/font><br>$_username<\/td><\/tr>";
_JS_;
}


Regards.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Meoff
PostPosted: Fri Aug 25, 2006 8:36 am Reply with quote

Hi montego-

Thanks for your reply!

I followed your instructions and made the modification you suggested. I found the exact lines with no problem, and replaced them using Crimson Editor.

When I uploaded the modded file, the ForumsCollapsing block would not load, and it caused the rest of the page to stop loading also... all blocks underneath and right hand side.

Could you be kind enough to have a look at it again / double check for me? I'm by no means smart enough to figure out whee it is going wrong on my own!

Much obliged.....

Meoff
 
montego
PostPosted: Sat Aug 26, 2006 6:20 am Reply with quote

You need to get a good text editor. Although I have never used Crimson Editor, I think that I have heard of issues like this with it. Don't use notepad or wordpad either. I would try TextPad or search here for other editors. It has introduced characters causing issues.

Send your original version file to me at montego {AT} montegoscripts __DOT__ com and I'll get this done for you.
 
Meoff
PostPosted: Sat Aug 26, 2006 7:49 am Reply with quote

Hi montego,

I downloaded TextPad and tried to do it myself, and got the same result.

Hence- I have sent the file to you- from rs {AT} bkkok __DOT__ com.

Your help is much appreciated! You're a prince among the common people!

Rgds,

Meoff
 
montego
PostPosted: Sat Aug 26, 2006 8:13 am Reply with quote

I just sent it back... and it is tested on my local site.
 
Meoff
PostPosted: Sat Aug 26, 2006 10:21 am Reply with quote

Hi montego-

Sad to say that the block you have modified and sent to me causes the same problem.... won't load and prevents all of the subsequent blocks / right side content from loading.

Could it be something to do with my PHPNuke setup? I'm using RavenNuke76_v2.02.02, which was originally PHPnuke 7.8 before downgrading.

Any suggestions would be welcome!

Rgds,
Meoff
 
montego
PostPosted: Sat Aug 26, 2006 11:32 am Reply with quote

Meoff,

This worked perfectly in my own RavenNuke 2.02.02 environment. There must be some other conflict with another block or code that you have employed on this site. You could try disabling other blocks one-by-one until you find the one causing the conflict.

I tried... Sad

montego
 
Meoff
PostPosted: Mon Aug 28, 2006 12:02 pm Reply with quote

Definitely appreciate the effort Montego...

I figured out how to change the text color of the Topic line to make it stand out / easier to read. Can live with that.

Tks again for trying!

Meoff
 
ahmedbahgat
New Member
New Member


Joined: Apr 03, 2007
Posts: 5

PostPosted: Tue Apr 03, 2007 9:49 pm Reply with quote

Hello

I have removed the forum title link in the forum block, you can see it in here, if you are interested, please let me know and I will post the mod : Only registered users can see links on this board! Get registered or login!


btw I tried to implement the mod by Meoff and had the same problem, nevertheless I appreciate his try

Cheers
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's Collapsing Forums Block

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©