Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> GT - Raven's RavenNuke(tm) v2.x Distro
Author Message
Isaiah
Hangin' Around


Joined: Nov 09, 2004
Posts: 32

PostPosted: Tue Jun 27, 2006 5:13 am Reply with quote

Hi there,

I experienced the following problem :

My site's forum links are looking like this :
Only registered users can see links on this board! Get registered or login!

instead of
Only registered users can see links on this board! Get registered or login!


Is this a problem, is it danger or not?
And how i can get rid of &sid=.... ?

I browsed a couple of googletaped nuke forums,
and all of them has no this &sid....
 
View user's profile Send private message
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Tue Jun 27, 2006 5:57 am Reply with quote

Are you running ravennuke?

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
Isaiah
PostPosted: Tue Jun 27, 2006 6:08 am Reply with quote

yes
 
gregexp
PostPosted: Tue Jun 27, 2006 6:25 am Reply with quote

Ok, I was just asking to find out if this was in the right forum or not.
 
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Tue Jun 27, 2006 6:29 am Reply with quote

well that doesnt help much darklord...
 
View user's profile Send private message
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Tue Jun 27, 2006 6:43 am Reply with quote

I seem to remember this happening to me. I couldn't figure out what was causing it and it only seemed to happen on my computer, but I wasn't using GoogleTap.

Does it do it on other computers?

I managed to fix it somehow, but I can't remember how I did it. Have you tried clearing out your Cookies and History etc.?
 
View user's profile Send private message
Isaiah
PostPosted: Tue Jun 27, 2006 6:48 am Reply with quote

Hi Jakec,

Yes, i clean everything, it happens to all users,
i think it has to do something with the user sessions or the append sid function.

I tried to edit a lot of nuke files to find the &sid reference,
but didn't found anything...
 
hitwalker
PostPosted: Tue Jun 27, 2006 6:49 am Reply with quote

yeah its caused by googletap but ive seen/read a few "solutions" but its very unclear whitch one works..
for some this works but is based on phpbb standalone....


Find the the function append_sid and replace it with:
in Sessions.php
Code:



function append_sid($url, $non_html_amp = false)
{
global $SID;


if ( !empty($SID) && !preg_match('#sid=#', $url) && !stristr( $_SERVER["HTTP_USER_AGENT"] ,'bot') && !stristr($_SERVER["HTTP_USER_AGENT"] ,'inktomi'))
{
$url .= ( ( strpos($url, '?') != false ) ? ( ( $non_html_amp ) ? '&' : '&' ) : '?' ) . $SID ;
}

return $url;
}


i haven't tried it...
 
Isaiah
PostPosted: Tue Jun 27, 2006 6:51 am Reply with quote

hitwalker wrote:
yeah its caused by googletap but ive seen/read a few "solutions" but its very unclear whitch one works..
for some this works but is based on phpbb standalone....


Find the the function append_sid and replace it with:
in Sessions.php
Code:



function append_sid($url, $non_html_amp = false)
{
global $SID;


if ( !empty($SID) && !preg_match('#sid=#', $url) && !stristr( $_SERVER["HTTP_USER_AGENT"] ,'bot') && !stristr($_SERVER["HTTP_USER_AGENT"] ,'inktomi'))
{
$url .= ( ( strpos($url, '?') != false ) ? ( ( $non_html_amp ) ? '&' : '&' ) : '?' ) . $SID ;
}

return $url;
}


i haven't tried it...


Thanks hitwalker,
but to which file is this function?
 
hitwalker
PostPosted: Tue Jun 27, 2006 6:53 am Reply with quote

in Sessions.php
BACKUP WHATEVER YOUR GONNA DO Smile
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Tue Jun 27, 2006 6:55 am Reply with quote

The original instructions for GT-NExtGEn have the edits to make to sessions.php in them to stop this, for most search engines.

Is this happening only when you are browsing the forums as anonymous or when you are actually logged in, or both?

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Isaiah
PostPosted: Tue Jun 27, 2006 7:03 am Reply with quote

Actually i made the forum only for registered users.

Anyway,
This one method Hitwalker wrote didn't worked,
but i removed this :

if ($userdata['user_level'] > 1) {
if ( !empty($SID) && !eregi('sid=', $url) )
{
if ( !empty($SID) && !eregi('sid=', $url) ) {
$url .= ( ( strpos($url, '?') != false ) ? ( ( $non_html_amp ) ? '&' : '&' ) : '?' ) . $SID;
}
}
}


From my sessions.php file and the problem has been solved.
 
montego
PostPosted: Tue Jun 27, 2006 7:05 am Reply with quote

Well, I am no phpBB expert, so cannot tell you what the impact of doing that is... Hopefully none.
 
hitwalker
PostPosted: Tue Jun 27, 2006 7:10 am Reply with quote

im surely not gonna recommend thats the right way...

but after editing the sessions.php as written in the gt file i end up with ..

Parse error: syntax error, unexpected $end in /home/public_html/includes/sessions.php on line 965

but weird cause thats the php closing tag..
 
hitwalker
PostPosted: Tue Jun 27, 2006 7:32 am Reply with quote

i tried a few so called solutions but non of them work,and yes Isaiah...taking out the few lines you posted does indeed solve the problem but uncertain is what the effect would be in general..
 
Isaiah
PostPosted: Tue Jun 27, 2006 7:39 am Reply with quote

Yes, correct.

I will leave it like this for now,
let's hope that there will not be any problem.

Thanks for driving me to edit the correct file!
 
hitwalker
PostPosted: Tue Jun 27, 2006 7:56 am Reply with quote

no prob...
but member susann spend a lot of time diggin into this problem so i send a pm to her..
see what she found ...
 
gregexp
PostPosted: Tue Jun 27, 2006 8:30 am Reply with quote

if ($userdata['user_level'] > 1) {
if ( !empty($SID) && !eregi('sid=', $url) )
{
if ( !empty($SID) && !eregi('sid=', $url) ) {
$url .= ( ( strpos($url, '?') != false ) ? ( ( $non_html_amp ) ? '&' : '&' ) : '?' ) . $SID;
}
}
}

if im reading this correctly, this is the problem, what it seems to do is add the sid part into the url and direct u to the correct post, It seems to strip or verify that it is the correct url.
I dont know enough about the coding to change it to verify that it the url is correct with googletap installed.
Hopefully this is not a security issue.

Hitwalker, I asked because it didnt seem to be directly caused by a ravennuke code and I searched for a solution as I'm sure others did and could find a lot of responses but could offer no solution as it seems that I could not find one that was definitley as solution, so instead of running in circles, I stopped there and was trying to allow someone with more knowledge on this issue to post with somethin more valuable then a list of possible solutions.
Glad you and the others were able to help.
 
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Tue Jun 27, 2006 10:47 am Reply with quote

Well, there are different ways to get rid of the sid. I´m using a solution based on several different posts from nukecops.com for Nuke 6.5.
Only registered users can see links on this board! Get registered or login!


This modified sessions.php doesn´t work for RavenNuke and phpBB 2.0.21. but I´hope and believe that Montego is able to give the code to mask or remove the SIDs from the official GT RavenNuke version. Still there i no official GT RN version out. Smile
If you like to check your site just use the spider simulator and choose google:
Only registered users can see links on this board! Get registered or login!


Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
hitwalker
PostPosted: Tue Jun 27, 2006 3:37 pm Reply with quote

well its not that clear susann...
as far as i could find out everybody agrees on one thing....
the sid su..s and can realy harm your site...
so question is,any valid way know to remove it...
 
Susann
PostPosted: Tue Jun 27, 2006 4:10 pm Reply with quote

Sure, but you better ask Raven, djmaze or Montego and it´s a difference to remove the sids or just mask them for bots.
I haven´t tried this because my Raven Nuke website isn´t google tapped.


Last edited by Susann on Tue Jun 27, 2006 4:18 pm; edited 1 time in total 
hitwalker
PostPosted: Tue Jun 27, 2006 4:16 pm Reply with quote

well i doubt if anyone knows it ....
otherwise we would have a clear answer to it....lol
 
montego
PostPosted: Tue Jun 27, 2006 8:50 pm Reply with quote

Yeah, I don't know for certain either. I have worked into the RN2.10.00 release a "ShortLinks" type code based mostly off the GT-NExtGEn concept, but really struggled with the sessions.php code they provided. I think that portion will need some follow-on work.

I'll get to it eventually, but I just did not get the feeling like it was still an issue with the later phpBB versions. Like I said, more research is forthcoming, but not quickly...
 
hitwalker
PostPosted: Wed Jun 28, 2006 3:56 am Reply with quote

i dont mind waiting,but im curious to know if there's realy a negative thing about removing the few lines like Isaiah did ....
 
montego
PostPosted: Wed Jun 28, 2006 5:59 am Reply with quote

Without serious testing, I dont know either. phpBB to me is a "tangled web" that needs to be "unraveled" before I can feel confident in anything I say about the sid. Sorry.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> GT - Raven's RavenNuke(tm) v2.x Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©