Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke
Author Message
myrtletrees
Involved
Involved


Joined: Sep 13, 2005
Posts: 259
Location: Cornfields of Indiana

PostPosted: Tue Jun 20, 2006 5:16 pm Reply with quote

I have a problem with the security image in Nuke.
Running Nuke 7.6 pl3.2 Forums 2.0.21

The security code image works on the admin login, a CZuser info block we use, but it does NOT work on ANY of the Your Account pages. Login, register or what-not.
 
View user's profile Send private message
gregexp
The Mouse Is Extension Of Arm


Joined: Feb 21, 2006
Posts: 1497
Location: In front of a screen....HELP! lol

PostPosted: Tue Jun 20, 2006 5:40 pm Reply with quote

ok does it show a red x?

_________________
For those who stand shall NEVER fall and those who fall shall RISE once more!! 
View user's profile Send private message Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger ICQ Number
myrtletrees
PostPosted: Tue Jun 20, 2006 9:28 pm Reply with quote

no, it just shows the Alt ot title text:

Security Code
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Wed Jun 21, 2006 6:30 am Reply with quote

myrtletrees, since I have no link to your site, I cannot check this... Wink but is your site using some form of GoogleTap?

Also, I assume you have already read this site's FAQ regarding the security image not showing and have exhausted those checks.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
myrtletrees
PostPosted: Wed Jun 21, 2006 7:02 am Reply with quote

So, considering the graphic image works on the admin login, and CZuser info block, then it must have something to do the with the Your Account module files. I never edit my files with anything other than UltraEdit.
As far as spaces in the php files, there are plenty of spaces, but none before or after the opening or closing php tags.

Here is a link. I've activated the Security image for the moment so you can see. When you go to the Your Account page it also kills the Security image in the User INfo block, but if you leave the Your Account page, the security image re-appears in the User Info block.
Only registered users can see links on this board! Get registered or login!

Oh and YES it is Google Tapped.
 
montego
PostPosted: Wed Jun 21, 2006 7:15 am Reply with quote

Quote:

Oh and YES it is Google Tapped.


Then that could be the issue. Try this:

Add the following to your GT-Your_Account.php urlin array:

'"(?<!/)\?gfx=gfx&amp;random_num=([0-9]*)"',


Add the following to your urlout array:

'account-gfx-\\1.html',


And the following into your .htaccess file:

RewriteRule ^account-gfx-([0-9]*).html index.php?gfx=gfx&random_num=$1 [L]


Make sure with your urlin and urlout to insert these above the last items since they have the "comma" on the end of these lines.

I have this working for the next version of RavenNuke76.
 
myrtletrees
PostPosted: Wed Jun 21, 2006 7:17 am Reply with quote

Applying your fix now. After disabling GT, the image shows, so that HAS to be the problem.
 
myrtletrees
PostPosted: Wed Jun 21, 2006 7:24 am Reply with quote

hmmm.

Well after applying the fix, the image shows on the Your account page, however, it still kills the image in the block. If not on the Your Account page, the User Info Block security image shows...hmm

I had to manually change the code int he CZUserinfo block from this:
Code:
?gfx=gfx&random_num=$random_num

to this
Code:
account-gfx-$random_num.html

and now it works in the block


Last edited by myrtletrees on Wed Jun 21, 2006 7:50 am; edited 1 time in total 
montego
PostPosted: Wed Jun 21, 2006 7:48 am Reply with quote

myrtletrees, you can either get my GTBlocks hack from my site and then be able to "tap" your block or you are going to have to modify the block's code to hardcode the shortened link.

Unfortunately, right now, those are the only two options until I can get TegoNuke(tm) ShortURLs released. I am close, but am wanting to wait until it is tested by the RavenNuke76 QA Team.
 
myrtletrees
PostPosted: Wed Jun 21, 2006 7:50 am Reply with quote

See my eidt above, I guess we posted at the same time Smile

AND now, I have a site that the code does not work on at all and GD IS installed.

This other site is NOT using GT. It is Nuke 7.5 pl 3.1

I've checked thru most critical files I think are included and removed a few spaces at the end of a couple php files, but not Security Image yet.

The next site in question is here Only registered users can see links on this board! Get registered or login!
 
myrtletrees
PostPosted: Wed Jun 21, 2006 8:17 am Reply with quote

FIXED!
The CZUser Info block I was using on the 7.5 site was outdated. I updated that block and all Security code images now work. I had it on the left side so it was appearing on all pages and killing the security code image.

Thanks to all for all your help. Hopefully this thread will help others as well.
 
montego
PostPosted: Thu Jun 22, 2006 5:33 am Reply with quote

Awesome! That is what we like to see.

RavensScripts
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Thu Jun 22, 2006 5:39 am Reply with quote

myrtletrees - were you able to identify anything specific between the two block files other than what you posted earlier?
 
View user's profile Send private message Send e-mail
myrtletrees
PostPosted: Thu Jun 22, 2006 5:57 am Reply with quote

Guardian2003 wrote:
myrtletrees - were you able to identify anything specific between the two block files other than what you posted earlier?


actually, not really. The one that DID NOT work was this:
Code:
/********************************************************/

/* CZ User Info Info Block for PHP-Nuke V3              */
/* Version 2.0  Updated  3-29-04                        */
/* By: Telli (telli@codezwiz.com)                       */
/* http://codezwiz.com/                                 */
/* Copyright © 2000-2004 by Codezwiz                    */
/********************************************************/


the one that DOES work is this version:
Code:
/**********************************************/ 

/* CZUser InfoV5 Universal Block              */
/*                                            */
/* (c) 2002-2004 by Codezwiz Network, LLC.    */
/* http://www.codezwiz.com                    */
/*                                            */
/**********************************************/


I looked at the security code a little, and it looks similar.
If you would like to investigate it more, I can post the code for both blocks so you can take a look, let me know. It may answer some unanswered questions.
 
Guardian2003
PostPosted: Thu Jun 22, 2006 6:23 am Reply with quote

Thanks I'll grab them and run a compare - very much appreciated!!!!!!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©