Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
warz_nl
Hangin' Around


Joined: Aug 29, 2006
Posts: 29

PostPosted: Fri Feb 16, 2007 6:23 am Reply with quote

Hi guys

Been a while since my last post, nice to see you all still here.

I have a problem that I cant get my confirmation emails sent to my forum members I am still useing the raven-Nuke package version: rnv2.02.02

I have move away from my hosting company and am running on my own box in a Data Center now. although this is great for the love of money I cant get my confirmation email out or any email for that matter when I was on a shared host it was no problem every thing worked fine.

I have search the internet for about 2 weeks now and cant seem to resolve this problem. I have also purchased a email server and setup the DNS to point to MX ip and all that. The webmail works fine so I know that the the SMTP for my domain is working and the POP3 too.

The whole site is working fine except for the mail function.

What I am running:

Windows server 2003
Apache 2
PHP 5.2.1
MySQL 5.0.22

My web address is Only registered users can see links on this board! Get registered or login!

And here is the my php Info page Only registered users can see links on this board! Get registered or login!

I will be very greatful for any help you guys can offer.

Thank you, Warren (Warz) Wink
 
View user's profile Send private message
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Fri Feb 16, 2007 7:34 am Reply with quote

I don't think nuke has been tested under Apache 2 yet but I'm sure someone will correct me.
 
View user's profile Send private message Send e-mail
warz_nl
PostPosted: Fri Feb 16, 2007 9:34 am Reply with quote

Hi Grardian

Well I am not sure either but every thing is working super fine on the Apache 2 server I have no complaints about that. And I really dont this that the Apache server is the problem I have opened the port and IP to the smtp server which is also being hosted on the same machine, I have to do this as I have multiple IP's on my server and I only want Apache to listen to a certain group of IP's and ports on my server.

I am just hopeing to get my emails to work or find another work around to get my fellow guild members registered on our forums.

I just had to relogin after clearing my cache and I had to enter that password thing befor submiting the login what is that thing called and were can I get it? I would make a excellent temppory solution to my login problem so that our members can start registering.
 
Guardian2003
PostPosted: Fri Feb 16, 2007 12:44 pm Reply with quote

The security code can be switched on in your config.php or if you are intending to upgrade to Raven Nuke 2.10 there is a proper CAPTCHA as can be seen at Only registered users can see links on this board! Get registered or login!
 
warz_nl
PostPosted: Fri Feb 16, 2007 12:59 pm Reply with quote

I will have a look at the config and I am on my way now to download the Raven Nuke 2.10 but that still doesnt solve my smtp problem Sad

I suppose I will have to carry on looking if you guys get anymore ideas or thoughts plz let me know

Thanks Wink

Edit:
How do I get my new members out of the user_temp and into the user? do I need to make a new login file? lol it not released Very Happy
 
Guardian2003
PostPosted: Fri Feb 16, 2007 6:00 pm Reply with quote

You may need to copy the data over manually and fill in the gaps. Sounds very much like a mail server issue but I'm not running Apache 2 under windows so not sure what additional help I can be.
 
warz_nl
PostPosted: Fri Feb 16, 2007 6:09 pm Reply with quote

Well I did ask my old hosting provider for a copy of his php.ini but I have not heard from him since I stoped using his services. As for the mail server I am hosting that on the same machine as my websites. Is it possible that I post a copy of my ini file here so some one can look it over maybe I am missing some obivious in.
 
warz_nl
PostPosted: Sat Feb 17, 2007 6:16 pm Reply with quote

ok I think I am going to sit is a corner and go slightly mad now.....

I have used 3 diferent mail servers and still nothing.

When I register on my forum using a address from my local domian I get the e-mail but as soon as I try and send the mail outside to another ISP it doesnt arrive.

I have check my mail sever setings for about 2 weeks now and I have access to my DNS and have check that the MX is setup properly.

I am at a total loss is there any other way that I can allow people to register without sending them a confirmation e-mail and having them activate there registartion.

Please I beg you for help. I will be getting hold of the Data center on Monday and maybe they can explain what the issue is.
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sun Feb 18, 2007 9:42 pm Reply with quote

There is the autoactivation hack that allows people to create accounts without email confirmation

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
warz_nl
PostPosted: Mon Feb 19, 2007 12:05 am Reply with quote

Hi Evaders and every one

Ok I have isolated the problem but I am not sure how to work it out.

I have my own server at a colocation (data Center) and I have configured my server to run my websites and my email server I can send email useing my email client and recieve. When I add my SMTP data to my test server here at my house it too sends the user activation to who ever has registered. However when I add the SMTP details to my php.ini I get a time out or a connection reset by peer.

Now to tranlate that. It seems I can run my web server and my mail server on the same server box.

Ok I have downloaded the hack and I will take a look at it. Thanks Evaders

I am also going to send a fat long email to the company that I perchased the mail server from and see what they have to say about this maybe they can help me.
 
evaders99
PostPosted: Mon Feb 19, 2007 2:41 pm Reply with quote

Maybe a firewall issue that prevents your web server from talking to your mail server?
I don't really know how this works because I rent my own root server that already has LAMP configured
 
warz_nl
PostPosted: Mon Feb 19, 2007 4:25 pm Reply with quote

Its not a firewall issue that is for sure, that was the first thing I checked the second was the permissions and so on. I have dicussed this issue with some friends of mine who have tthe same e-mail server I do and they too have the same problem when they are running and application that requires SMTP on the same server box as they app they get an identical error as mine. Even if I changed my MX record to route to another IP address on the same server and set the e-mail server to listen only on that IP address I still get the same error as do my friends.

But the wierd thing is when I moved the appliction (in this account Raven Nuke) to a remote server and have it connect to the SMTP from there it works just fine.

BTW I found the activation hack for Nuke version.7 it works great as long as you add the code manually I have updated that version to comply with the Raven Nuke 76 distro rnv2.02.02 so that all you have to do is copy the new index.php straight into your Your_Account module. I was just wanting to know if I can zip it and send it to one of you to add to the downloads section on the forums for those who need it. I know you guys are really busy and dont have much time to worry about the smaller thing like this.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©