Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
nikits72
Regular
Regular


Joined: Jan 06, 2005
Posts: 80
Location: Athens/Greece

PostPosted: Thu Jan 25, 2007 12:41 pm Reply with quote

Hi all,

maybe someone can enlighten me.
When i am in the admin panel and i press aon of the modules ,phpnuke keeps asks me for name and password.After i enter them and try to click a module the same happens again.
And so i cannot access any module.

Some info that i believe you might need if you kindly would like to help me:

1.The site is a copy of an online site which i copied locally for tests e.t.c.
2.I have reset the password and username of god admin cause i dont remember the ones of the online site.
3.I changed the local config.php setting in order phpnuke can access the local (at this point database) i mean changed the variables $dbhost,$dbuname,$dbpass to match the local settings to localhost,root,"" accordingly.
4.When in admin.php i see a message saying : Notice: Undefined variable: aid in d:\www\html\admin.php on line 4
The code there says :
Code:
<?php


define('ADMIN_FILE', true);
if($aid AND (!isset($admin) OR empty($admin)) AND $op!='login') {
unset($aid);
unset($admin);
echo "Access denied";
die();
}
// Uncomment the following block of code after editing the next line to match your site domain
/*$domainname = "www.yourdomainname.com";
if ($_SERVER['SERVER_NAME'] != $domainname ) {
  echo "Access denied";
  die();
}*/
/************************************************************************/
/* PHP-NUKE: Advanced Content Management System                         */
/* ============================================                         */
/*                                                                      */
/* Copyright (c) 2002 by Francisco Burzi                                */
/* http://phpnuke.org                 
e.t.c.
e.t.c.       

5.The online site was 7.6 patched with sentinel ver 2.2.0 and i guess the local is so since i just copied the html files and dirs.

Thank you for reading this.
Regards ,
N.

P.S. i hate to say that i searched the forums yet couldn't find a solution
(Crowd's voice---> oh yeah you did? then you are so newbbie Evil or Very Mad )

_________________
nikits72 with the unexploding grenade...

Last edited by nikits72 on Mon Jan 29, 2007 7:06 am; edited 1 time in total 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Thu Jan 25, 2007 4:19 pm Reply with quote

Sounds like something's wrong with your cookies

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
nikits72
PostPosted: Fri Jan 26, 2007 6:27 am Reply with quote

I cleared my cookies and the problem persist if this is what you meant.

Allthough can it be that the cookies have something to do with the number 4? :
4.When in admin.php i see a message saying : Notice: Undefined variable: aid in d:\www\html\admin.php on line 4
 
jakec
Site Admin


Joined: Feb 06, 2006
Posts: 3048
Location: United Kingdom

PostPosted: Fri Jan 26, 2007 11:24 am Reply with quote

Were you using CGIAUTH, or HTTPAUTH on the site you copied locally for testing?
 
View user's profile Send private message
nikits72
PostPosted: Fri Jan 26, 2007 11:46 am Reply with quote

From what i can see in the online ver of the site right now,

the cgiauth field is empty so no i guess i dont use this.

As for the httpauth i cant find where this is exactly but if you mean the field :
Admin Auth -where both hhtpauth and cgiauth reside- it is set to off.

Hope these answer your question.

Thx,
N.
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Jan 26, 2007 3:50 pm Reply with quote

Are you using Apache or IIS? I am surprised that you do not see CGIAuth in the list.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
evaders99
PostPosted: Sat Jan 27, 2007 12:30 am Reply with quote

Seems you need to turn down your error reporting level too
 
nikits72
PostPosted: Sat Jan 27, 2007 1:29 pm Reply with quote

Well ,
here is my on line site, sentinel administration panel settings in three pics.
Maybe this is helpful 4 you to assist me.
Sentinel ver is 2.2.0 and i have blanked some areas where i thought there are 'sensitive' data
Here they are:

Image
Image
Image

Thank you 4 your concern.
N.
 
montego
PostPosted: Sat Jan 27, 2007 3:27 pm Reply with quote

Unfortunately, that does not help at all. Couple of things, I had asked this a few posts back:

Quote:

Are you using Apache or IIS? I am surprised that you do not see CGIAuth in the list.


Do you know the answer to that? I do not believe you can use admin authentication if you are using IIS and in fact, you cannot even use "write to .htaccess" options in the blockers. That is the only reason why I can think of CGIAuth not showing up as a valid option.

I have seen HTTPAuth not show up, which can be valid depending on someone's set up, but I have NEVER not seen CGIAuth.

Also, you might want to consider upgrading to NukeSentinel 2.5.05. You need to keep up with the changes in order to protect yourself from newer exploits. Being back on 2.2.0 is like having an Anti-Virus tool but your definitions are 2 years old!
 
nikits72
PostPosted: Sat Jan 27, 2007 4:51 pm Reply with quote

I see montego.
Locally i run apache.So does the webhoster for the online ver.

To tell you the truth i was thinking upgrading sentinel.But -as you said- i setup the online site about 2 years ago and since i dont remember much by now i was very sceptical about upgrading sentinel since as far as i could remember i had some difficulties.
But you are right, i will try to upgrade sentinel on the online site.

Yet, for the local site (the online site copy).
I doubt if i will succeed upgrading sentinel since the problem we talk exists still and i dont have access of the modules,not to mention that it will be of no use since i test locally and i wont hack myself.
(Crowd's voice----> Well nikits y r so newbbie that you might do that as well by accident Twisted Evil )

Anyway since i would prefer to have identical copies it might not be a bad idea to upgrade sentinel on the online site and then copy all of it locally although i doubt it will work as with sentinel 2.2.0 didnt.

Maybe this problem may be irrelevant with sentinel.

Anyway, apart of these.... any comments about the notice ? :
When in admin.php getting the Notice: Undefined variable: aid in d:\www\html\admin.php on line 4


It is so hard to fix things when you dont know php and i know that is also -if not more- difficult to help someone who doesnt know from afar.
Though i am much obliged for the concern of all who replied.

Thx.
N.

P.S. Excuse my lame english.
 
montego
PostPosted: Sat Jan 27, 2007 5:06 pm Reply with quote

Not sure what is going on with NukeSentinel, except that it sounds to me like your local setup is just not set up properly. If you have not gotten too far into things, you might try replacing your local setup with XAMP or LAMP depending on whether you are using Windows or Linus. I use XAMP locally for ALL my development now and do have mirror images of all my nuke sites on my local machine. I install and test thoroughly everything locally FIRST before I do the same on a production site.

I was able to get XAMP up and running very quickly on my local system and with running PHP-Nuke and NukeSentinel with virtually NO configuration setting changes.

Regarding the notices, you would not believe how many notices there are lurking within PHP-Nuke! In our latest work on RavenNuke version 2.10 (not released yet), we have cleaned up literally 10,000+ notices and probably close to that in XHTML compliance errors. PHP-Nuke is simply a mess! If you are not seeing these on your production site, then I would not worry about this.

I see that you are using 7.6. You are a prime candidate for migrating over to RavenNuke if you ever wish to use this highly cleaned up and tested and secure version... 2.10 will hopefully be out in the coming weeks.
 
nikits72
PostPosted: Sat Jan 27, 2007 5:23 pm Reply with quote

I use easy-php which is described on the phpnuke HOW-TO manual.
Never had problems with that.Very easily installed and working like a charm.


As for RavenNuke, my eyes -and i bet of many others simple users like me- are upon it all the time.
As it is common by now ,phpnuke has many bugs but it has the biggest community.
Can someone with Ravennuke has a decent help for it? Yes ,but only here if we judge from sentinel.

But you see , for this issue i have now -probably due to sentinel- , this is the only forum ,that there is a chance i get help. I ve posted this problem to other forums as well ,where i usually find help but for this nothing.Not even a single reply.Except here.Because here -except a good forum- is where sentinel is made i guess...
And similar could be with ravennuke as well.
Of course ,these are only my thoughts. Maybe Ravennuke is so similar with phpnuke that you could get help in other forums as well.
But since i am the average phpnuke user i think these thoughts are common and should be considered -and probably are- from you developing Ravennuke.

Though this is another subject,for another thread ...


So it seems, no other proposition.
Seems the best i have to do now is to uppgrade sentinel to the online site and then copy it locally wishing that everything will go ok?

Sounds ....difficult... but i will try it and pray...
 
montego
PostPosted: Sat Jan 27, 2007 8:01 pm Reply with quote

Quote:

Yes ,but only here if we judge from sentinel.


That is a strength and not a weakness... you will not find better support elsewhere! (At least, so we hear... Wink )

Quote:

Seems the best i have to do now is to uppgrade sentinel to the online site and then copy it locally wishing that everything will go ok?

Sounds ....difficult... but i will try it and pray...


Well, pray, AND take backups of your database AND script files ahead of time so that you can very quickly recover if something ends up getting messed up.
 
nikits72
PostPosted: Sun Jan 28, 2007 10:33 am Reply with quote

Hi all once more,

by now i have managed to make my online site run locally with no problemas at all.(I will describe below how i did that in case someone has similar problems as this is the least i can do for the help i get from this forum)

Now i would like to upgrade sentinel from 2.2.0 to the latest version.
Though it seems that there is no sentinel in download area except from some sentinel upgrades.
Where can i download sentinel from?
I mean nukescripts.net site seems to has the latest version but i wonder why isnt the files here where it is the official support for sentinel? Probably i missed it right? If yes please advice.
**********************
**********************
Now for the problems i had and how they were solved:
It was really matter of a simple thought.
Since sentinel seemed to cause the trouble what i did was to get chatserv latest 7.6 fix files.
I installed them over my local copy of the online site.
So sentinel files are still there but not being used since Chatserv fixed files dont include use of sentinel.
Then migrate the database with the online one.
Trimmed config.php for the local site.
Chatserv fixed files dont include sentinel so i suppose right now i have some sentinel tables in the db and some sentinel code in the html files which remained from the copy of the online database and html files and now are there but not being used.
Now it is the time to install latest sentinel ver as soon as you give me an answer where to find the latest sentinel files and then maybe clear some of the old vers sentinel files and tables -since i read how to do it in the sentinel readme.txt file-.
It may sounds complicated for a newbbie to do but with much reading and the aid Only registered users can see links on this board! Get registered or login! it can be done.
I just hope that the installation of sentinel will be so easy too Smile
(Crowd's voice----> Seems that you ve been extremely lucky up to now nikits Evil or Very Mad )

Thx you for your help.

Thx,
N.

P.S. If i will finally do it locally then AND ONLY then i will try to update chatserv and sentinel on the online site and hope that murphy's laws wont happen.
(Crowd's voice----> Twisted Evil yeah right! You ll be here again crying for help cause of the problems youll have on the online ver of the site ehehehehe Twisted Evil )

P.S.2
Quote:

Yes ,but only here if we judge from sentinel.


That is a strength and not a weakness... you will not find better support elsewhere! (At least, so we hear... Wink )

Is there a thread about this subject.I wouldnt like to comment here because it is out of this thread's subject...
 
montego
PostPosted: Sun Jan 28, 2007 7:04 pm Reply with quote

Although Raven has a support forum here for NukeSentinel, he is NOT in control over the code. The author is the owner of Only registered users can see links on this board! Get registered or login! and that is where one should ALWAYS go to get the latest when it comes to NukeSentinel(tm). Support is here, software is there. Been that way for over a year, probably longer (meant only as a "history lesson", nothing more).

The latest version is 2.5.05 as of this writing.

Not sure what you are getting at with this comment here:

Quote:

Is there a thread about this subject.I wouldnt like to comment here because it is out of this thread's subject...


So, pick a forum that looks right to you... Wink
 
nikits72
PostPosted: Mon Jan 29, 2007 4:07 am Reply with quote

Thank you 4 explaining that to me.

There are many thoughts i would like to say but since this is how things are i better shut up and go along Smile

The thread i ask about at the end is a thread with talk about the phpnuke and how the community is going.
But right now after a second thought i am sure that this have been long commented and from people more evolved to this community than me..

Thx 4 your help.
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Mon Jan 29, 2007 7:50 am Reply with quote

Montego wrote:
... I do not believe you can use admin authentication ...


Actually, IIS does support Admin Authentication but, as you said, not .htaccess.
 
View user's profile Send private message
montego
PostPosted: Tue Jan 30, 2007 6:34 pm Reply with quote

Quote:

Actually, IIS does support Admin Authentication but, as you said, not .htaccess.


Ah, very good to know. Thanks.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©