Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
Meoff
Regular
Regular


Joined: Aug 05, 2006
Posts: 55
Location: Thailand

PostPosted: Wed Sep 13, 2006 9:09 am Reply with quote

Hello to everyone.

I was hacked again last night- in a huge way. As a result, I deleted my whole site, and uploaded a fresh full version of RN 2.02.02.

I uploaded a known good backup copy of my database, from a few days before this happened, so I am hoping that it is clean. It is a database that was originally a Nuke 7.8 version that I downgraded to use with RaveNuke.

I'm afraid to use any of the old files, because when I tried to restore the files / database, the attack would return in about 60 minutes. I've got no way of knowing what he left behind bacuse I hadn't activated my server logs. (Live and learn....)

My problem is- everything seems to be working, except the majority of my modules are returning "not found" when I try to open / use them. I can see the modules installed on the server, and in the modules administration list. Deactivating / Re-activating makes no difference.

Among the modules not found is "Your Account", therefore no one can log in.

Also mising is the "News" module, which I would really like to get back because there are almost 1000 stories inside. I can see the stories on the Admin homepage, but can not click on them.

Searching on this gave me some ideas- checked the permissions, and affected modules folders are set to 755, looking in the MyPHP admin shows all of the tables in place, and apparently in good order. (Not that I would have a clue what I am looking at, but no error is returned when I try to open the "nuke_stories" table for example.

Can anyone offer any suggestions to get my make my modules work again?

Another question- what is the proper "protocol" for the forum? If I have another related question, can I continue in one post, or should I start a new topic for the question?

The other question is... (quick one) where can I download the latest Nuke Sentinel? I thought i had the latest version with my recent download, but it is 2.4.2. I see version 2.5+ mentioned in the forum, but the Raven download page apparently does not have this.

Thanks in advance for any suggestions!

Meoff
 
View user's profile Send private message Visit poster's website
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6793
Location: Ha Noi, Viet Nam

PostPosted: Wed Sep 13, 2006 11:52 am Reply with quote

It sounds very much like there is a problem with some of the table structures - the fields within the tables.
You would need to compare what is in the current download with what is currently used onyour site. It's the only thing I can think of that would give you these problems, assuming you have no old redundant files left over from your 7.8 install.
 
View user's profile Send private message Send e-mail
Meoff
PostPosted: Wed Sep 13, 2006 2:24 pm Reply with quote

There are no redundant / old files from the 7.8 install... I deleted the lot.

Looking in PHP MyAdmin, all of the tables show "Collation" as "latin1_swedish_ci".

Under the "operations" tab, there is abig red error warning..."The additional features for working with linked tables have been
deactivated. To find out why click here."

Clicking there leads me into a lot of stuff I'm having trouble to decipher.

Is this the correct collation scheme? Am I on to something? Would re-collating with another format help, and if yes, which format is correct?
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Wed Sep 13, 2006 4:01 pm Reply with quote

Not files, but the tables from 7.8 may not be compatible directly with RavenNuke.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Meoff
PostPosted: Wed Sep 13, 2006 7:28 pm Reply with quote

The site was originally Nuke 7.8, but I downgraded it to RN 7.6. I downgraded the database to RN 7.6 with the downgrade utility.

I'm now trying to use the downgraded database with a fresh full install of RN 7.6.

Maybe that is my answer? Install a fresh version of nuke 7.8, then apply all the RN 7.6 files to the 7.8 installation as I did originally? Worth trying?
 
evaders99
PostPosted: Thu Sep 14, 2006 3:26 pm Reply with quote

Which downgrade did you use? The only one I know goes to phpNuke 7.6, not directly to RavenNuke. I know there's more on the forums about going from phpNuke to RavenNuke
 
Meoff
PostPosted: Fri Sep 15, 2006 8:13 am Reply with quote

Hello to all,

Thanks for the input... problem is solved.

It turns out that there was no problem with the database. My FTP transfer to upload the RaveNuke files was corrupt / files missing. Downloading a fresh copy of RaveNuke from the website and installing it solved the problem.

Just goes to show you that high tech problems often have a low tech solution! go back to square one and verify everything!

Still would like to know where to get the latest and best Nuke Sentinel in order to upgrade the version bundled into RN 2.02.02.

Also- what version of PHPBB is in the RN 2.02.02 bundle? My original Nuke 7.8 had been upgraded to 2.0.21, and I would like to do the same with the new installation.

Rgds,
Meoff
 
Tao_Man
Involved
Involved


Joined: Jul 15, 2004
Posts: 252
Location: OKC, OK

PostPosted: Fri Sep 15, 2006 9:33 am Reply with quote

Nuke Sentinel is at Only registered users can see links on this board! Get registered or login!

that is the full package, he also has upgrade scripts, if you are going from 2.4 to 2.5 I would just do the whole thing, but thats just me.

_________________
------------------------------------------
To strive, to seek, to find, but not to yield!
I don't know Kara-te but I do know cra-zy, and I WILL use it! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©