Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks
Author Message
Bluezzz
Involved
Involved


Joined: Feb 08, 2005
Posts: 290
Location: USA

PostPosted: Sat Sep 09, 2006 4:33 am Reply with quote

I'm having the same problems noted here ...
Only registered users can see links on this board! Get registered or login!

In which I can put in about three weblinks (HTML format), once I add a fourth the block goes screwy in that 1) the Save Changes button disappears; 2) the block somehow inherits all three Footers causing havoc on any page the block shows on because the footers now align on the left side of the page under whatever last block is there.

The only way to correct this problem is to disable the User's Custom Box Block. So, been there, done that. But I liked having a menu where I could add links, or my members can have their own block to add their most used links. I now know that that block is limited in the data it can hold ... is there anyway to *fix it* so it can hold more data, expanding as it gets more data? Is there any way to stop it from inheriting the footer data? Is there any way to keep it properly aligned?

If not, is there anything similar I can use for me and my members to hold favorite links? Thanks in advance!

_________________
Bluezzz
~ Stop & smell the roses, while you can! ~ 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9453
Location: Arizona

PostPosted: Sat Sep 09, 2006 8:25 am Reply with quote

I am pretty sure the reason it is displaying so poorly is it has chopped off the HTML that was placed in that field.

You could try to change the field "ublock" on the nuke_users table from "tinytext" to "mediumtext", but I have not tested this.

Either try this on a test instance of your site or get a good backup of that table and data for that table so you can get it back quickly.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Bluezzz
PostPosted: Sat Sep 09, 2006 4:45 pm Reply with quote

You know, you may well be right about the font size. On the site as a whole I changed the templates so that they're all size 12px (where they had been 8-11px). I think rather than use this block I'd prefer a new block that would allow the 12px font size and would allow for more than just four or so lines of data. Is there any such block available where users can add their own links, etc ... that is SAFE ... and that is better than this standard one that comes with RN76?

The current block is somehow picking up footer 1 through 3 data so it's corrupt somehow.

Thanks for replying : o}
 
montego
PostPosted: Sat Sep 09, 2006 5:49 pm Reply with quote

Bluezz, we are missing each other again... Sad I was not referring to font size at all. The reason the block is getting out-of-wack, is that the way the field "ublock" is defined on the nuke_users table (which is where each user's personal block is stored), it can only hold 255 characters. Therefore, if you paste HTML code in there that is longer than that, you could have missing end tags in the block. Depending upon what the individual user is putting into this personal block, like tables, not having the proper closing tags could very well screw up everything in the footer.

BTW, this is not a standard "block" per se, so there is nothing to "corrupt". It is one of the "special use blocks", similar to the admin block, that you do not control using the Blocks administration.

Hope this helped clarify things better.

Do, what I was getting at is that the root cause of the problem you are seeing is related to the size of the field which stores the "block"'s HTML. If you increase the size of that field, you might find that it works properly.
 
Bluezzz
PostPosted: Sat Sep 09, 2006 9:13 pm Reply with quote

I'm sorry hun, I don't quite understand how to *fix* the table. Where exactly is the table, how exactly do I *fix the number of characters* ... I'm not very good at the table side of things I'm afraid : o/

I appreciate your reply and understand that it's not a font size issue as I'd thought you meant previously ... but I still don't know how to fix the problem. I've deactivated the block for now. Oddly enough I didn't past any long code in the box, I simply had four HTML links in there. Somehow it's *added* the footer1, 2 and 3 data on it's own ... I can't fix that because even if I go into the block and delete all that stuff I have no Save button for which to keep the fix!

Will fixing the table fix readd the Save Changes button?
 
montego
PostPosted: Sun Sep 10, 2006 6:22 am Reply with quote

Are we not talking about the "Users Custom Box Block"? That is in each user's Your Account --> Home screen. Each user has the ability to put HTML code of their choice in there. This is what I understood the thread to be about (I want to make sure!)

By your comment here, I am now not sure we are talking about the same thing:

Quote:

I can't fix that because even if I go into the block and delete all that stuff I have no Save button for which to keep the fix!


Where are you within PHP-Nuke when you do this?

Confused Confused Confused Confused
 
Bluezzz
PostPosted: Sun Sep 10, 2006 10:54 am Reply with quote

Yep that's the one ... User's Custom Block in Blocks but for each user that creates one it's called Menu for So-n-so. I'm in Your Account when creating the links in *my block*. But like I said, for some reason it's lost the Save Changes button AND it's inherited the footer 1-3 data ... I can't get it out because even if I delete all the excess footer stuff I can't save the changes. I don't know where to edit the table.

I assume you mean I have to make the 255 change to 1255 or somesuch WITHIN the table, but I have no idea how to do that, where that table is or how to get at it, etc.

I quoted a page url above that talks about the same issue but I don't understand how it was resolved. My HTML code in that box was only three links to start with ... I added a fourth link and that's when my problem began ... Save Changes disappeared and a whole mess of code from the footer 1 through 3 appeared and I could not then remove that because even if I did there is no Save Changes button to save the removal of all the footer stuff!?
 
montego
PostPosted: Tue Sep 12, 2006 5:33 am Reply with quote

Oh my... You are going to have to use phpMyAdmin to clean this up it appears. Go to the nuke_users table and find the user that is having this issue (is it you?). Edit that record and clear out the value that is in the *ublock* field and then re-save the record.

This has never happened to me, so I do not understand how this happened.

Better yet, if you could also paste the contents of that field into a reply here that would be great (or email it to me at montego __AT.. montegoscripts **dot** com). I'd like to see what caused it (if I can).
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©