Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
adriancollins
New Member
New Member


Joined: May 08, 2006
Posts: 8

PostPosted: Thu May 18, 2006 2:41 am Reply with quote

Hi,

I'm currently using std PHP-Nuke 7.8 (patched) and would like to change to the latest version of RN76 v2.02.02.

I'm quite new to this, and have been unable to find the best method so far. I only have a couple of users and a few addons such as Coppermine / NUCalendar etc as the site has not been launched yet.

I have done a std install of RavenNuke on another domain and wish I had found it first. So easy!

The only info I have found so far was this Only registered users can see links on this board! Get registered or login!

I understand (after backing up!) I first need to downgrade my DB to 7.6 using PHP-Nuke Downgrader Only registered users can see links on this board! Get registered or login!
I presume this part is straightforward?

Would it be best to then run a std install of RN using a new database then export any data from my 'old' database. Or just copy over all the RN7.6 files and configure config.php etc manually afterwards? I presume I will need to reinstall any addons

I would appreciate any help which may save me hours or save me from a broken site completely! My site is Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
adriancollins
PostPosted: Fri May 19, 2006 1:22 am Reply with quote

Hi

I would really appreciate it if someone could please advise me on the best way to go about this, many thanks
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri May 19, 2006 5:41 am Reply with quote

Well, Raven's post here (in the thread you reference) is the simplest possible approach:
Only registered users can see links on this board! Get registered or login!

As always, back up your original 7.8 database and files before doing this in case you make a mistake and then you can easily get back to where you started. If you run into issues, look for answers in these forums and if you are still stuck, just post back here with your issue.

Good luck!

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
adriancollins
PostPosted: Fri May 19, 2006 12:00 pm Reply with quote

Thanks for your reply Montego, well I gave it a go and all seemed to go according to plan, but...

All I see now when browsing Only registered users can see links on this board! Get registered or login! for example is a black blank page (I have a temporary redirect in place if you just browse the top level domain without adding the actual page)

If you view the source of the page there its pretty much blank. I have checked the server logs and get this output below.

Does anyone have any ideas to put me in the right direction please

Many thanks - Adrian

[Fri May 19 18:00:57 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/404.shtml
[Fri May 19 18:00:57 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/favicon.ico
[Fri May 19 17:55:53 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/404.shtml
[Fri May 19 17:55:53 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/favicon.ico
[Fri May 19 17:53:32 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/404.shtml
[Fri May 19 17:53:32 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/INSTALLATION/installSQL.php
[Fri May 19 17:53:28 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/404.shtml
[Fri May 19 17:53:28 2006] [error] [client 212.159.76.99] File does not exist: /home/westr56/public_html/INSTALLATION/installSQL.php
[Fri May 19 17:47:39 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:47:39 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:47:31 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:47:31 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:47:28 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:47:28 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:46:09 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
[Fri May 19 17:46:09 2006] [alert] [client 212.159.76.99] /home/westr56/public_html/.htaccess: Invalid command 'ml', perhaps mis-spelled or defined by a module not included in the server configuration
 
montego
PostPosted: Sat May 20, 2006 12:30 am Reply with quote

Are you certain you FTP'd all the 2.02.02 files over top of your existing 7.8 ones? Be careful to note down your pertinent details from config.php, but then again, you backed everything up like I said anyways right?
 
adriancollins
PostPosted: Sat May 20, 2006 1:47 am Reply with quote

Montego, yep, I'm certain that all the latest files have been copied over the top of the 7.8 ones. I have copied the details from config.php etc. (Also everything is backed up yes)

I was wondering if I am now better off doing a 'clean' install of RavenNuke 2.02.02 and just importing any reqd parts of the database back in, what do you think pls? I know this would take a while but it's not as if I have many users or anything so far.

Many thanks, Adrian
 
montego
PostPosted: Sat May 20, 2006 2:05 am Reply with quote

Others have done this. You should be able to export just the DATA from the database you just downgraded to 7.6 plus the added step of installing the NSN Groups step within Raven's install SQL (you have already done this in your steps above).

There may be few slight issues with the 2.0.20 forums patch, but, unfortunately, I am not that familiar with it.

If you run into troubles, you simply need to compare the table schemas between the core RN76 installed tables and your downgraded database to find the differences.
 
adriancollins
PostPosted: Sun May 21, 2006 7:49 am Reply with quote

Hi Montego, thanks again for your help.

It took me about two days work to get this to work but all is now working fine (Apart from a few problems but these are quite minor in comparison) - I found out that the problems I had on May 20th (above) were due to my modified Theme not working correctly under 7.6RN for some reason. I had to recreate this from the Odyssey theme files from RN 2.02.02. Now all fine.

After I had worked this out I actually restored the old (d/graded 7.6 Dbase) and BINGO, one happy bunny. It's worth the effort for peace of mind if anyone else is considering doing this!

Regards, Adrian
 
montego
PostPosted: Sun May 21, 2006 6:24 pm Reply with quote

Most excellent!! The really good news is that now that you are on RavenNuke76, any future upgrades will be very easy... I highly recommend keeping up with them as they come available.
 
utssace
Worker
Worker


Joined: Feb 18, 2006
Posts: 155
Location: Virginia

PostPosted: Sun Jul 23, 2006 8:11 am Reply with quote

I also am running phpnuke 7.8 with 3.1 patch. I like the idea of a fresh install of Raven Nuke and downgrade my database to 7.6 & import into RN.

My question: I also have NukeSentinel(tm) 2.4.2pl4 installed on my 7.8 site. Do I need to uninstall Sentinel first...then downgrade to 7.6....then import database into RN (since RN has a separate install for NS)?
 
View user's profile Send private message Visit poster's website
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Sun Jul 23, 2006 8:25 am Reply with quote

No you don't need to go to all that trouble. RN has its own installer for Sentinel so if you run that it update any tables it needs to automatically.
 
View user's profile Send private message Send e-mail
utssace
PostPosted: Sun Jul 23, 2006 12:15 pm Reply with quote

Ok I have the FULL RN installed in a separate location.

I have the "Downgrade to 7.6" script. Can I just run this script to downgrade the database without overwriting the 7.8 files with the 7.6 core files.

I just want to capture the downgraded database so I can import the data into my new Raven core tables.
 
Guardian2003
PostPosted: Sun Jul 23, 2006 12:29 pm Reply with quote

Sounds like a good plan to me.
Make sure to download a back up of your 7.8 database before running the downgrader script on it.
 
utssace
PostPosted: Sat Jul 29, 2006 11:25 pm Reply with quote

After running the downgrade DB to 7.6 script, I get this message:

ALTER TABLE nuke_modules failed


Last edited by utssace on Sun Jul 30, 2006 8:14 am; edited 1 time in total 
utssace
PostPosted: Sun Jul 30, 2006 7:45 am Reply with quote

Help please:

I tried to use the downgraded database in spite of this failed ALTER TABLE nuke_modules. (this may be my problem)

I am finding several tables where the column count doesn't match. To be specific, (nuke_bbwords, nuke_blocks, nuke_message, nuke_modules)...(SO FAR)

Also, the downgrade didn't get rid of tables that RavenNuke7.6 doesn't use, (nuke_cities, nuke_optimize_gain)

What I have done so far to fix this is:

I restored the original table data for nuke_bbwords, and nuke_blocks. I deleted the nuke_cities, and nuke_optimize_gain tables from my downgraded 7.6. But I don't know how to fix the nuke_message and nuke_modules tables. (there are probably more)

Also wondering if some tables that appeared to import OK, may have matched up wrong data if the columns are layed out different.
 
utssace
PostPosted: Sun Jul 30, 2006 9:32 am Reply with quote

Well I got it. I had to manually insert some tables but it works now. (fingers crossed)

the downgrade isn't perfect but it seemed to manage the forum part well...which is most important.

Thanks for the help. This thread really helped. RavensScripts
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©