Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro
Author Message
dubLeE
Regular
Regular


Joined: Jan 12, 2006
Posts: 60

PostPosted: Thu Jul 13, 2006 11:25 pm Reply with quote

ok today i finally upgraded to 2.02.02 from 2.02.00 and the upgrade went successfully however my themes are messed up...
Only registered users can see links on this board! Get registered or login!

the stories and footer won't show on the main page of the theme and i can't figure out why it's doing that...
also the work board does not work either...

_________________
[Personal] Only registered users can see links on this board! Get registered or login!
[Hosting] Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website AIM Address MSN Messenger
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Fri Jul 14, 2006 4:38 am Reply with quote

Try to access your footer.php directly. I'd guess there is a parsing error there.

Not sure about the workboard. What's happening.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Jul 14, 2006 6:47 am Reply with quote

Looks to me like you may have had a different news system prior to upgrading? Did you have NSN News by chance? If so, then you may have just overwritten some of those files with code nuke76 news files.

The reason I ask is your Submit News link is not the core RN one.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
dubLeE
PostPosted: Fri Jul 14, 2006 10:42 am Reply with quote

kguske wrote:
Try to access your footer.php directly. I'd guess there is a parsing error there.


My Theme: Only registered users can see links on this board! Get registered or login!
Fisubice: Only registered users can see links on this board! Get registered or login!
No Parse error, it all shows up correctly when accesses directly
i think my guess would be that because my stories/News is messed up, it is somehow hindering the footer

kguske wrote:
Not sure about the workboard. What's happening.

it's remaned to _PJ_TITLE in the Admin Panel and when i click it i get a blank page...

montego wrote:
Looks to me like you may have had a different news system prior to upgrading? Did you have NSN News by chance? If so, then you may have just overwritten some of those files with code nuke76 news files.

The reason I ask is your Submit News link is not the core RN one.

i remember i did install it but never used, i reverted back to the normal News that came with RavenNuke


Last edited by dubLeE on Fri Jul 14, 2006 10:39 pm; edited 2 times in total 
montego
PostPosted: Fri Jul 14, 2006 4:35 pm Reply with quote

Well, it looks to me like there may still be some files and/or DB tables that have not been completely backed out or overwritten. Since News is in the Home page, I am thinking that the issue really is with News. Most of your other modules are working just fine and showing the footer.
 
Guardian2003
Site Admin


Joined: Aug 28, 2003
Posts: 6792
Location: Ha Noi, Viet Nam

PostPosted: Fri Jul 14, 2006 4:37 pm Reply with quote

You could always post the news table structure here for us to check Smile
 
View user's profile Send private message Send e-mail
dubLeE
PostPosted: Fri Jul 14, 2006 6:12 pm Reply with quote

montego wrote:
Well, it looks to me like there may still be some files and/or DB tables that have not been completely backed out or overwritten. Since News is in the Home page, I am thinking that the issue really is with News. Most of your other modules are working just fine and showing the footer.
how can i check this?


Guardian2003 wrote:

You could always post the news table structure here for us to check Smile

Code:


-- phpMyAdmin SQL Dump
-- version 2.8.0.2
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Jul 14, 2006 at 08:19 PM
-- Server version: 4.1.19
-- PHP Version: 4.4.2
--
-- Database: `dubleee_main`
--

-- --------------------------------------------------------

--
-- Table structure for table `nuke_stories`
--

CREATE TABLE `nuke_stories` (
  `sid` int(11) NOT NULL auto_increment,
  `catid` int(11) NOT NULL default '0',
  `aid` varchar(25) NOT NULL default '',
  `title` varchar(80) default NULL,
  `time` datetime default NULL,
  `hometext` text,
  `bodytext` text NOT NULL,
  `comments` int(11) default '0',
  `counter` mediumint(8) unsigned default NULL,
  `topic` int(3) NOT NULL default '1',
  `informant` varchar(25) NOT NULL default '',
  `notes` text NOT NULL,
  `ihome` int(1) NOT NULL default '0',
  `alanguage` varchar(30) NOT NULL default '',
  `acomm` int(1) NOT NULL default '0',
  `haspoll` int(1) NOT NULL default '0',
  `pollID` int(10) NOT NULL default '0',
  `score` int(10) NOT NULL default '0',
  `ratings` int(10) NOT NULL default '0',
  `associated` text NOT NULL,
  PRIMARY KEY  (`sid`),
  KEY `catid` (`catid`),
  KEY `counter` (`counter`),
  KEY `topic` (`topic`)
) ENGINE=MyISAM DEFAULT CHARSET=latin1 AUTO_INCREMENT=4 ;

--
-- Dumping data for table `nuke_stories`
--

INSERT INTO `nuke_stories` VALUES (1, 0, 'dubLeE', 'TEST...', '2006-02-14 22:04:07', 'test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test ', 'test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test test ', 0, 26, 1, 'dubLeE', '', 0, 'english', 0, 0, 0, 0, 0, '1-');
INSERT INTO `nuke_stories` VALUES (2, 0, 'dubLeE', 'Test 2...Test 2...', '2006-02-15 19:12:27', 'Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...', 'Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...Test 2...', 0, 13, 1, 'dubLeE', '', 0, 'english', 0, 0, 0, 0, 0, '1-');
INSERT INTO `nuke_stories` VALUES (3, 0, 'dubLeE', 'sad', '2006-03-04 11:49:05', 'asd', '', 0, NULL, 1, 'dubLeE', '', 0, 'english', 0, 0, 0, 0, 0, '1');

i think that's the table structure
 
dubLeE
PostPosted: Fri Jul 14, 2006 10:37 pm Reply with quote

montego wrote:
Well, it looks to me like there may still be some files and/or DB tables that have not been completely backed out or overwritten. Since News is in the Home page, I am thinking that the issue really is with News. Most of your other modules are working just fine and showing the footer.
i did have NSNNews installed, i just checked the files. i don't NSNNews anymore, how would go about removing it and fixing this easy? should i just delete the News module and reupload from RavenNuke Package?

EDIT:
deleting the News folder and reuploading did not work hahaha
so yeah, i'm stuck now... debating if i want to play with the tables or not...
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sat Jul 15, 2006 12:08 am Reply with quote

No errors when you enable error reporting?

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
dubLeE
PostPosted: Sat Jul 15, 2006 12:39 am Reply with quote

evaders99 wrote:
No errors when you enable error reporting?
had no idea such an option even existed. quick searched the forums and found it in the config.php, enabled and waalaa

Code:
Fatal error: Call to undefined function: pjprojectpercent_info() in /home/dubleee/public_html/dEv2/blocks/block-NukeProject.php on line 25


time to tamper with the error see if i can get it before you guys post the solution...

thanks for pointing this out evaders
 
dubLeE
PostPosted: Sat Jul 15, 2006 12:43 am Reply with quote

this is line 25:
Code:
  $project = pjprojectpercent_info($project_id); 

absolutely no idea what to do...

however, when i deactivate the NukeProject block, all is well!
so now, how to i get NukeProject working correctly?
 
evaders99
PostPosted: Sat Jul 15, 2006 2:03 am Reply with quote

Well something in NukeProject isn't installed. I would go through that installation and make sure you did all relevant code changes. I can't be much more help than that, I don't use NukeProject
 
montego
PostPosted: Sat Jul 15, 2006 6:55 am Reply with quote

Might be the include file for the functions. Bob has been pretty consistent in his scripts in providing the functions that he uses in a script in the includes directory. You are probably missing this file.
 
dubLeE
PostPosted: Sat Jul 15, 2006 12:30 pm Reply with quote

i don't get how the upgrade could have messed up the files. it was working perfectly before the upgrade. i'm going to try to reinstall it again and see what happens...
 
dubLeE
PostPosted: Sat Jul 15, 2006 2:58 pm Reply with quote

ok i uninstalled NukeProject and tried to re-install it but i get the following errors:

Code:
Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 72


Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 80

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 88

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 98

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 110

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 130

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 139

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 150

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 172

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 194

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 203

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 212

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 223

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 255

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 269

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 278

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 287

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 298

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 328

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 342

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 351

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 363

Warning: in_array() [function.in-array]: Wrong datatype for second argument in /home/dubleee/public_html/dEv2/nsnpj_installer/install.php on line 386
Everything seems to have completed succeesfully :)


i need help to get this thing backup or an alternative work board that delivers the same features...
NukeScripts doesn't seem to have a support forums so you guys are my only option...
 
evaders99
PostPosted: Sun Jul 16, 2006 1:22 am Reply with quote

Despite those errors, does NukeProjects run at all? Not sure about that installer, may need to PM Bob Marion directly
 
dubLeE
PostPosted: Sun Jul 16, 2006 12:37 pm Reply with quote

it ran on the 2.02.00 version perfectly, but after the upgrade to 2.02.02, it completely stopped working...and in admin menu, the name for it says _PJ_TITLE now...

what's Bob Marion's username here?

EDIT:
Got it
 
Guardian2003
PostPosted: Sun Jul 16, 2006 1:25 pm Reply with quote

Looks like the language file for that module is missing then.
If you completely wiped your old site, you will have to add the Nuke Project module back in including any database changes it requires.
 
dubLeE
PostPosted: Sun Jul 16, 2006 2:32 pm Reply with quote

i didn't completely wipe my old site, it was just an upgrade. and after the upgrade NukeProject module stopped working. and even i try to install it again, i get errors which i posted a few posts up...
 
Guardian2003
PostPosted: Sun Jul 16, 2006 4:06 pm Reply with quote

I have just taken a quick look at the module and I am completely lost as to why it might be having this problem.
The only thing in it that affects core nuke is the mainfile.php edit.
 
Susann
Moderator


Joined: Dec 19, 2004
Posts: 3191
Location: Germany:Moderator German NukeSentinel Support

PostPosted: Sun Jul 16, 2006 5:01 pm Reply with quote

I had the same errors"Wrong datatype for second argument" couldn´t install Nuke Project correctly in this RavenNuke version but the Work Board Probe 1.4 version still works there and in RN version 2.02.00 NukeProject without problems.
 
View user's profile Send private message
Guardian2003
PostPosted: Sun Jul 16, 2006 5:23 pm Reply with quote

How strange. I'll try and look at this further then but I think it might be a job for Bob or Raven.
 
dubLeE
PostPosted: Sun Jul 16, 2006 6:14 pm Reply with quote

ok i feel REALLY stupid now.
i didn't do the edit for mainfile.php. didn't realize it HAD to be done =) since it didn't particularly state in the readme to do the edits.

hahaha seems to work now
 
Guardian2003
PostPosted: Sun Jul 16, 2006 6:28 pm Reply with quote

Excellent news.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.02.02 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©