Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
banelos
Hangin' Around


Joined: May 05, 2006
Posts: 30

PostPosted: Fri May 05, 2006 9:29 pm Reply with quote

I have succesfully installed Raven Nuke distro 2.02.02 and used a backup of a phpbb forum and got it to work and updated it.

Only 2 problems I seem to have at the moment though is Registration mails not being sent and wrongly placed bbcode when making posts

Registration mails not being sent:
Im receiving emails when a new PM is received or when I have been made a member of a new forum group, but when I try to recover a lost password or register a new user, the activation email never arrives.

I have tried using Only registered users can see links on this board! Get registered or login! to fix it and it seems to be helping, now I am at least getting a "mail undelivered" message to the admin mail I have set in config saying "unrouteable mail domain 'whatever email domain I registered'". And I have tried using different emails to register with.. No delivery on all trys.

Wrongly placed bbcode when making posts
For some reason when I insert bbcode in posts I am writing it is always placed in the end of the text no matter where I am writing. This bug I can't seem to find any clue to so far.

I hope some of you can help me with these 2 issues I am having.
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Sat May 06, 2006 9:29 am Reply with quote

What do you mean by a backup of a phpbb forum? Just tables, or scripts, too?

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
banelos
PostPosted: Sat May 06, 2006 4:09 pm Reply with quote

Naw just the database backup.
Used phpbbtonuke script afterwards to change the tables to the nuke_ prefix and then used the chatserv scripts to update the database from .0.11 to .0.20.
 
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sat May 06, 2006 5:01 pm Reply with quote

In terms of BBCode, if you hit the button using Firefox, it will default to the end. That is something that phpBB Group has not corrected yet.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
banelos
PostPosted: Sat May 06, 2006 5:15 pm Reply with quote

Ok thanks that is true, bbcode is inserted properly in IE.

Seems my only bug then is the missing activation emails. For further info I found that when registering a user with an email of the same domain as my server (fnguild.co.uk) the activation email got sent just fine.
 
banelos
PostPosted: Wed May 10, 2006 4:02 am Reply with quote

Been trying to figure out more about why these activation emails doesn't arrive.
I found out that the activation email will arrive properly if I register with an email of the same domain as the server (fnguild.co.uk) which is kinda strange.

Why would my server have trouble sending only activation emails to outside domains when it works for PM notifications etc. ?

Also it seems it doesn't matter if I change user activation from none, user or admin activated in the forum configuration. It will just say that an activation email has been sent to my mail when I register a new user no matter what the config says.

EDIT: Just a couple of other ravennuke related questions I have aswell I might aswell get off my chest. What should .htaccess and .staccess be CHMODed to? I don't have the option to use http auth in nukesentinel, only cgi-auth, any reason to this? I have all admin pass set in Admin Auth List aswell as put them on protected.
 
banelos
PostPosted: Mon May 15, 2006 12:43 pm Reply with quote

Found out that my server can't even execute simple mail() functions and that the other emails that are working is because they are executed over the smtp account I have set up in the forum configuration.

I am trying at the moment to get the mail() function fixed from my server, but is there any way I can make the activation and lost password emails be sent over my smtp server aswell? Been trying to find the code that connects to the smtp server to send the "New PM" so that I could look at the code and perhaps make my own hack for the activation email, but so far I havn't been able.
Any help would be greatly appreciated.
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Wed May 17, 2006 6:37 am Reply with quote

<bump>

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
banelos
PostPosted: Thu Jun 15, 2006 6:32 am Reply with quote

Ok so I just talked to my server admin.
Seems they have their mail() function disabled because of bots that use formmail scripts to spread spam with.

My question now is, why do PHPNuke not send out activation and lost password emails over the smtp account set up in the BBtoNuke board?

Is there any way to edit the parts of Your_Account module that has to do with Activation Emails and Lost Password Emails in order to make them be sent over the SMTP account I have, or any other way around this issue Im having. I have installed a module in admin part of site to activate temp users, but still I would like this solved in some way, if possible at all.

Thanks in advance.
 
spyrule
Worker
Worker


Joined: Jun 06, 2006
Posts: 105

PostPosted: Fri Jun 16, 2006 8:28 am Reply with quote

Hello,

For anybody reading this forum, their may be a solution here :
Only registered users can see links on this board! Get registered or login!

Spyrule
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©