Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help
Author Message
soulkeeper
New Member
New Member


Joined: May 02, 2005
Posts: 6

PostPosted: Mon May 02, 2005 1:16 pm Reply with quote

Hi

i installed Phpnuke 7.6 and what i did is upload the html files into the cgi folder , modified the config.php with my mysql info and added a databse in the mysql , anyway it worked i registered as administrator and i saw the site and everything is cool but when i click register nothing happen and when i click any section ( calendar , downloads , etc ) nothing happens at all and i cant even add a vote in the poll , no error messages , i just can post a message in the shout box ... what is the problem ?

second problem i noticed that the site is downloading the graphics everytime i open it or try to open a new section ? so slow ? is it a cach problem and how to make sure and how to solve ?

i had an smf forums , can i import and export database to the phpbb forums ? how ?

im really sorry if my questions seems noobish but the fact is im noob still.

plz help and thanks in advance .

Soulkeeper
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Mon May 02, 2005 2:34 pm Reply with quote

Just curious, why the CGI folder? Normally, their in the root directory or a /nuke directory or something else.

Are you using a loaded version of PHP-Nuke? Shout box isn't included with standard PHP-Nuke...

Did you create the tables in addition to the database?

Not sure what the graphics issue is. Might be a browser setting.

Not familiar with SMF forums. If you can't find an existing conversion script, you might be able to do it by extracting the data via phpMySQL, reformatting it, and uploading it to phpBB. Definitely not for the faint of heart...

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
64bitguy
The Mouse Is Extension Of Arm


Joined: Mar 06, 2004
Posts: 1159
Location: Sanbornton, NH USA

PostPosted: Mon May 02, 2005 7:42 pm Reply with quote

First, you should not install anything into your /cgi folder. Everything should be installed into the root level of your hosting space (for example, your /public_html folder which should be one level above your /public_html/cgi folder, if you will).

Next, there are some scripts that exist to import SMF forums data into phpBB; however, unfortunately, those won't work with the Nuke version as it is a port of phpBB versus being a "Stand-Alone" version of phpBB. Thus substantial work would need to go into these routines to redefine the phpBB table names (to match up with Nuke's version of phpBB).

_________________
Steph Benoit Only registered users can see links on this board! Get registered or login!
1CMS, 100% Section 508 and W3C XHTML/CSS Compliant (Truly) 
View user's profile Send private message Visit poster's website
kguske
PostPosted: Mon May 02, 2005 7:48 pm Reply with quote

Hi, Steph. Where did you find the import SMF to phpBB scripts? I searched but could only find references to a script being developed and to a phpBB to SMF script you can download...
 
64bitguy
PostPosted: Mon May 02, 2005 9:20 pm Reply with quote

Only registered users can see links on this board! Get registered or login! and Only registered users can see links on this board! Get registered or login!
 
kguske
PostPosted: Mon May 02, 2005 9:29 pm Reply with quote

Thanks...
 
soulkeeper
PostPosted: Tue May 03, 2005 3:35 am Reply with quote

Quote:

Why did you put everything in your cgi folder?


coz Only registered users can see links on this board! Get registered or login! said that :

All CGI scripts must be placed in the /www/cgi/ directory

so when i tried to take the Contents of HTML folder and upoad it to the root of my web site : clanoap.com/ i got an error ... when i tried to open the clanoap.com/admin.php i got the explorer opening the php as a text and firefox asks me to save that file ... but when i put them in cgi folder everything is fine .

Quote:
Did you expand the html folder or did you simply upload the html folder?


yes i expand it i took everything inside to the cgi folder .

and i had a simple machine forums

the slow cach problem and other problms are solved , i had a problem that module.php was no uploaded right to the site so i reuploaded it and everything went smooth except few things which i will explain now :

first of all when i open cpanel in administrator i see duplicated modules icons like for example i see 2 banners ids , 2 forums modules icons , 2 .. etc why ????
and then when i create a user a test one i log in and when i press account i get account not found even tho the test user is logged in normally .

i get this serious errors when i try to open the following modules :


Code:


legal documents

Fatal error: Cannot redeclare ns_doc_questions() in /www/cgi/modules/Docs/doc_config.php on line 198


calendar

Fatal error: Cannot redeclare prevday() in /www/cgi/modules/Calendar/datefuncs.php on line 371

Downloads

Fatal error: Cannot redeclare ns_download_mod_title() in /www/cgi/modules/Downloads/ns_downloads_file.php on line 431


Forums

Fatal error: Cannot redeclare head() in /www/cgi/header.php on line 49

Member list

Fatal error: Cannot redeclare head() in /www/cgi/header.php on line 49

Private messages

Fatal error: Cannot redeclare head() in /www/cgi/header.php on line 49

classified

Fatal error: Cannot redeclare menunukec() in /www/cgi/modules/Classifieds/functions.php on line 1091


shopping card


Fatal error: Cannot redeclare class emporium_shipping in /www/cgi/modules/Shopping_Cart/includes/class.shipping.php on line 85




aaa and one more thing , user is Test .. when i shout box and post a message when this user is looged in i get his name in the message as test&acute : , can i fix that ?

plz help Sad

Thanks in advance ,

Raul
 
64bitguy
PostPosted: Tue May 03, 2005 3:55 am Reply with quote

Hi..

First, you have serious problems. If this is a new installation, simply start by deleting everything that is nuke related out of your CGI folder.

I should explain that PHP-Nuke has nothing to do with CGI scripts whatsoever and does not belong in the CGI folder of any host. CGI Scripts are different and have no relation to nuke. A CGI script would end with .cgi and not .php (as is the case with Nuke files)

PHP-Nuke should only be installed at the PUBLIC root of your server. WWW is usually a "shortcut" to the location of your public_html folder (public_html is the name most commonly used by shared hosts and the default of linux servers for describing the PUBLIC root of your server, which is where PHP-Nuke should be installed). If you don't have a "public_html" folder, but rather only a "www" folder, okay fine... the "www" folder is where the Nuke files should be installed.

This is where all contents WITHIN the HTML folder of your PHP-Nuke zip file would go.

Now... Let's talk about that for a second. Where did you get your PHP-Nuke zip file? What version is it exactly and if you can, point me to the exact link where you got it. This will help me identify exactly what revision it is and what needs to happen next.

Also, what are you using to edit you files? You should be aware that you can't use word, or any regular editor. I suggest that you use Crimson Editor ( it is free and you can get it at Only registered users can see links on this board! Get registered or login! ). Remember, that php files can never have any blank lines at the end, the must always end in ?>

Sometimes, you can't see the blank lines in other editors and those cause serious problems with Nuke running the way it should.

Steph
 
soulkeeper
PostPosted: Tue May 03, 2005 12:12 pm Reply with quote

i admit that i have a serious problem Sad i have Phpnuke Platinum 7.6 and Only registered users can see links on this board! Get registered or login! is the site .

ok now i tried your advise and i put the contain of the html folder of the nuke in the root of my host , so i open the site like this : Only registered users can see links on this board! Get registered or login! so i get the explorer opening a text file of the php , and if i try it with fire fox it ask me to save the file as if im downloading something . my host is Only registered users can see links on this board! Get registered or login! and i think that php cant work unless it is in cgi folder ? thats what they said in support unless i dont understand them well which it happen sometimes lol .

and i use macromedia fire work to edit files but lately i use the free server php edit tool which is inside the host .

ty Steph for your reply Smile and i will try to install the phpnuke again from another download link , but BTW when i installed the phpnuke platinum on local server apache and EVERything worked so fine ...

Peace
 
64bitguy
PostPosted: Tue May 03, 2005 6:42 pm Reply with quote

Okay....

Again, I want to emphasize that you do not install in your CGI directory. As someone that builds servers, I can absolutely assure you that you would NEVER, EVER install a runtime .php solution in the CGI directory. It's not a matter for interpretation, it's a matter of what a server does. If your host is telling you to install Nuke in the CGI directory, you need a new host.

Next, as previously advised, you should use a local .php editor. My experience has been that host based editors corrupt files. As advised previously, download Crimson Editor and use that to edit your .php files.

At this point I can only assume that your problem is with hosting. It certainly looks that way anyway. You should contact you host and ask them to view this thread and have them reply based on the information within.

Finally, if you got Platinum to work on a local box, then it's not platinum, but rather your server, so that just kind of supports this whole assumption.

Hope this helps.
Steph
 
police01040
New Member
New Member


Joined: Mar 15, 2006
Posts: 1

PostPosted: Wed Mar 15, 2006 2:16 pm Reply with quote

Guys, am really need some help in converting smf to phpnuke
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Wed Mar 15, 2006 4:57 pm Reply with quote

I don't know SMF, but look for a SMF to phpBB converter. Then you can use a phpBB to phpNuke converter

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Installation Help

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©