Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro
Author Message
Hwange
New Member
New Member


Joined: Nov 28, 2005
Posts: 7

PostPosted: Thu Jan 26, 2006 6:37 pm Reply with quote

Just wondering if anyone can help!!!

I installed Raven's RavenNuke76 v2.x Distro and have one small problem.

When I try to email a group they bounce back.

I run 2 domains on my pc using aphache and have xmail for my mail server. All the mail functions work fine registration confirmation, lost password and newsletter.

I was wondering what nsn groups does different in the mail function to cause this bounce.

I'm still learning PHP but as far as I can see the mail() function is what determines the settings that differ.

All the standard mail() functions in nuke are as follows

mail($user_email, $subject, $message, "From: $adminmail\nX-Mailer: PHP/" . phpversion());

and they all work, however in \admin\modules\nsngroups\NSNGroupsUsersEmailSend.php it's

mail($to, $gsubject, $gcontent, $headers);

The $Headers are

$headers .= "From: $aname <$amail>\r\n";
$headers .= "Return-Path: $amail\r\n";
$headers .= "Reply-To: $amail\r\n";
$headers .= "X-Mailer: NSN Groups";

I've tried replacing $headers with "From: $adminmail\nX-Mailer: PHP/" . phpversion()) but no joy

Any advise would be great
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Thu Jan 26, 2006 7:15 pm Reply with quote

Have you checked the email to see why it was treated as spam? Were all of the emails rejected / treated as spam, or just some?

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
Hwange
PostPosted: Thu Jan 26, 2006 7:22 pm Reply with quote

Thanks Kguske,

Just checked the logs in Xmail and it seemed to be trying to sent it to the name of the group instead of the email addresses.

Solved it now, in the NSNGroupsUsersEmailSend.php I just changed
this

after getting the $email from a query it added this line
$to = ""._GR_GLET." <$email>";

I just got rid of that line and changed

mail($to, $gsubject, $gcontent, $headers);
to
mail($email, $gsubject, $gcontent, $headers);

All working great now
 
kguske
PostPosted: Thu Jan 26, 2006 7:43 pm Reply with quote

Awesome! I haven't used that function, so I hadn't noticed that. Thank you for following up...

I recommend that your fix be included in future versions of both NSN Groups and RavenNuke.
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Sun Mar 05, 2006 8:07 am Reply with quote

Quote:

I recommend that your fix be included in future versions of both NSN Groups and RavenNuke.


Fixed in version 2.02.02 patch release.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v2.00.00 - v2.02.00 Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©