Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> WYSIWYG - Raven's RavenNuke(tm) v2.x Distro
Author Message
bfnuke
Hangin' Around


Joined: Feb 01, 2006
Posts: 43

PostPosted: Wed Feb 01, 2006 1:37 pm Reply with quote

Ok, I just installed the new distro and the FCK editor. I realize that php5 and mysql 4 together are not "supported" as I read in a different post, but this has got to be a very simple thing to fix. Just can't find the exact place to fix it.

When I am in the admin->preferences area, the footer message text boxes give this instead:

Not Found

The requested URL /\/includes/FCKeditor/editor/fckeditor.html was not found on this server.
Apache/2.0.55 (Win32) PHP/5.0.5 Server at localhost Port 80

Notice the /\/. Playin around with teh fckeditor.php code in teh constructor, I have determined that this:
Code:


      if ($strBP{strlen($strBP)-1} != "/") $strBP   .= "/";


Seems to be true. I determined this by changing the "/" to "x/x" and seeing what changed.

If I that line, then the error looks like this:

The requested URL /\includes/FCKeditor/editor/fckeditor.html was not found on this server.

Notice a "/" is missing. So this makes me think that this code:

Code:


$strBP = dirname($_SERVER['PHP_SELF']);


is returning "/\" instead of just "/" because removing that line (the dirname code) the editor works fine.

So the questions I have are:

1> Why is it returning "/\" instead of just "/"? Is this a function of apache, or php5, or something else?

2> Does it always return this? If so, maybe we can substring the "\" out of it?


I am running on Localhost
Apache 2.0.55
PHP 5.0.5
MySql 4.1.15
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Wed Feb 01, 2006 8:02 pm Reply with quote

It's a function of PHP, but it seems like a bug. If you're running Nuke in the root directory, just replace
Code:
if ($strBP{strlen($strBP)-1} != "/") $strBP   .= "/"; 
with
Code:
$strBP = "/";

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
bfnuke
PostPosted: Thu Feb 02, 2006 7:42 am Reply with quote

But isn't this code here to help automatically determine where it is running from and adjust accordingly?

Personally, I just removed all the checks completely for my purpose, but thought there may be a way to 'program' around it so you still have the functionality of automatically adjusting for either case.
 
kguske
PostPosted: Thu Feb 02, 2006 9:10 pm Reply with quote

That's the goal, and it worked fine for everyone else so far. There is something strange / different about your setup...
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> WYSIWYG - Raven's RavenNuke(tm) v2.x Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©