Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x
Author Message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Tue Jan 10, 2006 8:02 am Reply with quote

It has come to my attention (thanks Foggy) that the CGI Auth routines were not always honoring the NukeSentinel(tm) admin username. depending on how the .staccess file was created, NukeSentinel(tm) was mistakenly using the nuke_authors table aid column. As a result, you could never get a match for security.

To correct this, you need to modify 1 line in 2 different files.

Edit admin/modules/nukesentinel/ABAuthEditSave.php
FIND
$stwrite .= $adminrow['aid'].":".$adminrow['password_crypt']."\n";

CHANGE TO
$stwrite .= $adminrow['login'].":".$adminrow['password_crypt']."\n";


Edit admin/modules/nukesentinel/ABCGIBuild.php
FIND
$stwrite .= $adminrow['aid'].":".$adminrow['password_crypt']."\n";

CHANGE TO
$stwrite .= $adminrow['login'].":".$adminrow['password_crypt']."\n";

This will be corrected in the next release of NukeSentinel(tm)

This will be referred to as v2.4.2pl3 until we release v2.4.3
 
View user's profile Send private message
Raven
PostPosted: Tue Jan 10, 2006 9:51 am Reply with quote

I have also made a download patch available from Only registered users can see links on this board! Get registered or login!
 
djrino
Regular
Regular


Joined: Mar 11, 2005
Posts: 52

PostPosted: Tue Jan 10, 2006 1:52 pm Reply with quote

Hi raven many tnx fo suppor to sentinel..
i don't find the v2.4.2pl3 i have take a look on nukescript and here but nothing where is the v2.4.2pl3????

Many tnx
 
View user's profile Send private message
Raven
PostPosted: Tue Jan 10, 2006 2:30 pm Reply with quote

In the post right above yours is the link.
 
djrino
PostPosted: Tue Jan 10, 2006 2:37 pm Reply with quote

this is a upgrade file s not a full version
i dont' find the full versios v2.4.2pl3 to make this fix
 
Raven
PostPosted: Tue Jan 10, 2006 2:44 pm Reply with quote

The full version v2.4.2 is available from Only registered users can see links on this board! Get registered or login! You will still need to apply this patch.
 
djrino
PostPosted: Tue Jan 10, 2006 2:46 pm Reply with quote

Ok many tnx Smile
 
rino
New Member
New Member


Joined: Dec 06, 2005
Posts: 12

PostPosted: Tue Jan 10, 2006 5:11 pm Reply with quote

Ciao Raven,

on the download patch i see 3 files and not 2.
-admin/modules/nukesentinel/ABAuthEditSave.php
-admin/modules/nukesentinel/ABCGIBuild.php
-includes/nukesentinel.php

Wich its correct patch? 2 files or 3 files?
Thanks for your big work!
Rino Only registered users can see links on this board! Get registered or login!

_________________
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message
Raven
PostPosted: Tue Jan 10, 2006 5:26 pm Reply with quote

All 3 - it is a cumulative patch
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©