Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v1.x Distro
Author Message
Stray_Bullet
New Member
New Member


Joined: Nov 13, 2004
Posts: 17
Location: New York, USA

PostPosted: Sat Jan 07, 2006 4:27 pm Reply with quote

Is there going to be a continuation of RavenNuke7.6 version 1... Like as in support, fixes & so on?

I would rather not upgrade to version 2 because I like a plain & simple Nuke. I am not looking to have all these new additions that I am not going to use anyway, just more stuff to have to update... More things for people to try & hack into... More space being taken up...

I like this package as it is now, or would I be better off just getting a regular 7.6 package that has been patched with chatserv's files. I use nuke sentinel & always apply the fixes from nukefixes.com anyways...

Thanks in advance...
 
View user's profile Send private message Visit poster's website
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9456
Location: Arizona

PostPosted: Sat Jan 07, 2006 6:10 pm Reply with quote

Stray_Bullet, I would doubt it from a development standpoint. From a support standpoint, most likely "yes". This release was by no means "bloated". In fact, the WYSIWYG editor was provided as a separate add-on. I would highly recommend this release as a good foundation.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sat Jan 07, 2006 6:49 pm Reply with quote

Correct, Montego. There will be no further development on ANY previous version. We will support and offer fixes for those versions, but I will not patch them. In other words, if Chatserv was to release a 3.2 or a 4.0 fixpack, I will apply that to the latest version but not any previous versions. That will be your responsibility. I am disabling the previous versions shortly.
 
View user's profile Send private message
Stray_Bullet
PostPosted: Sun Jan 08, 2006 5:41 pm Reply with quote

Okay but this stuff can be disabled? Like the photo gallery, the WYSIWYG editor & so on?

If so is it disabled through the config, or just through the modules administration?

I guess if this stuff can be disabled, I will go ahead & upgrade. Thanks for your replys!
 
montego
PostPosted: Sun Jan 08, 2006 5:54 pm Reply with quote

Currently, with 2.0.0, there is no photo gallery and the WYSIWYG editor is a separate install - In other words, if you want it, Raven and Kguske have made it really easy to include it in your nuke site. But, you don't even have to upload it if you do not wish to.

I cannot say for sure, how Raven is going to implement modules in the future. However, this version gets you the latest of the forums, a few additional bug fixes, and NSN Groups, which is really useful to have in your "back pocket" if you need to start restriction content based on groups you define.

All good stuff.
 
Raven
PostPosted: Sun Jan 08, 2006 6:46 pm Reply with quote

At the present time, with the way nuke is [un]structured, it would be nearly impossible to modularize these things. The only reason WYSIWYG is "experimental" is because we kind of pushed it in at the last minute. Not that it isn't thoroughly tested. It is, as much as we, as developers and the test team, could see fit to test. If all goes well, it will become a part of the v2.1.0 release. It can be turned off via config.php. That's the beauty of it.

Now, as to G2 and other essentials that the Community identified in the poll, I will do the best I can to make it so you can use it or not. Sometimes the code changes are too great and you have to do what you have to do. You can always choose to not activate the module. Easy - Done.

But, since there will be 4 or 5 addons, I can't make the code dependent on addon-1 and addon-3, or addon-2, addon-3, and addon-5. See what I mean? The code will have to be made to all work together and then you will need to control what is active or not through other means.

That's what this stage of the Distro is all about. A preconfigured, ready to go, out-of-the-box CMS that is fully integrated in all essential addons. Then you choose whether or not to use any, all, or none.

The only downside to all this is that when you go to do updates, your code may or may not resemble, exactly, the integrated code. That's where I and those helping support RavenNuke76(tm) will issue upgrades.
 
Stray_Bullet
PostPosted: Mon Jan 09, 2006 3:35 pm Reply with quote

Okay it sounds good! So basically when I see security fixes & stuff @ nukefixes.com I probably shouldn't apply them? Because I might mess up some code that has to do with RavenNuke addons? I usually go there two or three times a week and see different fixes...

Well another question, do these addons add anything to the database? Like add or alter tables, besides like the modules table & so on...

I appreciate all the help! Razz
 
Raven
PostPosted: Mon Jan 09, 2006 3:47 pm Reply with quote

Nukefixes is a different story. If someone has found a hole that needs patching, Chat usually notifies me and I respond appropriately. Not all "patches" are global in scope. Some are for very specific circumstances. My practice, as a whole, is to only apply the Patches when Chat releases a full package. I can't say that applying these others will mess up anything, but when I issue another release it will be predicated upon my previous release, not your patches.

Some will alter tables, but that's the beauty of the Distro. I/we have already worked out the integration issues for you. You can always examine the SQL to see specifically what is being changed.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's RavenNuke(tm) v1.x Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©