Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke
Author Message
SpaceMonkey
Worker
Worker


Joined: Apr 30, 2005
Posts: 170

PostPosted: Sun Jan 08, 2006 5:26 am Reply with quote

Are the chatserve patches cumulative or can I just use the latest ones? I have no idea which ones I'm up to.. Is there any way of checking?

BTW.. Thanks to this site for keeping me up to date.. Smile
 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Jan 08, 2006 1:24 pm Reply with quote

They are not cumulative.
 
View user's profile Send private message
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Sun Jan 08, 2006 1:34 pm Reply with quote

I think he's asking about the Patched files themselves. Yes they are cumulative... that is, 3.1 replaces 3.0, 2.9...

However, the BBToNuke packages are not cumulative.

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
SpaceMonkey
PostPosted: Sun Jan 08, 2006 5:27 pm Reply with quote

Yeah I'm actually talking about the patched files themselves. i.e.

12/07/04 - Version 2.8
02/15/05 - Version 2.9
04/29/05 - Version 3.0
06/24/05 - Version 3.0 For PHP-Nuke 7.8
07/28/05 - Version 3.1

If I have version 2.8 can I just install 3.1? Or do I have to do 2.8 then 2.9 then 3.0 then 3.1?

If so, how do I know which patched version I have?
 
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9453
Location: Arizona

PostPosted: Sun Jan 08, 2006 5:59 pm Reply with quote

SpaceMonkey, quite honestly, in my opinion, it is always best to download the latest patches, unzip them in a separate directory and use a good comparison tool, such as Beyond Compare 2 (there are others mentioned in several forum posts here) to compare the provided patched files/directories with your nuke installation.

This is unless of course you have made NO changes to these core nuke scripts along the way.

Unfortunately, there was no consistency in any kind of internal script comments or setting up a constant to easily tell which patchset is installed. Would have been a very useful tool for not only web masters, but also module designers to be able to look at a version constant / variable and take different program paths accordingly. But, that is water under the bridge so to speak.

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
evaders99
PostPosted: Sun Jan 08, 2006 11:25 pm Reply with quote

Yes, you can install 3.1 over 2.8

If you saved the readme.txt or the changes.txt, then you should have the Patched version number.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©