Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
SpaceMonkey
Worker
Worker


Joined: Apr 30, 2005
Posts: 170

PostPosted: Mon Dec 12, 2005 8:19 pm Reply with quote

I'm about to upgrade from 2.3.1 to 2.4.2 and I'd like some advice before proceeding. The only core files that will need editting are YourAccount/index and the mainfile.

I'm guessing I have to update all the rest of the files.

When I do the install, will it make the appropriate changes to the database? Or do I have to delete some of the old ones?

TIA [/b]
 
View user's profile Send private message Visit poster's website
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Mon Dec 12, 2005 8:28 pm Reply with quote

Not trying to be smart-alec, but just follow the instructions Wink - no other advise is needed.
 
View user's profile Send private message
SpaceMonkey
PostPosted: Mon Dec 12, 2005 8:50 pm Reply with quote

I can't seem to find "global $setinfo, $user_prefix, $db, $module_name, $pm_login, $prefix;" in the core file "Your Account"....
 
Raven
PostPosted: Mon Dec 12, 2005 9:00 pm Reply with quote

What version of Nuke?
 
SpaceMonkey
PostPosted: Mon Dec 12, 2005 9:22 pm Reply with quote

I'm using 7.7... I found it.. It's weird that BBedit seems to have trouble finding these things..
 
SpaceMonkey
PostPosted: Mon Dec 12, 2005 9:50 pm Reply with quote

My mainfile has this
Code:
if (defined('FORUM_ADMIN')) {

    @require_once("../../../config.php");
    @require_once("../../../db/db.php");
} elseif (defined('INSIDE_MOD')) {
    @require_once("../../config.php");
    @require_once("../../db/db.php");
} else {
    @require_once("config.php");
    @require_once("db/db.php");
}

/* FOLLOWING LINES ARE DEPRECATED BUT ARE HERE FOR OLD MODULES COMPATIBILITY */
/* PLEASE START USING THE NEW SQL ABSTRACTION LAYER. SEE MODULES DOC FOR DETAILS */
if (defined('FORUM_ADMIN')) {
    @require_once("../../../includes/sql_layer.php");
    $dbi = sql_connect($dbhost, $dbuname, $dbpass, $dbname);
} elseif (defined('INSIDE_MOD')) {
    @require_once("../../includes/sql_layer.php");
    $dbi = sql_connect($dbhost, $dbuname, $dbpass, $dbname);
} else {
    @require_once("includes/sql_layer.php");
    $dbi = sql_connect($dbhost, $dbuname, $dbpass, $dbname);


It doesn't have what's described in the mainfile edit text... Should I just replace the above with what's described in the edit?
 
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Mon Dec 12, 2005 10:05 pm Reply with quote

If you're using the 3.1 patch, search the forums here for alternate instructions.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
SpaceMonkey
PostPosted: Mon Dec 12, 2005 10:31 pm Reply with quote

I know I'm using some version of chatservs patches. How do I find out if it's 3.1? I've tried searching the forums for alternate instructions and can't find them.

Can anyone point them out?
 
SpaceMonkey
PostPosted: Mon Dec 12, 2005 11:35 pm Reply with quote

Everything seems to be working and I'm running 2.4.2 Thanks..
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©