Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff
Author Message
blith
Client


Joined: Jul 18, 2003
Posts: 977

PostPosted: Tue Oct 25, 2005 2:38 pm Reply with quote

It is getting really hard to keep up with everything that needs to be done when installing and upgrading and which version to use and what to patch and which line to change... it seems so crazy sometimes. I try to do searches but there are umpteen results on one search and then the answers can vary depending on which version you are using and what it is patched to? My problem is this. I am using 7.6 patched to 3.1 (thanks Chatserv) with latest Sentinel installed (thanks Raven and Bob) then I needed to upgrade the forums and lo and behold I found out that applying upgrades over patch files can ruin the whole thing so now I get a blank admin page in the forums. I did a search and there are many answers but most are specific to some version I do not have and the threads are old. What should I do in this case? In all cases I want to learn how to do it and be able to help in the future but for now I just need to know what to do to fix my problem.... thank you all for your patience with those of us who do not know.
 
View user's profile Send private message Visit poster's website
evaders99
Former Moderator in Good Standing


Joined: Apr 30, 2004
Posts: 3221

PostPosted: Tue Oct 25, 2005 3:00 pm Reply with quote

Use the Patched files - it upgrades your forums to BBToNuke 2.0.17 already. Don't forget to run the upgrade file

_________________
- Only registered users can see links on this board! Get registered or login! -

Need help? Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
blith
PostPosted: Tue Oct 25, 2005 3:33 pm Reply with quote

umm I am not sure what you mean. I realize I may have made the mistake about upgrading patched files but after the virgin install of 7.6 (3.1) my forums were still 2.10. How do I upgrade them to 2.17?
 
evaders99
PostPosted: Tue Oct 25, 2005 8:21 pm Reply with quote

Did you run the upgrade script?
 
64bitguy
The Mouse Is Extension Of Arm


Joined: Mar 06, 2004
Posts: 1159
Location: Sanbornton, NH USA

PostPosted: Wed Oct 26, 2005 12:43 am Reply with quote

This is the inherant problem from running PHP-Nuke. Frankly, there is no solution as the PHP-Nuke author refuses to incorporate known fixes. Furthermore, he fails to maintain the baseline modules including phpBB forums. So usually when there are forums upgrades, default Nuke is behind, even with new releases. It is left to Chatserv to patch the existing versions and release patches. This also applies to things like NukeSentinel and other modules.

The bottom line is that if project development was consolidated, none of that would be necessary and evolution and improvements could be made so that each new release meant more fixes and better security and actually improvements versus what PHP-Nuke actually is which is more bugs, more instability, less security and more patching required with each new release.

_________________
Steph Benoit Only registered users can see links on this board! Get registered or login!
1CMS, 100% Section 508 and W3C XHTML/CSS Compliant (Truly) 
View user's profile Send private message Visit poster's website
blith
PostPosted: Wed Oct 26, 2005 8:19 am Reply with quote

Go Raven!! What he said!! lol Thanks 64-bitguy. Can you help me with my problem? What should I do now that I have ran bbtoNuke upgrade scripts on a 7.6(3.1) install? And like I said the only reason I ran the upgrade scripts is because my forums were still 2.10 after install. How do I get them to 2.17 and working? Thanks for everyones help by the way I do appreciate it.
 
blith
PostPosted: Wed Oct 26, 2005 8:22 am Reply with quote

okay, I just saw the sticky... boy am I stooopid.... but I still have the blank admin page problem. I made all the changes necessary but it is still blank... which would mean I really didn't right? Well can anyone lay those out straight and clear in one easy to read post and make it a sticky? thanks.
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Wed Oct 26, 2005 9:12 am Reply with quote

I will take a look at your setup. PM me your id's and password's.
 
View user's profile Send private message
blith
PostPosted: Wed Oct 26, 2005 11:27 am Reply with quote

Thank you Raven. I have PMd the info. If I left anything out please let me know.
 
Raven
PostPosted: Wed Oct 26, 2005 12:46 pm Reply with quote

I'll look into it as soon as I can.
 
64bitguy
PostPosted: Wed Oct 26, 2005 4:22 pm Reply with quote

Doh, hey sorry about that... When I posted this, it was in reference to the first post and the title and I thought you were commenting. There is a couple of posts on here about the process and sequence of doing these updates. 20 hour day... in any event, my bad.

My last couple of posts at: Only registered users can see links on this board! Get registered or login! start to address the proper sequence to upgrade through 2.0.15. For anyone reading this, that is the proper sequence to use and it should be continued with BBtoNuke updates through 2.0.17 (soon to be 2.0.1Cool.

Start reading where my post is dated: Posted: Fri Jun 17, 2005 7:49 am

Please note that Chatserv has also created some new updates of these older versions that include the OLD "Patched" methodologies to eliminate the problem identified that you can't see forums admin functions after the 2.0.15.

So given that, you should check for a different 2.0.15 version of BBtoNuke that runs on "Patched" revisions prior to 3.1. Once all "BBtoNuke" forums updates are done, simply overwriting all files with the latest patched files and run the patched update and that should do the trick.

Hope this helps.
Steph
 
blith
PostPosted: Thu Oct 27, 2005 10:23 am Reply with quote

Okay. So now I am reinstalling Nuke 7.6(3.1) then I am going to do the forum upgrades, then I am going to do the nuke upgrade, then I do what? Is this the order or am I missing something. Thanks! Oh yeah and I will do Sentinel after all is said and done...
 
blith
PostPosted: Thu Oct 27, 2005 11:34 am Reply with quote

disregard. I am following 64bitguy's guide...
 
blith
PostPosted: Fri Oct 28, 2005 9:46 am Reply with quote

Okay, I reinstalled 7.6(3.1), installed Sentinel, ran all the forum upgrades, installed 7.6 patched files, did the upgrade.php, ran the upgrade sql.
Two things I have noticed right off the bat is that Sentinel has disappeared from the admin menu.. and when I set a theme it does not stick to the Your Account page. Where did I go wrong? Thanks.
____________________________________________________
Alright I got Sentinel back. i just had to redo the core edits.. but my Your Account Module stays in Deep Blue no matter what theme I have. Can anyone help with this? Thanks!
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©