Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sat Oct 15, 2005 11:16 am Reply with quote

Just towards the top, like after the include('mainfile.php'); statement.
 
View user's profile Send private message
alexwise
Regular
Regular


Joined: Oct 15, 2005
Posts: 80

PostPosted: Sat Oct 15, 2005 11:21 am Reply with quote

ok done , but no effect agan.
 
View user's profile Send private message
Raven
PostPosted: Sat Oct 15, 2005 11:23 am Reply with quote

Let's be sure we are on the same page. You have 7.6pl3.1 installed and your theme isn't displaying the right hand blocks like on the home page. Correct?
 
alexwise
PostPosted: Sat Oct 15, 2005 11:24 am Reply with quote

Yes Correct
 
Raven
PostPosted: Sat Oct 15, 2005 11:28 am Reply with quote

Those changes should allow the right blocks to appear whenever a module is loaded in the browser window. So, if News is your home page and you have added $index=1; to News/index.php then when you pull up News you should see the right blocks.
 
alexwise
PostPosted: Sat Oct 15, 2005 11:33 am Reply with quote

the blocks show up when you click to view a module like News as you say, but the right blocks dont show up on the home page.
 
alexwise
PostPosted: Sat Oct 15, 2005 11:35 am Reply with quote

lol and looks rubish, cos now ive got the news all squashed in the middle of the blocks, were on that page view I would normally have no right blocks so the news could fit with the votingf on the left and print freindly block etc.
 
alexwise
PostPosted: Sat Oct 15, 2005 11:37 am Reply with quote

AH hang on, i just needed to put it in the index.php file :s
 
Raven
PostPosted: Sat Oct 15, 2005 11:40 am Reply with quote

Smack Bang Head
 
alexwise
PostPosted: Sat Oct 15, 2005 11:43 am Reply with quote

ok, but now ive got the news module all screwed up with the right blocks showing when they shouldnt even though ive removed the $index=1 in the index.php for news module?
 
Raven
PostPosted: Sat Oct 15, 2005 11:48 am Reply with quote

Did you comment out this line also define('INDEX_FILE', true);?

BTW, donations are always welcomed Wink
 
alexwise
PostPosted: Sat Oct 15, 2005 11:53 am Reply with quote

I didnt but that line is in index.php ...

$modpath .= "modules/$name/".$mod_file.".php";
if (file_exists($modpath)) {
include($modpath);
} else {
define('INDEX_FILE', true);

Also my account goes to a white page and I cant login as a user or vote, and proberly a tone of other things I havent looked at, what am I missing now "SLAMS HEAD ON DESK AND SHOUTS WERE CAN I FIND A LOWER VER OF THE PATCH!"

Also I cant get in the forum it gives this msg..

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
 
alexwise
PostPosted: Sat Oct 15, 2005 11:57 am Reply with quote

ok i Just ran upgrade.php and the forum works but my account and poll voting are still going to white pages and the blocks are still showing on pages they shouldnt.
 
Raven
PostPosted: Sat Oct 15, 2005 11:57 am Reply with quote

You only need to comment it out in News/index.php for the moment as that's what you're asking about. Make sure that in News/index.php, $index=1; and define('INDEX_FILE', true); are both commented out. Then, as long as you have made no other errors/changes other than adding $index=1; in the 2 files I told you earlier, everything should be working.
 
Raven
PostPosted: Sat Oct 15, 2005 11:58 am Reply with quote

alexwise wrote:
ok i Just ran upgrade.php and the forum works but my account and poll voting are still going to white pages and the blocks are still showing on pages they shouldnt.
You need to comment out the define('INDEX_FILE', true); and $index=1; in every module that you do not want right blocks on.
 
alexwise
PostPosted: Sat Oct 15, 2005 12:09 pm Reply with quote

right well the define('INDEX_FILE', true); is now commented out in news, but still shows up and the fourm index.php dosent even have that line in it soo I cant comment it out to stop it showing up. :@

I think im gonna give up on this Sad
 
Raven
PostPosted: Sat Oct 15, 2005 12:18 pm Reply with quote

Are you using your theme or a standard theme?
 
alexwise
PostPosted: Sat Oct 15, 2005 12:20 pm Reply with quote

My theme
 
Raven
PostPosted: Sat Oct 15, 2005 12:25 pm Reply with quote

And in News/index.php you do not have $index=1;?
 
alexwise
PostPosted: Sat Oct 15, 2005 12:31 pm Reply with quote

Nope, I just looked with a diff theme and the blocks do not show up on news anymore anymore.

Its deff this theme screwing things up.

ok thanks for your help but im gonna give up on this 3.1 patch, I think for me with this theme its gonna make more sence to go for a lower patch so I dont get this problem with the blocks, thats if I can find 2.9 or 3.0 ive looked evry were.

Why does Sentinal need these patches ?
Ive seen so many posts about problems with the patches, cant sentinal run on its own, perhaps with these fixes included?
 
Raven
PostPosted: Sat Oct 15, 2005 12:36 pm Reply with quote

The problem is not in the patches, per se. The patches are there for a very good reason - security. NukeSentinel does not need these patches as much as it works with them. Otherwsie we would constantly be writing routines to patch each others code. Both serve distinctive purposes. Frankly, if it were me, I'd rather spend a few bucks to get the theme fixed, knowing that my site is as secure as it can be. I think you are making an unwise decision, but that's just my opinion Wink.
 
alexwise
PostPosted: Sat Oct 15, 2005 12:41 pm Reply with quote

Im not saying the patches are usless I think its good they are made to fix holes in the orig code, thats why Im trying to get it to work.
But ive spent 3 days on this, and its not my website lol, and some patch with Sentinel is better than ver 6.8 with no security which is what we curently have.

But by the looks of things im not gonna be able to find a lower patch Sad
 
Raven
PostPosted: Sat Oct 15, 2005 12:51 pm Reply with quote

Contact Chatserv directly. If anyone has copies, he does. But, I still think you (or I) may just have missed something because those changes are all that should be required. Oh well, good luck.
 
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Sat Oct 15, 2005 1:19 pm Reply with quote

well if chatserv cant help you give a yell...
i still have my version of 7.6 3.0,but stripped from languages.
 
View user's profile Send private message
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©