Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff
Author Message
Vchat20
Hangin' Around


Joined: Nov 27, 2004
Posts: 31

PostPosted: Tue Sep 27, 2005 4:40 am Reply with quote

just curious on this one: is it possible for multiple, separat nuke sites to share a single nuke_users table? this way the user's login and personal settings are trnasportable across each site.
 
View user's profile Send private message
chatserv
Member Emeritus


Joined: May 02, 2003
Posts: 1389
Location: Puerto Rico

PostPosted: Tue Sep 27, 2005 12:27 pm Reply with quote

You would need to host the database tables for all sites on one database each set of tables with their own prefix but sharing the same user_prefix on all sites, that way all user info would be pulled from only one users table.
 
View user's profile Send private message Visit poster's website
Vchat20
PostPosted: Thu Sep 29, 2005 7:25 am Reply with quote

ok. yeah. i did read that in the howto pages on the official phpnuke website and from what i read it does exactly what i want. but im having trouble here. heres my two websites:
Only registered users can see links on this board! Get registered or login!
-and- Only registered users can see links on this board! Get registered or login!

the TLD is the original site i have already established. the subdomain is the one im starting up and want to share the user database with. i edited the config file for the subdomain site. heres the related section:

Code:
$dbhost = "localhost";

$dbuname = "pokeocom_sq";
$dbpass = "****";
$dbname = "pokeocom_sq";
$prefix = "ksim";
$user_prefix = "nuke";
$dbtype = "MySQL";
$sitekey = "SStgF54$3@+%288-982%/(-derThsR-23";
$gfx_chk = 3;
$subscription_url = "";
$admin_file = "admin";
$tipath = "images/topics/";
$nuke_editor = 1;
$display_errors = true;


pokeocom_sq is the database where the original site was installed to. it got installed under the default 'nuke_' prefix. i also made sure to edit the nuke.sql before uploading so it added the fields in the database under 'ksim_'.

basically what its doing (i assume from what the site is showing) is assuming the nuke_ prefix despite having changed it in the config.

any ideas on whats going wrong?


btw, the TLD is running nuke 7.7 and the subdomain is running 7.9
 
Vchat20
PostPosted: Thu Sep 29, 2005 4:48 pm Reply with quote

ok. i think i figured it out somewhat. cuz i ended up moving the line $prefix = empty($user_prefix) ? $prefix : $user_prefix; out of config.php and the site is working. mind informing me what exactly that line does and why its needed? it was an educated wild guess considering it had $prefix = at the beginning and inside it had $user_prefix so it probably had something to do with it.
 
chatserv
PostPosted: Thu Sep 29, 2005 11:26 pm Reply with quote

The line would set all prefix related variables to user_prefix, i guess i uploaded that change by mistake so i'll take it out.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> General/Other Stuff

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©