Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x
Author Message
topmug
Hangin' Around


Joined: Aug 11, 2005
Posts: 26

PostPosted: Thu Aug 11, 2005 1:11 am Reply with quote

Hi there, i installed Nuke Sentinel on my patched 3.1 7.4 nuke setup and several users are having problems when trying to post.

The error they get when they hit the post button is

Code:
Warning: your browser doesn't send the HTTP_REFERER header to the website. 

This can be caused due to your browser, using a proxy server or your firewall.
Please change browser or turn off the use of a proxy
or turn off the 'Deny servers to trace web browsing' in your firewall
and you shouldn't have problems when sending a POST on this website.


Has any one got any idea how i can stop this.

Thanks in advance

Tom
 
View user's profile Send private message
kguske
Site Admin


Joined: Jun 04, 2004
Posts: 6383

PostPosted: Thu Aug 11, 2005 10:10 am Reply with quote

It's unlikely to be the browser, since many are having the same problem. Is your server behind a firewall (or running a software firewall)? If so, check what the message suggests.

_________________
I google, therefore I exist...
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
technocrat
Life Cycles Becoming CPU Cycles


Joined: Jul 07, 2005
Posts: 511

PostPosted: Thu Aug 11, 2005 10:43 am Reply with quote

Yeah its the one line in 3.1 that I thought was a bad idea. Sad

In mainfile.php find:
Code:
if ($_SERVER['REQUEST_METHOD'] == "POST") {

  if (isset($_SERVER['HTTP_REFERER'])) {
    if (!stripos_clone($_SERVER['HTTP_REFERER'], $_SERVER['HTTP_HOST'])) {
        die('Posting from another server not allowed!');
    }
  } else {
    die($posttags);
  }
}


Delete it or comment it out /* */

_________________
Only registered users can see links on this board! Get registered or login!
Only registered users can see links on this board! Get registered or login! / Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message
topmug
PostPosted: Thu Aug 11, 2005 11:09 am Reply with quote

Thanks Mate, ill give it ago!
 
topmug
PostPosted: Fri Aug 12, 2005 12:52 am Reply with quote

Cheers mate, that worked a treat!

appreciated!

Tom Very Happy
 
BobMarion
Former Admin in Good Standing


Joined: Oct 30, 2002
Posts: 1037
Location: RedNeck Land (known as Kentucky)

PostPosted: Sun Aug 14, 2005 11:11 am Reply with quote

I can tell you this, while it's not truely a NS issue, that many of the "Internet Security" products mask the http referer or entirely remove it. Norton's and McAfee are two that come to mind right off the bat.

Anyway, I will look at NS's main file to see if there is any reason it would trigger this piece of code in mainfile.php .

_________________
Bob Marion
Codito Ergo Sum
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
fkelly
Former Moderator in Good Standing


Joined: Aug 30, 2005
Posts: 3312
Location: near Albany NY

PostPosted: Wed Dec 07, 2005 4:18 pm Reply with quote

Thought I would just add a bit to this after having spent the last few days tracking down a related problem. I just upgraded from Nuke 7.4 to 7.6 with patched 3.1 and Sentinel 2.4.2. Have Gallery software installed and was getting a crazy message:
Quote:
Server contacted, but Gallery not found at this URL ( Only registered users can see links on this board! Get registered or login!"


Went thru all sorts of searches and experiments looking at applet code and Gallery PHP code before I saw a reference to the referer blocking code in mainfile.php causing the problem.

So I commented out:

Code:
/* if ($_SERVER['REQUEST_METHOD'] == "POST") {

  if (isset($_SERVER['HTTP_REFERER'])) {
    if (!stripos_clone($_SERVER['HTTP_REFERER'], $_SERVER['HTTP_HOST'])) {
        die('Posting from another server not allowed!');
    }
  } else {
    die($posttags);
  }
} */
 

in mainfile and voila. Incidentally, as far as I can tell the referer blocks in Sentinel don't affect this. I turned them off for testing and the Gallery applet upload worked okay, but when I turned them back on it still worked okay. But if I uncomment the block in mainfile I get the problem right back.

Note to Gallery users, this also affects slideshows using the applet method.
 
View user's profile Send private message Visit poster's website
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™ v2.4.x

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©