Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> GT - Next Gen and Standard
Author Message
Nuke_Royal
New Member
New Member


Joined: Nov 20, 2004
Posts: 16

PostPosted: Tue Jul 12, 2005 4:52 pm Reply with quote

Hi all i think the problem lays in he [L] for (it stops when the string matches)
its the [L] on some ones it doesnt accept it

as in the ones representing the module itself may cauz problems,
removing the L should fix it on those ones

_________________
All we want is knowledge.
And if knowledge is power .
We should be considered dangerous.
<b>Beware of false knowledge;
it is more dangerous than ignorance</b> Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Visit poster's website
hitwalker
Sells PC To Pay For Divorce


Joined:
Posts: 5661

PostPosted: Tue Jul 12, 2005 4:57 pm Reply with quote

hi...nice of you to drop by......lol

well in the install says...Thats its optinonal !

speedtype>>Optional Tweak for .htaccess file<<<<<<<<<<<

- Find all RewriteRule statements and append [L] at the end, for example
#AvantGo
RewriteRule ^avantgo-print-([0-9]*).html modules.php?name=AvantGo&file=print&sid=$1
RewriteRule ^avantgo.html avantgo.html

Would now become
#AvantGo
RewriteRule ^avantgo-print-([0-9]*).html modules.php?name=AvantGo&file=print&sid=$1 [L]
RewriteRule ^avantgo.html avantgo.html [L]

- Do all RewriteRules, this will help save resource time, the [L] tell mod_rewrite to stop rewriting once a match has been found.
By default it will go down the entire RewriteRule list until attempting to rewrite it over and over again even though you
may have already found a match, this will help circumvent that. Smile
 
View user's profile Send private message
VinDSL
Life Cycles Becoming CPU Cycles


Joined: Jul 11, 2004
Posts: 614
Location: Arizona (USA) Admin: NukeCops.com Admin: Disipal Designs Admin: Lenon.com

PostPosted: Tue Jul 12, 2005 5:03 pm Reply with quote

hitwalker wrote:
Well all his attention goes to his family and stuff so he dropped the whole stuff.
And he doesnt have the time..
He says he will try to give it some attention again but i have my doubts..

Hrm…

Okay, now I have a question for you...

If 0.4 is working for you, why do you want to upgrade to 0.4a - arguably an orphaned (and obviously bug-ridden) release?

_________________
.:: "The further in you go, the bigger it gets!" ::.
.:: Only registered users can see links on this board! Get registered or login! | Only registered users can see links on this board! Get registered or login! ::.

Last edited by VinDSL on Tue Jul 12, 2005 5:07 pm; edited 1 time in total 
View user's profile Send private message Visit poster's website ICQ Number
Nuke_Royal
PostPosted: Tue Jul 12, 2005 5:05 pm Reply with quote

lol i think i ve been reading to fast.
i thought it wasnt working
and i thought u might had those Ls bothering you.

yes it is opcional,and i use it myself too but on someones i had to take the L off else i got a page not found 404


good luck
 
hitwalker
PostPosted: Tue Jul 12, 2005 5:08 pm Reply with quote

Yeah well thats why we have testsites...
And for vin..
...nice question vin...lol
Why do we update nuke ?

As the author writes..

This is a release to upate the NExtGEn framework to accurately propagate module names. Some modules are very stubborn indeed! 0.4a also allows you to convert your blocks on the fly, Not recommended because of resources, but nonetheless still an option Wink

That was on 15-Jun-2004
 
VinDSL
PostPosted: Tue Jul 12, 2005 5:09 pm Reply with quote

Nuke_Royal wrote:
lol i think i ve been reading to fast...

LoL! You been drinking too?
 
VinDSL
PostPosted: Tue Jul 12, 2005 5:10 pm Reply with quote

hitwalker wrote:
Yeah well thats why we have testsites...
And for vin..
...nice question vin...lol
Why do we update nuke ?

Heh! I'm just asking...

I enjoy a challenge as much as anyone. I just wanted to make sure we're on the same page! Very Happy
 
hitwalker
PostPosted: Tue Jul 12, 2005 5:13 pm Reply with quote

well it keeps me busy as well,and other to i think.,...lol
 
VinDSL
PostPosted: Tue Jul 12, 2005 5:18 pm Reply with quote

Yeah, I have a fertive mind too. That's what drives me, I guess - a fear of boredom...

So, this begs the question, "Since Bill isn't interested in picking up the torch, should one of us continue his work?"
 
64bitguy
The Mouse Is Extension Of Arm


Joined: Mar 06, 2004
Posts: 1159
Location: Sanbornton, NH USA

PostPosted: Tue Jul 12, 2005 5:18 pm Reply with quote

I went round and round with things like this with someone else once and I can't recall how many different ways to do there are, but it is really a "depends on how you have your hosting" setup scenario. A quick google search yeilded this post that might help.
Only registered users can see links on this board! Get registered or login!

_________________
Steph Benoit Only registered users can see links on this board! Get registered or login!
1CMS, 100% Section 508 and W3C XHTML/CSS Compliant (Truly) 
View user's profile Send private message Visit poster's website
hitwalker
PostPosted: Tue Jul 12, 2005 5:23 pm Reply with quote

hi steph,i appreciate your input but if i use the 0.4 version i have no problem at all !
So whats that different in the 0.4a ?
If it was anyway related to as the HOW my hosting is set up ? then i believe it shouldnt work at all..
But with the 0.4 it simply works..that is whats bugging me...
 
64bitguy
PostPosted: Tue Jul 12, 2005 5:36 pm Reply with quote

Well, I think i've asked this like twice already but WHAT VERSION OF NUKE IS THIS?

The reason for potential problems in a sub-domain with a replicated version is that if you have the same conditions in rules in another domain and no "RewriteBase" you are going to inherit rules.
 
hitwalker
PostPosted: Tue Jul 12, 2005 5:43 pm Reply with quote

Version..?
well with the link to download the files i also wrote :

"And the files are from nuke 7.6.0 patched 3.0c"
 
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Tue Jul 12, 2005 6:17 pm Reply with quote

boxing
 
View user's profile Send private message
hitwalker
PostPosted: Tue Jul 12, 2005 6:20 pm Reply with quote

ha...ha......ha....... Groovy
 
64bitguy
PostPosted: Tue Jul 12, 2005 8:20 pm Reply with quote

There wasn't any GoogleTap code in the mainfile that you zipped.

I recoded it with the GT NextGen 0.4a functions. Look for my comments in that code!

Here it is: Only registered users can see links on this board! Get registered or login!
 
hitwalker
PostPosted: Wed Jul 13, 2005 3:50 am Reply with quote

well steph,
the big file i posted had the code in it.
the file is packed didnt.
so il give this a try...
thanks.. Smile
 
dean
Worker
Worker


Joined: Apr 14, 2004
Posts: 193

PostPosted: Sat Jul 16, 2005 11:31 pm Reply with quote

Indeed what is wrong. After installing it at lease a dozen times and helping others do the same I find myself in a quandry. I just got done upgrading one of my nuke 7.3 sites to 3.0b patched and reinstalled GT NextGen 0.4a without a hitch.

Then I come to my other nuke 7.3, also upgrading it to 3.0b patch. Patch works fine but when I upload my GT NextGen edited main, header and footer files the site vanishes, poof, just like that. The edited files are identical to the patch ones except for the Sentinel and GT Next Gen edits.

I would be appreciative to the point of making a donation to someone who would look over my shoulder. I'm losing sleep over these upgrades and I may not be thinking clearly. Heres my files Only registered users can see links on this board! Get registered or login! and the site is located at Only registered users can see links on this board! Get registered or login!. You can see that the htaccess code is still working properly if you use the top navigation.
 
View user's profile Send private message
dean
PostPosted: Sun Jul 17, 2005 12:08 am Reply with quote

Ah, I found the problem......... I deactivated all of the blocks and restarted them each one at a time. The Total Hits block included with the patch files is what caused the site to stop working. Heres the pesky short file:
Code:
if ( !defined('BLOCK_FILE') ) {

    Header("Location: ../index.php");
    die();
}

global $nukeurl, $prefix, $startdate, $db;

$row = $db->sql_fetchrow($db->sql_query("SELECT count FROM ".$prefix."_counter WHERE type='total' AND var='hits'"));
$content = "<font class=\"tiny\"><center>"._WERECEIVED."<br><b><a href=\"stats.html\">$row[0]</a></b><br>"._PAGESVIEWS." $startdate</center></font>";

?>


Ack for some reason the forum converts the module name to its html equivalent. Anyway you get the idea.

Interestingly this one worked just fine prior to the site going googletap.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> GT - Next Gen and Standard

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©