Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> phpnuke 7.8
Author Message
robsscanner
New Member
New Member



Joined: Nov 17, 2004
Posts: 9

PostPosted: Sun Jun 05, 2005 5:59 am Reply with quote

Error

SQL-query :

CREATE TABLE nuke_authors(

aid varchar( 25 ) NOT NULL default '',
name varchar( 50 ) default NULL ,
url varchar( 255 ) NOT NULL default '',
email varchar( 255 ) NOT NULL default '',
pwd varchar( 40 ) default NULL ,
counter int( 11 ) NOT NULL default '0',
radminsuper tinyint( 1 ) NOT NULL default '1',
admlanguage varchar( 30 ) NOT NULL default '',
PRIMARY KEY ( aid ) ,
KEY aid( aid )
)ENGINE = MYISAM

MySQL said:


#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ENGINE=MyISAM' at line 12
 
View user's profile Send private message
Manuel
Regular
Regular



Joined: May 28, 2005
Posts: 90

PostPosted: Sun Jun 05, 2005 6:09 am Reply with quote

should be:

Quote:

DROP TABLE IF EXISTS `nuke_authors`;
CREATE TABLE `nuke_authors` (
`aid` varchar(25) NOT NULL default '',
`name` varchar(50) default NULL,
`url` varchar(255) NOT NULL default '',
`email` varchar(255) NOT NULL default '',
`pwd` varchar(40) default NULL,
`counter` int(11) NOT NULL default '0',
`radminsuper` tinyint(1) NOT NULL default '1',
`admlanguage` varchar(30) NOT NULL default '',
PRIMARY KEY (`aid`),
KEY `aid` (`aid`)
) TYPE=MyISAM;


... engine instead of type? mmm...

_________________
Image 
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
robsscanner







PostPosted: Sun Jun 05, 2005 6:12 am Reply with quote

all the tablesin the sql file have ENGINE = MYISAM in them...... not ) TYPE=MyISAM;
 
Manuel







PostPosted: Sun Jun 05, 2005 6:17 am Reply with quote

so my sql doesn't work too?
this is strange because the #1064 say that you have an error near 'ENGINE=MyISAM'

also try to add ; at the end of line
 
Raven
Site Admin/Owner



Joined: Aug 27, 2002
Posts: 17087

PostPosted: Sun Jun 05, 2005 7:37 am Reply with quote

Make sure you have applied thi [ Only registered users can see links on this board! Get registered or login! ] .
 
View user's profile Send private message
robsscanner







PostPosted: Sun Jun 05, 2005 7:03 pm Reply with quote

i have applyed that fix sitll get the error it will not ever upload the sql file ......

Code:
Error 


SQL-query :

CREATE TABLE nuke_authors(

aid varchar( 25 ) NOT NULL default '',
name varchar( 50 ) default NULL ,
url varchar( 255 ) NOT NULL default '',
email varchar( 255 ) NOT NULL default '',
pwd varchar( 40 ) default NULL ,
counter int( 11 ) NOT NULL default '0',
radminsuper tinyint( 1 ) NOT NULL default '1',
admlanguage varchar( 30 ) NOT NULL default '',
PRIMARY KEY ( aid ) ,
KEY aid( aid )
)ENGINE = MYISAM

MySQL said:


#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ENGINE=MyISAM' at line 12
 
Raven







PostPosted: Sun Jun 05, 2005 7:18 pm Reply with quote

That code works perfectly for me. Try just running that code alone in an SQL window in phpMyAdmin.
 
robsscanner







PostPosted: Sun Jun 05, 2005 7:26 pm Reply with quote

i have changed ENGINE = MYISAM to TYPE=MyISAM but this forums admin is blank now, this newest version is a hunk of junk ......
 
Raven







PostPosted: Sun Jun 05, 2005 7:33 pm Reply with quote

Leave it as engine. Did you try what I suggested? What server version of MySQL are you using?
 
robsscanner







PostPosted: Sun Jun 05, 2005 7:43 pm Reply with quote

4.0.23_Debian-4-log no still get the error when its ENGINE = MYISAM
but when i use TYPE=MyISAM it works but no forums




when do you think you will have a patch for 7.8
 
Raven







PostPosted: Sun Jun 05, 2005 9:22 pm Reply with quote

For the third time! Did you try what I suggested - running the code as stand alone?
 
robsscanner







PostPosted: Sun Jun 05, 2005 10:19 pm Reply with quote

yes i still get the same result
 
Raven







PostPosted: Mon Jun 06, 2005 4:23 am Reply with quote

I would need to have access to your phpMyAdmin to debug any further. PM me the login information if you want me to debug.
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> phpnuke 7.8

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©