Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
California
Hangin' Around


Joined: Mar 24, 2005
Posts: 28

PostPosted: Mon May 16, 2005 4:07 pm Reply with quote

This line of code is preventing the use of $id as a variable in your system.

includes/sentinel.php
Code:
Starting line 24:

$tmp=explode(",",$bad_uri_content);
while(list($id,$uri_content)=each($tmp)) {
   if (strpos($REQUEST_URI,$uri_content)) {
      die("Illegal Content");
   }
}


Can I modify or delete this so I can use the $id variable and still have protection?
 
View user's profile Send private message
BobMarion
Former Admin in Good Standing


Joined: Oct 30, 2002
Posts: 1037
Location: RedNeck Land (known as Kentucky)

PostPosted: Mon May 16, 2005 8:19 pm Reply with quote

Your using an older version of NukeSentinel. That was changed to $spid awhile back Smile

_________________
Bob Marion
Codito Ergo Sum
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
California
PostPosted: Tue May 17, 2005 2:03 am Reply with quote

BobMarion wrote:
Your using an older version of NukeSentinel. That was changed to $spid awhile back Smile


I am running NukeSentinel 2.2.1

I looked at the last three upgrades I did and none of them included a new sentinel.php (including 2.2.1) so where do I get the correct sentinel.php?

I tried including nukesentinel.php from my mainfile instead of sentinel.php thinking that was the problem but it just gave me an error saying to insert the code for sentinel.php in mainfile when I tried to access the nukesentinel administration area.

I am also running 3.0 patched series.
 
BobMarion
PostPosted: Wed May 25, 2005 12:23 am Reply with quote

sentinel.php changed to nukesentinel.php . From the readme:
Code:
SPECIAL NOTES:

This version has changed filenames from sentinel.xxx to nukesentinel.xxx for
clarity. For this reason you will need to remove all old NukeSentinel(tm) files
once you install and link the new NukeSentinel(tm) files.
 
California
PostPosted: Wed May 25, 2005 4:28 am Reply with quote

Ok. Thanks for the verification. I suspected that was the problem. I will go back and check everything again.
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©