Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™
Author Message
GeoffM
New Member
New Member


Joined: May 19, 2004
Posts: 21
Location: Bellingham, WA.

PostPosted: Tue Dec 14, 2004 11:38 am Reply with quote

No, nor did I see that instruction in the readme or else where- by "encrypted" do you mean a copy of the password that MySQL stores? or do I now need to get an encrytion program to generate encryted passwords? such things should be in the installation section of the module - I have pretty straight forward PHPNukes installed on industry standard linux hosting platforms most of the troubles I have with installing mod's are my own ineptude adding code (ie not following instructions) or version mismatches - this just seems incomplete to me, but lessons learn now I now what to do with it adding it to my othersite and having had all of them hacked at one time or another I do appreciate this mod to no end.

_________________
Webmaster Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login! Only registered users can see links on this board! Get registered or login!

All Sites use PHP-Nuke 7.3 and up 
View user's profile Send private message Visit poster's website
BellorAnima
New Member
New Member


Joined: Dec 09, 2004
Posts: 12

PostPosted: Wed Dec 15, 2004 9:08 pm Reply with quote

I could have sworn that I already replied to this...

Yes, I entered the usernames and passwords into the .staccess file. I had Sentinel build both of the files, I didn't do it manually.
 
View user's profile Send private message
BobMarion
Former Admin in Good Standing


Joined: Oct 30, 2002
Posts: 1037
Location: RedNeck Land (known as Kentucky)

PostPosted: Wed Dec 15, 2004 11:00 pm Reply with quote

GeoffM - NukeSentinel(tm) uses two types of encryption. One type is for the db storage and the other is for the .staccess storage.

BellorAnima - NukeSentinel(tm) will write the login info to the .staccess, provided you have it set to CGIAuth, whenever you make a change to the admin's protected status or password.

_________________
Bob Marion
Codito Ergo Sum
Only registered users can see links on this board! Get registered or login! 
View user's profile Send private message Send e-mail Visit poster's website
dotlr
New Member
New Member


Joined: Dec 16, 2004
Posts: 1

PostPosted: Thu Dec 16, 2004 9:50 am Reply with quote

how do you do that Raven? i'm having an admin loop and can't get into admin at all. comes up with there are no admins created yet, soi create one, then takes me to the log in for admin, try to log in with the god i just made and takes me straight back to there are none created yet. HELP!
 
View user's profile Send private message
montego
Site Admin


Joined: Aug 29, 2004
Posts: 9449
Location: Arizona

PostPosted: Fri Dec 24, 2004 10:56 am Reply with quote

I am having similar issues with 2.1.2 install on 7.5 with 2.8 patches. No matter what I try, I cannot get passed the login box. My PHP / Apache is NOT running as CGI so I was simply trying to use HTTP Auth. I have tried it with and without an .htaccess file (my test servers are Windows XP running with Apache). I have never had these issues with 2.0.2. I even copied my previous 2.0.2 based .htaccess file (which had nothing written in it by the way) and 2.1.2 HTTP Auth still does not work.

At this point, I have run out of ideas and have almost given up on trying to get 2.1.2 working, but that is a big shame because everything else is working great! I just can't run without protecting the admin module!

Any ideas?

TIA,
montego
 
View user's profile Send private message Visit poster's website
GeoffM
PostPosted: Fri Dec 24, 2004 1:11 pm Reply with quote

montego wrote:
........Any ideas?

TIA,
montego


I decided not to use the admin login part for now


Last edited by GeoffM on Fri Dec 24, 2004 2:00 pm; edited 1 time in total 
BobMarion
PostPosted: Fri Dec 24, 2004 1:37 pm Reply with quote

I will be taking time next week to look back over a few trouble spots in the code that have been reported and will take a close look at the HTTPAuth. Strange thing is nothing in that section of the code changed Sad
 
montego
PostPosted: Fri Dec 24, 2004 2:47 pm Reply with quote

Not sure how I lost it or if maybe my hosting company changed someone on me, but I fixed the problem by ensuring I had NO extra spaces at the end of config.php and mainfile.php AND added the following to my .htaccess file:

PHP_FLAG output_buffering On

Again, have no idea why it changed all of a sudden.

Regards,
Rob
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> NukeSentinel™

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©