Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke
Author Message
Muffin
Client


Joined: Apr 10, 2004
Posts: 649
Location: UK

PostPosted: Thu Nov 25, 2004 10:29 pm Reply with quote

I'm getting some code in my forums that I can't suss out.

I updated my site tonight with Chat's latest patched files to see if it cleared it but it didnt.

here's what I'm getting:

Quote:
Under Home Downloads Your Account Forums menu and before mCm Forums (in my theme and all other themes on my site)

Warning: Cannot modify header information - headers already sent by (output started at /home/minicity/public_html/nuke/html/header.php:34) in /home/minicity/public_html/nuke/html/includes/sessions.php on line 372

Warning: Cannot modify header information - headers already sent by (output started at /home/minicity/public_html/nuke/html/header.php:34) in /home/minicity/public_html/nuke/html/includes/sessions.php on line 373


Between Forums head and FAQ Search Memberlist etc menu

Warning: Cannot modify header information - headers already sent by (output started at /home/minicity/public_html/nuke/html/header.php:34) in /home/minicity/public_html/nuke/html/includes/page_header.php on line 494

Warning: Cannot modify header information - headers already sent by (output started at /home/minicity/public_html/nuke/html/header.php:34) in /home/minicity/public_html/nuke/html/includes/page_header.php on line 496

Warning: Cannot modify header information - headers already sent by (output started at /home/minicity/public_html/nuke/html/header.php:34) in /home/minicity/public_html/nuke/html/includes/page_header.php on line 497



I'm using FireFox, I dont get it using IE

And I dont see it on this forum or any other Nuke forum just my own.

It's driving me nutz lol

Can anyone tell me what's happening?

I use Onspeed to go thru their servers and back to my browser to speed up my really slow internet connection, but I dont think it's that because it doesnt affect any other nuke forum I go onto just mine.

Here's my url if anyone wants to take a looksee if they use FireFox as well. Only registered users can see links on this board! Get registered or login!

You need to register to view the forums by the way.

Thanks

_________________
Classic Mini rules the bends & bends the rules!
[img] 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Thu Nov 25, 2004 10:41 pm Reply with quote

Have you tried this?
Only registered users can see links on this board! Get registered or login!
 
View user's profile Send private message
Muffin
PostPosted: Thu Nov 25, 2004 11:06 pm Reply with quote

Thanks Raven for the speedy reply.

I dont have access to php.ini so couldnt use that option.

I tried
Quote:
else copy the following into a file:
PHP_FLAG output_buffering On
save it as .htaccess and upload to the same place mainfile.php is located.


and I got a 404 page

so then tried the last option

Quote:
Or add the following line to mainfile.php right after the file credits:
ini_set("output_buffering","1");


and that didnt help either

when I added ini_set("output_buffering","1"); immediately after the credits I tried it after the top credits and the ones at the bottom, neither worked.

I don't know why they didnt work I'm afraid I don't know enough about scripting, is there anything else I could try?
 
Raven
PostPosted: Fri Nov 26, 2004 10:48 am Reply with quote

Muffin, make sure your file was named .htaccess (note the dot). Place that in the same folder as your mainfile.php
 
Muffin
PostPosted: Fri Nov 26, 2004 12:51 pm Reply with quote

Hi Raven

I emailed Hostroute and they modified the php.ini file for me so the error messages are gone now.

Thanks for your help though. {{{{{hugs}}}}}
 
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Fri Nov 26, 2004 1:27 pm Reply with quote

Nice not every host is willing to even consider they can improve the servers configuration! Let alone actually make an adjustment for a "consumer". <~ New politically correct term for client.

_________________
[b][size=5]openSUSE 11.4-x86 | Linux 2.6.37.1-1.2desktop i686 | KDE: 4.6.41>=4.7 | XFCE 4.8 | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
| GeForce 6200@433Mhz 512MB | Xorg 1.9.3 | NVIDIA 270.30[/size:2b8 
View user's profile Send private message
Muffin
PostPosted: Fri Nov 26, 2004 5:14 pm Reply with quote

lol Don't tell me you're politically correct Six

I think Hostroute are feeling a bit guilty lately as they've had so many DoS attacks and server problems that my site's been offline quite a lot lately. So they are trying to impress me I think with their customer support efficiency.

I've been with them for 5yrs and their support has always been good, but the last 12 mths has been a headache with the server problems.
 
Raven
PostPosted: Fri Nov 26, 2004 6:33 pm Reply with quote

I'm still waiting for you to move here Smile
 
Muffin
PostPosted: Fri Nov 26, 2004 6:57 pm Reply with quote

Well when the hosting is up for renewal Raven I will.

I wont have all these little problems then on your servers. hehehe
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Security - PHP Nuke

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©