Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks
Author Message
Bigboy177
Worker
Worker


Joined: Jul 07, 2004
Posts: 192

PostPosted: Sun Oct 24, 2004 6:27 pm Reply with quote

I wanted to put slider into my blocks... I've decided to use div as was shown in the user info block... But something terrible happens when I put align in it... My block is getting wider everytime I highlight a link in it...
But it only happens in mozilla...

Here Is the code... I'm using... for the block...

Code:


<?php


if (eregi("block-Scroll.php",$_SERVER['PHP_SELF'])) {
    Header("Location: index.php");
    die();
}

global $prefix, $multilingual, $currentlang, $db;
       $content .= "<DIV STYLE=\"overflow: auto; width: 200px; height: 150;
border-left: 0px gray solid; border-bottom: 0px gray solid;
border-right: 0px gray solid; border-top: 0px gray solid;
padding:0px; margin: 0px \">";
       $result1 = $db->sql_query("SELECT pid, title FROM ".$prefix."_cnb_pages ORDER BY pid DESC LIMIT 0,10");
while ($row1 = $db->sql_fetchrow($result1)) {   
$baza = $row1['title'];
$bazapid = $row1['pid'];
       $content .= "<table width=\"150\"><td align=\"left\"><a href=modules.php?name=Conteudo&pa=showpage&pid=$bazapid><strong><big>&middot;</big></strong>$baza</a></td></table>";
    }   

       $content .= "</DIV>";
?>


When I put align in the code, so it looks like this:
Code:


$content .= "<DIV STYLE=\"overflow: auto; align=center width: 200px; height: 150;
border-left: 0px gray solid; border-bottom: 0px gray solid;
border-right: 0px gray solid; border-top: 0px gray solid;
padding:0px; margin: 0px \">";

Everything goes crazy...
Can someone help please... Sad

_________________
Only registered users can see links on this board! Get registered or login!

Last edited by Bigboy177 on Wed Oct 27, 2004 6:57 pm; edited 1 time in total 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17086

PostPosted: Sun Oct 24, 2004 9:18 pm Reply with quote

I believe this
align=center width:

should be
text-align=center; width:
 
View user's profile Send private message
Bigboy177
PostPosted: Mon Oct 25, 2004 6:31 am Reply with quote

Raven wrote:
I believe this
align=center width:

should be
text-align=center; width:


It didn't help... Maybe there's another way to do sliders in a block... and maybe it won't cause problems in mozilla... Smile


Last edited by Bigboy177 on Wed Oct 27, 2004 6:57 pm; edited 1 time in total 
Bigboy177
PostPosted: Mon Oct 25, 2004 7:42 am Reply with quote

I've modified the file on my site so you can see what I mean...

Here is the address:
Only registered users can see links on this board! Get registered or login!

In Opera and in IE everything is OK... But when I load my site in Mozilla or Firefox... News are formatted in wrong possitions, and when you highlight a link in one of the NSN Center Blocks... the block goes crazy... I hope you will be able to help... Smile
 
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Mon Oct 25, 2004 8:39 am Reply with quote

Looks to me like you have a table for each block there inside a div? Try using one table with 3 columns set the width of the table as 100% and then set the <td width as 33% for each column. This is pretty basic html and a quick search or read of a editors help file should help you out greatly. I don't think Mozilla likes the alignment attribute of the <div tag at least thats been my experience. The going crazy seems to be a size/length issue with the links when I mouse over a link there it changes color and goes bold/underline try removing the bold once and see if that helps.

_________________
[b][size=5]openSUSE 11.4-x86 | Linux 2.6.37.1-1.2desktop i686 | KDE: 4.6.41>=4.7 | XFCE 4.8 | AMD Athlon(tm) XP 3000+ | MSI K7N2 Delta-L | 3GB Black Diamond DDR
| GeForce 6200@433Mhz 512MB | Xorg 1.9.3 | NVIDIA 270.30[/size:2b8 
View user's profile Send private message
Bigboy177
PostPosted: Mon Oct 25, 2004 12:01 pm Reply with quote

Thanks for help... Now it works like it should... Smile
 
Display posts from previous:       
Post new topic   Reply to topic    Ravens PHP Scripts And Web Hosting Forum Index -> Blocks

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©