Ravens PHP Scripts: Forums
 

 

View next topic
View previous topic
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's v7.0 Customized Distro
Author Message
sharlein
Member Emeritus


Joined: Nov 19, 2002
Posts: 322
Location: On the Road

PostPosted: Wed Apr 28, 2004 8:08 pm Reply with quote

Hi, I am getting this error when i try to load the site. I am also using chatserve's package for 7.0.
Code:
Parse error: parse error in /home/silvias/public_html/Nuke/html/mainfile.php on line 1105


Fatal error: Call to a member function on a non-object in /home/silvias/public_html/Nuke/html/index.php on line 21
Line 1105 is the closing line for the mainfile and line 21 in the index.php is
Code:
$row = $db->sql_fetchrow($db->sql_query("SELECT main_module from ".$prefix."_main"));
 
View user's profile Send private message
Raven
Site Admin/Owner


Joined: Aug 27, 2002
Posts: 17077

PostPosted: Wed Apr 28, 2004 9:15 pm Reply with quote

That's probably not the problem. It's probably a syntax error up higher. Your site was working. What have you changed?
 
View user's profile Send private message
sharlein
PostPosted: Wed Apr 28, 2004 10:33 pm Reply with quote

Raven, it is on the new site, Only registered users can see links on this board! Get registered or login!
 
Raven
PostPosted: Thu Apr 29, 2004 4:54 am Reply with quote

The hackalert code you pasted was missing a closing } Smile. Let me know if there is a post you copied that from that is missing the }
 
sharlein
PostPosted: Thu Apr 29, 2004 6:15 am Reply with quote

The one in the mainfile I copied from your first post earlier this week, the testing proposal, before the note was added. But I'm sure it was my error - the other two sites did not get this error. Thank you very much. Very Happy
 
sharlein
PostPosted: Tue Jun 01, 2004 5:12 pm Reply with quote

I can't log into any of my sites. I am greeted with this error
Code:
Parse error: parse error, unexpected T_STRING in /home/brokenpe/public_html/Nuke/html/modules/Your_Account/index.php on line 771

and on mine
Code:
Parse error: parse error, unexpected T_STRING in /home/sharlein/public_html/modules/Your_Account/index.php on line 754

and on the third
Code:
Warning: main(modules/Your_Account/navbar.php): failed to open stream: No such file or directory in /home/silvias/public_html/Nuke/html/modules/Your_Account/index.php on line 28


Warning: main(): Failed opening 'modules/Your_Account/navbar.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/silvias/public_html/Nuke/html/modules/Your_Account/index.php on line 28

The first two errors are including the header, and the last is including the navbar. As near as i can tell, it happened around the same time I installed Sentinel. Thank you, steve
 
sixonetonoffun
Spouse Contemplates Divorce


Joined: Jan 02, 2003
Posts: 2496

PostPosted: Tue Jun 01, 2004 6:30 pm Reply with quote

Did you use one copy of Your_Account index.php for all the sites so the same error might have come from one file?
 
View user's profile Send private message
Raven
PostPosted: Tue Jun 01, 2004 6:32 pm Reply with quote

Steve,

On line 752 you have the following
Code:
$userinfo = getusrinfo($user);"
Note that extra " at the end Wink ?
 
sharlein
PostPosted: Tue Jun 01, 2004 8:59 pm Reply with quote

Yes, Raven. everything works fine when I removed it in all of the instances. Just so happens I did the your_account mods the same day I installed Sentinel. I'm sorry. Thank you very much.
 
Raven
PostPosted: Tue Jun 01, 2004 9:44 pm Reply with quote

Laughing No problem my friend!
 
hireamerica
Client


Joined: Sep 30, 2004
Posts: 103
Location: New Jersey

PostPosted: Thu Sep 30, 2004 2:18 pm Reply with quote

I might have posted elsewhere, but now this seems the place:

Sentinel 2.0.1 was perfecto Raven! I just tried to go to 2.0.2 and the tables upgraded just fine and all was well.

I noticed the mainfile.php changes and those errored, so I did a simple include of sentinel.php and that works.

But in the 4 your_account changes I'm getting unexpected { found where I made the first change. Presumably I'd get it in the other 3, but I just can't seem to find the issues.

The replaced code is simple and atomic with a simple function and if ... {
The replacement code is also simple with 2 functions and an if ... {

So I'm not sure why the unexpected { now...

Quote:

cookiedecode($user);
getusrinfo($user);
if ( (is_user($user) AND ($userinfo[username] == $cookie[1]) AND ($userinfo[user_password] == $cookie[2]) ) {
 
View user's profile Send private message Visit poster's website Yahoo Messenger
hireamerica
PostPosted: Thu Sep 30, 2004 2:26 pm Reply with quote

Uggh... missed the )) afer the is_user

Fixed and working... my bad.
 
Raven
PostPosted: Thu Sep 30, 2004 2:28 pm Reply with quote

You've made a slight typo. You have
Code:
if ( (is_user($user) AND ($userinfo[username] == $cookie[1]) AND ($userinfo[user_password] == $cookie[2]) ) {
and it should be
Code:
if ((is_user($user)) AND (strtolower($userinfo[username]) == strtolower($cookie[1])) AND ($userinfo[user_password] == $cookie[2])) {
 
Raven
PostPosted: Thu Sep 30, 2004 2:29 pm Reply with quote

Posts crossed Laughing
 
Display posts from previous:       
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    Ravens PHP Scripts And Web Hosting Forum Index -> Raven's v7.0 Customized Distro

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum


Powered by phpBB © 2001-2007 phpBB Group
All times are GMT - 6 Hours
 
Forums ©